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Introduction to ActivePresenter 

ActivePresenter is an ultimate eLearning tool plus advanced screencasting and video editing 

features. With ActivePresenter, you can create various eLearning content types including 

video demos, software simulations, quizzes, eLearning games. Supporting responsive design, 

HTML5 technology and the ability to create different scenarios with interactivity features, 

ActivePresenter is the best tool for creating any eLearning courses.  

Common Concepts 

Screencasting 

Screencasting (also recording screen) implies a process when you record any activity on the 

computer screen. The result you receive is a so-called screencast. In other words, if you record 

screen, you have a screencast.  

Screencasting is different from capturing screen as screenshots. A screenshot is a photo of 

your screen while a screencast is a video of your screen. 

In ActivePresenter, a screencasting process has the following steps: 

1. Recording 

You work with the target application and record the screen. The outcome is a video or 

a series of slides. 

2. Editing and annotating 

You edit the video or slideshow. Then, add shapes, commentary, images, audio/video 

clips, etc.  

3. Adding interactivity (optional) 

You have a choice to insert interactive elements into the video or slideshow. These 

interactive elements may be interactive objects and questions. Besides, you can 

define how the presentation should respond to user inputs, for example, when users 

give a correct answer or press a key on the keyboard.  

4. Exporting (rendering) 

In this step, you render the output which is equivalent to exporting a file. In 

ActivePresenter, the outputs fall into three different categories as shown below: 

o Interactive presentation: HTML5 (viewable in a browser) 

o Video (with audio) 

o Documents: Image, HTML Slideshow, PDF, Word, Excel, and PowerPoint 
5. Making an actual delivery  

The actual delivery may be in a classroom setting (on a projector). It can also be made 

via a remote network where learners use their browsers to go through the presentation 

and/or read the documents using a PDF reader or Microsoft Office/LibreOffice.   
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HTML5 

HTML5 is the latest version of Hypertext Markup Language, which allows displaying and 

interacting with webpages. Not only web developers and browser creators but desktop and 

mobile visitors can also benefit from HTML5 thanks to better, faster, and more consistent web 

experiences.   

If you want to create contents which can run on various platforms and devices, consider using 

HTML5 output in ActivePresenter.  

Software Simulation 

A software simulation is an animated model which mimics the key functions and operations of 

your software. Using software simulations is a good strategy to show your customers and/or 

target audience how a feature of your program works. With ActivePresenter, you can easily 

create interactive software simulations.  

Quiz 

In the education context, quizzes are usually used to assess learners’ performance. In 

essence, a quiz may contain a series of questions with different types such as multiple choice, 

fill in the blank, and true/false. Meanwhile, a question is a statement with many options (like a 

multiple response question) or an examination that requires a written explanation or analysis 

in a sentence or a short paragraph (like an essay question). 

Responsive Design 

Responsive design is a method of designing web content, which uses flexible layouts, flexible 

images, and cascading style sheet media queries. The purpose of responsive design is to 

create web content that can detect visitors’ screen size and orientation. Then, change the 

layout accordingly. Simply put, using this design philosophy, web content automatically 

appears in their optimized form on all devices, even smartphones and tablets. ActivePresenter 

provides responsive design features so you can create eLearning courses which adapt to any 

devices at once. 

LMS, SCORM, and Experience API (xAPI) 

LMS 

The outputs produced by ActivePresenter can be hosted on an LMS as an online course. 

Basically, LMS stands for Learning Management System, which allows you to create, track, 

manage, and distribute any kind of learning materials. Besides online learning delivery, LMS 

also offers a range of other applications. For example, it acts as a platform for fully online 

courses and many hybrid forms like blended learning and flipped classrooms.  

SCORM 

SCORM means Shareable Content Object Reference Model. Developed by ADL Initiative, 

SCORM contains a set of technical standards, and its goal is to ensure that eLearning contents 

fully integrate with an LMS. Currently, there are four SCORM versions: SCORM 1.0, SCORM 
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1.1, SCORM 1.2, and SCORM 2014. In terms of SCORM 2014, this version has several 

different editions as well.  

Experience API (xAPI) 

Experience API (xAPI or also known as Tin Can API) is an open source API, the next 

generation of SCORM, with many new features. For instance, xAPI has a facility to view in-

depth assessment results, track offline learning and report multiple scores. In addition, xAPI 

doesn’t rely on any web browser, Internet connection and LMS to work. 

See The Difference Between SCORM and xAPI for more information.

ActivePresenter User Interface 

Start Page  

The Start Page gives you an easy and quick access to recording, creating a new project, 
opening recent projects as well as other resources such as samples and templates.  

When you first open ActivePresenter, you’re greeted with a very informative Start Page as you 
can see in the picture below. During the editing phase, to access the Start Page, click the 

ActivePresenter button > Start Page . 

Keep in mind that when you don’t open or create any project file, the Start Page is also 
displayed. 

  

The Start Page has many components which are grouped into two main different areas: left 
menu and central part.  

From the left menu of the Start Page, do either of the following ways to start working with 
ActivePresenter: 

• Click Blank Project to create a new project with a blank slide. 

• Click Record Video to record screen as video. 

https://atomisystems.com/elearning/differences-between-scorm-tin-can-api-xapi/
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• Click Record Software Simulation to record a software simulation.  

• Click Responsive Project to create a new responsive project. 

• Click Import PowerPoint to create a new project with blank slides replaced by 
PowerPoint slides.  

• Click Open to open a previously created project, a slide template, a theme, an object 
template or a video file.  

• In the Recent list, ActivePresenter shows a list of recently opened projects. Do either 
of the following: 

o To re-open a project file, click it or right-click the project file > Open. 

o To remove a project file from the list, right-click it > Remove . 

o To see the location of each project file, hover over the file name or right-click the 
project file > Open Folder. 

In the center of the Start Page, there are the following three tabs. 

• Templates: This tab contains all installed themes and templates, so you can quickly 
choose one to create a new project. See Create Project from Themes or Templates 
for details. 

• Samples: This tab provides some samples that allows you quickly to know what 
ActivePresenter can do. 

• Resources: This tab provides access to some ActivePresenter resources such as: 
user manual, homepage, community, update checking, etc. 

Workspace 

ActivePresenter workspace contains three main sections: Tabbed Toolbar (1), Document 
Window (2), and Status Bar (3). 

  



ActivePresenter User Manual  Version 7 

Introduction to ActivePresenter  > ActivePresenter User Interface 15 
 

Tabbed Toolbar 

Located at the top of the application window, the Tabbed Toolbar contains almost necessary 
tools for creating and editing contents. Basically, these tools are organized into logical tabs. 
Each tab relates to a type of activity, such as inserting annotations and exporting projects. 
Most tabs like Home and Slide are visible all the time, except some contextual tabs such as 
Format and Drawing. They only appear when you are working with a particular object which 
can be edited using special options. For more information, see Menus, Toolbars & Hotkeys. 

In each tab, buttons representing commands are arranged into named groups. You can click 
any tab to see an associated set of commands.  

In addition, point to any button to display a tooltip that contains the command name, a 
description of its function, and its hotkey (if existing).  

a) ActivePresenter Button  

  

The ActivePresenter button is at the top-left of the application window. Once clicking this 
button, ActivePresenter will show the ActivePresenter Main Menu with all common file 
operations, the configuration options, and an option to access the Start Page as the picture 
below: 
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b) Standard Window Buttons & Hide/Show Toolbar Button 

Three buttons (Minimize, Maximize/Restore Down, Close) at the top-right corner of the 
Tabbed Toolbar serve the same functions as those in other applications do. You can use 
them to collapse/expand the Tabbed Toolbar. 

  

You can click the double arrow at the top-right corner of the application window to temporarily 
hide the Tabbed Toolbar. After that, only tab names are visible. To redisplay the Tabbed 
Toolbar, click the double arrow again.  
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Document Window  

ActivePresenter allows you to open multiple projects simultaneously. Then, the document 
windows are displayed in tabs, so you can navigate between them more easily. 

 

The document window has components as below: 

1. The Quick Access Toolbar contains the following tools: New, Open, Save, Undo, 
and Redo. 

2. The document tab enables you to navigate between opening documents. You can also 
hover over this tab to view the location of the project file (displayed in a tooltip), or right-
click the tab to perform some tasks such as opening the file location and saving the 
file. 

3. The Slides pane shows the list of slides in your opening project. Using the Slides 
pane, you can select a slide to edit its contents, select multiple slides to 
cut/copy/paste/delete and change the order of slides. 

4. The Canvas displays the slide. All of your spatial editing is visually done here. It shows 
captured scenes and inserted annotations/interactive objects. 

Furthermore, you can adjust the relative positions of all objects and elements in 
horizontal and vertical directions, or make a stack of objects (where objects partly/fully 
overlap) to create special effects.  

5. The Timeline pane shows the slide against time axis. Its main function is to show all 
objects against time, and let you adjust their entrance and exit times. In fact, the 
Canvas always shows the slide at a particular moment that you select in the Timeline 
with Playhead.  

The Timeline pane also lets you play the current slide to check the effect of your 
adjustments. You can play the slide for only a selected portion of the Timeline to focus 
on what happens during that slice of time. You can also play the slide and record your 
voice in real time.  
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6. The Properties pane allows you to edit almost all physical and behavioral properties 
of your selected objects either on the Canvas or in the Timeline pane. In addition, this 
is also where you create events and actions for questions, objects, and slides. 

7. The Resources pane shows all resources in project. There are two categories of 
resources in ActivePresenter: Images and Audio & Video. 

8. The Selection pane allows you to view and change the selection, lock, and visibility 
states of particular objects, groups along with their child objects in the current slide. 
You can also view the hierarchy of composite objects using this pane. 

9. The Slide Pools pane contains slide pools. Basically, a slide pool is a collection of 
slides which don’t appear directly in presentation content. Slide pools serve for the 
purpose of slide randomization which allows you to create dynamic quizzes. That is, a 
random slide is used to pick a slide in a pool randomly.   

10. The Object States pane is where you can add, edit, and remove states of an object. 
This feature brings many benefits, especially in eLearning design. Normally, an object 
always has at least a state.  

11. The Object Templates pane contains object templates. An object template may 
include objects or object groups with their properties such as layouts, colors, and 
contents. You can add objects to this pane and reuse them with ease.  

Besides, ActivePresenter allows you to create a custom workspace that best suits your 
preferences and working style. You can do that by showing, hiding, moving, docking, floating, 
and resizing all panes. For more information, see Customizing User Interface. 

Status Bar 

Across the bottom of the application window, the Status Bar displays the status of the current 
project and provides easy access to some certain functions.  

 

The current slide and the number of slides in the editing project or the current status of the 
application.  

12. Show the active slide number and the number of slides in your working project. In other 
cases, this also shows the progress of the saving process. 

13. View and change the zoom scale of the editing project with the slider and level.  

14. Use the Zoom Fit button  to adjust the zoom level to fit the space of the Canvas.

ActivePresenter Editions 

ActivePresenter offers three different editions, including Free, Standard, and Professional. 

1. The Free edition is designed for those who want to create video demonstrations. You 
have an easy access to a number of screen recording features and advanced video 
editing tools. This edition also allows you to export projects to several different video 
formats such as MP4, FLV, MKV, WebM, WMV, and AVI. However, outputs can’t be 
used for commercial purposes. 

2. The Standard edition provides all features available in the Free edition but comes with 
some differences. The first is that you can create outputs for commercial use. Besides, 
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it also supports the capabilities to export projects to document formats, including HTML 
Slideshow, PDF Document, Microsoft Word, Microsoft Excel, and PowerPoint. Some 
advanced audio and video effects are also available in this edition. 

3. The Professional edition is the most powerful one allowing you to create impressive 
video demonstrations, interactive software simulations, and eLearning contents. This 
edition is highly suitable for online learning designers, trainers, educators, technical 
supporters, and anyone who wants to create professional contents.  

Note that you can access all features of ActivePresenter professional in the free edition for 
trial purpose. The watermark will be added in non-free outputs. 

The following table compares the features between three ActivePresenter editions. The 
features which are available in all three editions are not listed: 

Feature Free 
Edition  

Standard 
Edition 

Professional 
Edition 

Commercial Use No Yes Yes 

Report & Tracking in LMS (SCORM, xAPI) No No Yes 

Export To HTML5 No No Yes 

Export To Microsoft PowerPoint No Yes Yes 

Export To Microsoft Word No Yes Yes 

Export To Microsoft Excel No Yes Yes 

Export To PDF Document No Yes Yes 

Export To Video Yes Yes Yes 

Export To Images Yes Yes Yes 

Audio Fade In, Fade Out Effects No Yes Yes 

Audio Noise Reduction No Yes Yes 

Video Blur Effect No Yes Yes 

Video Green Screen Effect No Yes Yes 
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System Requirements

Here are system requirements for running ActivePresenter 7 on Windows and macOS.

Operating 
System 

Windows 7 SP1 with Platform Update, Windows 8, and Windows 10 (All 
Editions (only 64-bit (x64) is supported). 

macOS 10.11 or later. 

Hardware CPU: 1.0 GHz or faster processor with SSE2 (which is available from 
Intel Pentium 4) (1.5 GHz recent multi-cores or higher recommended). 

At least 2GB of RAM. 

2GB of available hard-disk space for installation and storing project files. 

Sound card and microphone for audio recording. 

Software For HTML Slideshow or HTML5 playback, the following web browsers are 
supported: 

Windows 

• Mozilla Firefox 38 or later 

• Google Chrome 43 or later 

• Internet Explorer 11 

• Microsoft Edge 

macOS 

• Google Chrome 43 or later 

• Safari 8 or later 

iOS 10 (or later) 

• Safari (latest) 

Android 5.0 (or later) 

• Chrome (latest) 

For Microsoft Word Export: Microsoft Word 2013 or later. 

For Microsoft Excel Export: Microsoft Excel 2013 or later. 

For Microsoft PowerPoint Import/Export: Microsoft PowerPoint 2013 or 
later. 
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Installing ActivePresenter 

Installing Windows 

After downloading the installer, double-click it and follow instructions. To 
install ActivePresenter silently from the command line, you can use the 
/VERYSILENT flag. For example, call 
ActivePresenter_v7.0.0_setup.exe /VERYSILENT from scripts. 

macOS 

After downloading the installer, double-click it and follow instructions. 

Activating  The Free edition doesn’t need activation. To activate Standard and 
Professional editions, click Help > Activate Product or go to the Start 
Page > Activate Product. 

Updating To update an existing version of ActivePresenter, just download the latest 
version of the executable and run it by double-clicking it. There is no need 
to early on uninstall the older version.  

You can also click the Check Updates button in the Help tab or on the 
Start Page. Then, ActivePresenter will check if there are new updates and 
do the updating automatically.  

Upgrading To upgrade your license, please contact the support group. 

Uninstalling Windows 

The standard way to uninstall ActivePresenter from your computer is to 
use the Control Panel of your Windows, go to the Programs and Features 
option, select ActivePresenter from the application list, and then follow the 
instructions to uninstall. 

Alternatively, open the folder in which you’ve installed ActivePresenter, 
double-click the unins000.exe file, and then follow the instructions to 
complete the uninstallation.  

macOS 

In the Finder sidebar, click Applications, drag the app from the 
Applications folder to the Trash (located at the end of the Dock), then 
choose Finder > Empty Trash. 

 

  

https://atomisystems.com/community/
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The Multi-tier System of Support

ActivePresenter has a multi-tier system of support, as described below: 

Tooltips ActivePresenter has a tooltip system that explains the purpose of all toolbar 
buttons. Hover your mouse pointer over any button, and a short description 
will appear. 

User 
Manual 

If you press F1 at any time, a user manual (PDF file) pops up to provide the 
ultimate reference on all topics. 

Demos The best way to learn any product is to watch as someone is actually using 
it. The website provides some excellent demos.  

Tutorials You can find a vast number of tutorials which are totally educated and 
professional. 

FAQ The User Community answers all your queries. (But it is always best to first 
check whether your query is already listed in the FAQ section.) 

If you have any feature in mind, you can also post a new feature request.  

Email 
support 

If you need any help or further information about ActivePresenter, you can 
send an email to the support team.  

Phone 
support 

For urgent support needs, contact +8424-3755-8373. 

  

https://atomisystems.com/activepresenter/demo/
https://www.youtube.com/user/ActivePresenter
https://talk.atomisystems.com/c/activepresenter
https://atomisystems.com/faq/
https://talk.atomisystems.com/c/activepresenter/feature-requests
https://atomisystems.com/contact/
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Creating Projects 

Creating Blank Projects

A blank project is a project that contains blank slides where you can add contents such as 
images, video/audio clips, and slides from ActivePresenter projects or PowerPoint 
presentations, etc. 

You can also add new recorded slides to a project by recording screen as video or as 
software simulations.  

To create a blank project, on the Start Page > Blank Project. 

Alternatively, in the currently opening project, access the ActivePresenter button and click 
Blank Project. 

ActivePresenter will launch a new project with the default theme. 

By default, the new project will have one blank slide with the layout corresponding to the 

theme. You can add more slides by opening the Home tab > New Slide , or in the Slide 

tab > New Slide . The new slide will be inserted after the slide that you are selecting.  

If you want to create a new slide with a different layout, access the down arrow in the New 
Slide button and select a slide layout from the drop-down list.

Changing Slide Size 

The new project that you’ve created has the default slide size (1280x720), and you can change 
it if needed. Note that you cannot change the slide size for a responsive project.  

To change the slide size, in the Design tab > Slide Size . 

The Change Slide Size dialog will pop up as shown in the screenshot below: 
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1. Preset Size: You can choose to quickly apply one of the preset sizes from the Preset Size 
drop-down list. The list contains different sizes ranging from small to large. You can also 
specify the new size by entering values in the Width and Height spin boxes, or clicking the 
up/down arrow button to increase/decrease the size respectively. 

2. Lock Aspect Ratio: By selecting this check box, ActivePresenter will automatically change 
the height according to the width, and vice versa so that the aspect ratio can be maintained. 

The new slide size that you select can be either smaller or larger than the previous size, so 
you have further options to adjust the contents of the slides. Two cases are described in details 
in the next parts.  

3. If the new size is smaller than the current slide size, do one of the following:  

o Click the Scale to Fit button to scale the contents to fit the new slide size. 

If you select the Scale All Objects check box, all objects in slides will be scaled to fit 
the new slide size, including placeholders in slides and Slide Masters. Otherwise, 
objects will keep their original sizes which are sometimes too large in comparison with 
the new slide size. However, you can adjust their sizes after that.  

o Click the Crop button, and then click Next to crop the contents. The following dialog 
will pop up: 
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To crop a slide, drag the orange frame to the desired position. You can crop each slide 
individually or all of them at once: 

Crop each slide individually: Select the slide from the Slide list box or click the left 

arrow button  and right arrow button , and then drag the orange frame to the 
desired position.  

Crop all slides at once: Select any slide of the project, drag the orange frame to the 
desired position, and then click the Apply to All Slides button. All slides will be 
cropped at the same position.  

Note: When you choose to crop the slide in any position, objects and placeholders of 
the slide or Slide Master will not be cut. They keep their original sizes and you can 
manually drag their handles to fit the new slide size. 

4. If the new size is larger than the current slide size, do one of the following:  
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o Click the Scale to Fit button to scale the contents in order to fit the new slide size. This 
is similar to the Scale to Fit command mentioned above when the new slide size is 
smaller than the previous slide size.  

If you select the Scale All Objects check box, all objects in slides will be scaled to fit 
the new slide size, including placeholders in slides and Slide Master. Otherwise, 
objects will keep their original sizes which are sometimes too small in comparison with 
the new slide size. However, you can adjust their sizes after that.  

o Click the Fill Background button, and then select the slide position where the contents 
will fill in from the Slide Position drop-down list, and then click OK.  

Creating Responsive Projects

Responsive design in ActivePresenter allows you to create a single project which displays 
perfectly in any devices which have different screen sizes. ActivePresenter defines five default 
responsive layouts which correspond to most popular device screen sizes:  

• Desktop with the viewport of 1280x620 

• Tablet Landscape with the viewport of 1024x674 

• Tablet Portrait with the viewport of 768x930 

• Mobile Landscape with the viewport of 667x345 

• Mobile Portrait with the viewport of 375x522 

Note that the above layout sizes are not the device viewport sizes. They are chosen to make 
sure that the content displays best on popular devices. You can add a responsive layout to 
support a particular device if you want. Besides, in the responsive mode, ActivePresenter also 
supports a flexible coordinate system with percentage, pixel, and auto units so the content still 
looks good with other screen sizes which are not in the list of responsive layouts of the project. 
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To create a responsive project, launch ActivePresenter and click Responsive Project on the 
Start Page. 

Alternatively, in the currently opening project, click the ActivePresenter button and select 
Responsive Project from the drop-down list. ActivePresenter will create a project with five 
different layouts which are Desktop, Tablet Landscape, Table Portrait, Mobile Landscape, and 
Mobile Portrait. 

 

Viewport of Responsive Layout 

Screen size 

The screen size is the physical measurement diagonally of the screen in inches.  

Resolution 

The resolution is the number of pixels on the screen often displayed as a width by height (i.e. 

1024×768).  

Viewport 

Because devices with the same screen size can have very different resolutions, we use 

viewports when creating mobile friendly content. Viewports are scaled down versions of 

resolutions that allows sites to be viewed more consistently across different devices. You can 

find the viewport sizes of popular devices at https://material.io/devices (in the column with 

dp unit). 

How is the size of a responsive layout calculated in ActivePresenter? 

Viewport of the responsive layout is the actual visible area of the content when displaying in 

browser excluding the HTML5 player toolbar if any. 

For example, the Mobile Portrait is based on the viewport of iPhone 6, 7, or 8 (375x667). After 

excluding the Safari browser title and navigation bars and the HTML5 player toolbar (width: 

100%, height: 30), the layout size is 375x522. But with Mobile Landscape, Safari browser 

automatically hides the title and navigation bars so the layout size is 667x345.

https://material.io/devices/
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Managing Responsive Layouts 

Adding Layouts 

To add a new layout, click the drop-down button on the Responsive Project pane (on the top 
of document window) and select Add New.  

You can select one of the layouts provided or have a custom size by clicking Custom... and 
adjusting the size for the new layout. 

 

Removing Layouts 

To remove a layout, select it and click the drop-down button on the Responsive Project pane 
> Remove... > OK. 

Changing Layout Name 

To rename a layout, select it and click the drop-down button on the Responsive Project pane 
> Rename... > type the new name in the Name box > OK. 

Changing the Current Layout 

To switch between layouts, click the drop-down button on the Responsive Project pane > 
select a layout from the drop-down list.  

Alternatively, you can click directly one of those layouts on the Responsive Project pane.  

Changing Layout Height 

The Canvas shows the Layout Height mark which indicates the current height of the 
responsive layout. 

To change the layout height, do the following: 

1. Go to the Properties pane > Slide Properties  > Layout Height > Layout Height 
button. This displays the Layout Height mark on the Canvas. 

2. Drag the Layout Height mark up or down to decrease or increase the height 
respectively.  
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Alternatively, you can enter a value in the Layout Height spin box or click the up/down arrow 
button next to it to get the same result. 

 

Changing Layout Width 

You can resize the layout width by moving the handles on Responsive Project pane to the left 
or right. However, the new width must be in the width range of the currently selected layout. 
This means if you are selecting the Table Portrait device layout, you can drag the handles 
within the width range of this layout only.  
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Changing Slide Height 

In common cases, you place the content inside the area which is limited layout width and 
layout height. However, for device with small viewport, you may want to have more space to 
place content. In that case, you can increase the slide height.  

To change the slide height, do as follows:  

1. Go to the Properties pane > Slide Properties  > Layout Height > Custom Slide 
Height. This enables the Custom Slide Height function.  

2. Enter a value in the Custom Slide Height spin box. Or drag the Layout Height mark 
up or down to decrease or increase the height respectively.  

If the slide height is bigger than the layout height, end users can view the contents beyond the 
layout by scrolling the bar on their devices.  

The slide width is always the same as the layout width.  

Changing Object Position Mode 

Position Mode is the exact specification of the object position in a slide of a project.  

To change this value of an object, select that object > Properties pane > Size & Properties 

tab  > Transform > select one from four modes (Top-Left, Top-Right, Bottom-Right, or 
Bottom-Left). 

Changing Object Position and Size  

These values define the object position in a slide. To change those values, in the Properties 

pane > Size & Properties tab  > Transform > adjust values of Top, Left, Right, Bottom, 
Width, and Height (in percentages or pixels) by entering values in those spin boxes. You can 
also click up/down arrow buttons next to the spin boxes to increase/decrease values.  

The values (Top, Left, Right, and Bottom) displayed in this section depend on the Position 
Mode type you select. For example, if you select the Bottom-Right mode, this section will show 
Bottom and Right value instead of showing Top and Left value when you select the Top-Left 
mode.   

If you want to keep the height-to-width ratio when changing the object width, select Auto in the 
Unit box next to the Height spin box. This option automatically changes the height according 
to the width.  

To rotate the object, along with dragging the rotation handle of the object, you can enter a 
value in the Rotation spin box.    

Changing Object Position Value Unit 

You can change the unit of object position value between percentages (%) and pixels (px). To 

do that, in the Properties pane > Size & Properties tab  > Transform > access the unit 
box drop-down list next to the Size spin boxes > select %, px, or Auto (for Height unit). 

• Choose the % unit if you want the object position to be a percentage of 
left/top/width/height. 

• Choose the px unit if you want the object position to be a number of pixels of 
left/top/width/height. 

• Choose Auto in the Height unit box to retain the aspect ratio.  
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Either the unit you choose, the size and position of the object should remain unchanged.  

Aligning Horizontal/Vertical Center 

You can align objects at the center of the slide in all layouts of responsive projects. To do that, 

in the Properties pane > Size & Properties tab  > Transform > Align Horizontal Center 
or Align Vertical Center. 

If you select both check boxes, objects will be aligned both horizontal and vertical center of 
the slide and you cannot move the object either in the horizontal or vertical direction.  

• Align Horizontal Center: The object will be aligned horizontal center and you can 
move the object only in the vertical direction of the slide. You cannot move it 
horizontally.  

• Align Vertical Center: The object will be aligned vertically center and you can move 
the object only in the horizontal direction of the slide. You cannot move it vertically.

Creating Projects from PowerPoint Presentations

This is a content-generation method where slides from a PowerPoint presentation are used 
instead of recording a target application or creating a blank project.  

To create a new project from PowerPoint slides, on the Start Page > Import PowerPoint > 
select the PowerPoint file from your computer.  

Alternatively, in the currently opening project, access the ActivePresenter button and click 
Import PowerPoint > select the PowerPoint file from your computer.  

Note: ActivePresenter cannot handle the odp files created by OpenOffice and LibreOffice. You 
have to convert these files to pptx files first, and then import them into ActivePresenter.  

After that, ActivePresenter will pop up the Import PowerPoint Presentation window as 
shown in the screenshot below: 
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You now have the following two options: 

• Import Slides as Backgrounds: Each slide turns into a background image for a 
corresponding slide in ActivePresenter project. All the separate objects in the pptx/ppt 
slides will be flattened into one image, and you cannot manipulate/animate them.  

• Process Objects in Slides: All the objects in each PowerPoint slide are imported into 
the corresponding ActivePresenter slide. You can manipulate those objects and then 
annotate the slides in ActivePresenter.  

Note: By default, all PowerPoint slides are selected. You can click the slides that you don’t 
want to import to deselect them. Click Deselect All to deselect all slides.  

If you want to select multiple slides, hold SHIFT or CTRL while clicking the slides. After that, 
click OK to import them into ActivePresenter. 

Creating Projects from Themes or Templates 

Creating projects from themes or templates can save you a lot of time in designing contents 
because you can reuse the project preferences (e.g. slide layouts, object properties) across 
multiple projects. It also ensures the workflow consistency especially when multiple authors 
are working on similar projects. 

An ActivePresenter theme or template contains the following: 

• Slide Master which includes predefined slide layouts. Each layout may have additional 
decoration content. 

• Predefined colors and fonts. 
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• Object settings if any (otherwise, default program settings will be used). 

• For template, there are some pre-created slides with content. 

To create a template-based project, on the Start Page > Templates tab > select a them or 
template.  

In the Template tab, you can right-click any theme to open the context menu: 

• Preview: Preview the theme. 

• Blank Project: Create a blank project with the theme you are currently selecting.  

• Record Video: Record a video demonstration.  

• Record Software Simulation: Record a software simulation.  

• Responsive Project: Create a responsive project with the theme that you are currently 
selecting.  

• Set as Default Theme: Set the theme as the default theme. 

Creating Projects from Video Files 

ActivePresenter allows you to create projects from video files, in which your desired video will 
be opened in a completely new ActivePresenter project. That new project will have the same 
size as the video size.  

To create a project from a video, do as follows:  

1. On the Start Page, click Open.  

Or, in the currently opening project, click the ActivePresenter button and select Open 
Project…. 

2. In the Files of type list box of the pop-up dialog, select All Support Types or Video 
Files. 

3. Browse the video files in your computer and select one. 

4. Click Open. 

After that, you can still resize and reposition the video as a normal object. 

Converting Projects 

Converting from Responsive to Non-Responsive Projects 

ActivePresenter allows you to convert from responsive to non-responsive projects.  

To get it done, click the ActivePresenter button > Project > Convert to Non-Responsive 
Project... > select one of the layouts. The project will be converted to a non-responsive project 
having the layout that you have chosen, without affecting object positions.  

Converting from Non-Responsive to Responsive Projects 

This feature allows you to convert from a non-responsive project to a responsive project having 
up to five default responsive layouts.  
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To get it done, click the ActivePresenter button > Project > Convert to Responsive 
Project… The Convert to Responsive Project dialog will pop up as shown in the screenshot 
below:  

 

• Current Project Size: Show the slide size of the currently working project.  

• Insert Preset Layouts: Choose which device layouts to insert into the new responsive 
project.   

• Convert Size & Position to Percent Unit: Convert unit from pixels to percentages.  

• Scale Content: Choose to scale the content in width, height or both dimensions.  

• Maintain Aspect Ratio: ActivePresenter will maintain the height-to-width ratio of the 
slide size and scale the contents.  

Saving Projects  

Saving Projects 

After creating and editing a project, you can save it easily by clicking the Save icon  in the 
Quick Access Toolbar, or by using the CTRL+S hotkey. You can also click the 
ActivePresenter button and click Save to get the same result. 

Alternatively, you can right-click the name of the project that you want to save on the 
Document tab, and then click Save from the pop-up list.  

Note that when you save a project created with an older version, ActivePresenter will 
automatically save it in the new format, and those files cannot be opened with the older 
versions anymore. In such case, ActivePresenter will warn you with a pop-up dialog. 
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Saving Projects as Different Types 

ActivePresenter allows you to save existing projects to four types: Project, slide template, 
object template, and theme so that you can reuse them as the basis for other projects.  

To do that, in the currently opening project, click the ActivePresenter button > Save As… > 
select a type from the Save as type drop-down list.  

You can also right-click the name of the project that you want to save on the Document tab, 
and click Save As… > select a type from the Save as type drop-down list.  

 

• ActivePresenter Projects (.approj): Save existing projects as normal projects with all 
the editing you’ve made.  

To know how to open an ActivePresenter project, refer to Opening Existing Projects.  

• ActivePresenter Slide Template (.apslide): Save existing projects as slide 
templates. If you save templates in the 
C:\Users\<user_name>\Documents\ActivePresenter Templates folder (for Windows) 
or /Users/<user_name>/Documents/ActivePresenter Templates folder (for macOS), 
they will be shown as custom themes in the Start Page. 

• ActivePresenter Object Template (.apobject): Save existing projects as object 
templates. If you save templates in the 
C:\Users\<user_name>\Documents\ActivePresenter Templates folder (for Windows) 
or /Users/<user_name>/Documents/ActivePresenter Templates folder (for macOS), 
they will be shown in the Object templates pane.  

• ActivePresenter Theme (.aptheme): Save existing projects as themes. If you save 
themes in the C:\Users\<user_name>\Documents\ActivePresenter Templates folder 
(for Windows) or /Users/<user_name>/Documents/ActivePresenter Templates folder 
(for macOS), they will be shown as custom themes in the Design tab and Start Page.  

To open any type of project, do one of the following: 

• On the Start Page > Open > select one project type from the Files of type drop-down 
list > select a project. 

• In the currently opening project > ActivePresenter button > Open Projects… > select 
one project type from the Files of type drop-down list > select one project. 

• In the currently opening project > click the   button on the Quick Access Toolbar > 
select one project type from the Files of type drop-down list > select one project. 

• Use the CTRL+O hotkey. ActivePresenter will open the folder containing 
ActivePresenter projects for you to select. Now you can select one project type from 
the Files of type drop-down list.

Shrinking Projects 
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A project containing unused resources can be increased in size. Its size can also be increased 
after some editing operations. You can choose to reduce the size by shrinking your project. 

To get it done, click the ActivePresenter button > Project > Shrink... 

ActivePresenter will pop up the Shrink Project dialog as shown in the screenshot below: 

 

To remove all of the unused resources, click the Delete All Unused Resources check box, 
and then click the Shrink button. 

You can also manually choose which resources to remove by clicking the Delete Manually 
button. The Project Resources dialog will pop up having two tabs. While the Images tab 
contains all the images of the project, the Audio & Video tab contains all the audio and video 
files of the project. 

Click the items that you want to remove, then click the Delete icon  at the top of the dialog. 

You can click the Select unused items button  to let ActivePresenter select all the unused 
resources for you, and then click the Delete icon . 

Opening Existing Projects 

When you have existing ActivePresenter projects, you can open them again easily. 

Do one of the following: 

• In the opening project, click the ActivePresenter button > Recent Projects > select a 

project, or click the  button on the Quick Access Toolbar > select a project.  

• Use the CTRL+O hotkey. ActivePresenter opens the folder containing ActivePresenter 
projects for you to select. 

• On the Start Page, select one project from the Recent list to open it. 
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Recording Projects 

Recording Videos  

You can use ActivePresenter to record the computer screen to create a video demo to show 
how your products or services look like. 

A recorded project captures truthfully all live actions on the screen along with mouse and 
keyboard actions while you are interacting with the target application.  

To record a new project, do one of the following: 

• On the Start Page, click Record Video. 

• In the currently opening project, access the ActivePresenter button and click Record 
Video. 

• In the Home tab, click the Record Screen button and select Record Video. 

Using this method, the new recorded video will be inserted as a slide in the project that 
you are working with.  

After that the Record Video Project dialog will appear as shown in the screenshot below: 

 

Capture Area Section  

This section allows you to specify the region on the computer screen to capture.  

 

• Full Screen: Allow you to capture the entire computer screen. When you select this 
mode, the entire screen will be treated as the recording window and the blue rectangle 
is invisible. Besides, ActivePresenter will temporarily change the screen resolution 
before capturing and automatically revert to the previous setting when you finish 
capturing.  

• Custom: Allow you to customize the captured screen in any size and direction by 
dragging the floating blue rectangle. ActivePresenter will capture anything that 
happens inside this blue rectangle while ignoring the rest of the screen. The fancy 
cross hair in the middle is just a visual reminder that this is a target-seeker window. 
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Alternatively, you can specify the captured frame size by entering the width and height 
value in the Size spin boxes.  

Besides, ActivePresenter provides some popular preset video sizes. You can quickly 
apply them by using the Preset Sizes button next to the spin boxes (the down arrow 
next to the Size spin boxes). 

Click the Lock to application check box to select a running application window to 
snap into the captured area. The Change Lock Mode button next to the list-of-
application box provides two options to define the snapping behavior. The Fit To 
Boundary option will resize the window of the selected application to fit the capture 
area. On the other hand, the Fit To Application option will resize the capture area to fit 
the window of the selected application.  

Audio & Webcam Section  

This section provides options for recording audio and webcam during the recording screen. 
You can record system audio, audio from microphone and webcam simultaneously, which is 
common in the practice. 

Audio Section 

 

Record System Audio: You can choose to record system audio by clicking the Select Audio 

Device button  > Record System Audio.  

Record Audio from Microphone: If any audio input device detected, you can choose to 
record it by selecting Microphone check box. 

The Volume slider displays the input audio signal level for the audio input device. Before 
actual recording, you can speak something into the microphone to test the sound.  
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The system audio volume can be changed by using the Adjust Volume tool in your computer. 

Webcam Section 

Recording screen and webcam video simultaneously comes in handy for instructional 
purposes such as presentations or game streaming.  

To record webcam video, do as follows: 

1. In the Record Video Project dialog, click the Webcam button  to enable webcam 
recording. A live preview of the camera appears next to the button.  

2. Click the Select Webcam Device arrow button to show the list of webcam input 
devices along with other options. 

 

3. Select the webcam you want to use from the list. 

o Click Webcam Properties to adjust video signal and camera control.  

o Click Format Settings to fine-tune video format and compression.  

4. Click Record to start a capture session. 

After you have finished capture process, the result you get is a slide that displays the screen 
captured video with the webcam feed at the bottom-right corner. The webcam video is actually 
a video object, so you can edit it as normal. 
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Record Button & Settings 

The Record button is a big red button which you can click to start recording. After clicking this 

button, there will be an ActivePresenter icon appearing in the system tray .  

The Settings icon placed at the top-right corner of the Record Video Project dialog provides 
the following options:  

 

• Recording Settings…: Launch the Recording Settings for Video dialog where you 
can change the settings for audio and video, cursor, and hotkeys. 

• Show Capture Area: Show the blue rectangle which indicates the recorded screen 
area. 

• Show Recording Toolbar: Pop up a toolbar with all necessary controls for the 
recording. 

 

• You can see the sound level from the Audio section. The large counter in the Duration 
section shows the current duration of the recording. The Statistics section shows the 
project statistics in terms of Mode, Frame, and Dropped.  

o Mode: Show the current recording project mode (Video). 

o Frames: Show the current frame number of the recording project.  

o Dropped: Show the number of missed frames of the recorded video. 

• Click the Settings icon at the top-right corner of the Recording Toolbar dialog to have 
more options in showing or not showing the Statistics, Duration, Audio, and 
Webcam section. 
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Note: You should not place this toolbar inside the blue rectangle because it will also 
be captured. When capturing full screen, the Show Recording Toolbar option should 
not be selected.  

• Calibrate Audio Input…: Open the Calibrate Audio Input dialog which allows you to 
change the audio input volume automatically or manually. 

When you finish the recording, click the Stop Recording button, ActivePresenter will end the 
recording and enter the editing mode with an intuitive interface. You can also use the hotkey 
CTRL+END to stop the recording.  

Recording Software Simulations 

Creating Software Simulation is a great way to show others how you practice an application 
or software engagingly and lively. Using this feature, you will have a project containing a series 
of slides describing how to achieve a specified purpose with the application you are capturing.  

To capture a new project, do one of the following: 

• On the Start Page, click Record Software Simulation. 

• In the currently opening project, access the ActivePresenter button and click Record 
Software Simulation. 

• In the Home tab, click the Record Screen button and select Record Software 
Simulation. 

Using this method, the new recorded simulation will be inserted as slides in the project 
that you are working with.  

The Record Software Simulation Project dialog will appear as shown in the screenshot 
below: 

  

Capture Area Section 

This section allows you to specify the region on the computer screen to capture.  

It has the same properties and functions as the Capture Area section when you record a 
video project.  

Audio Section  

This section provides the option for audio recording during the capturing. You can record 
system audio and audio from microphone simultaneously. For creating software simulations, 
recording webcam is not available. 
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It has the same properties and functions as the Audio & Webcam section when you record a 
video project.  

Record Button & Settings 

The Record button is a big red button which you can click to start capturing. After clicking this 

button, there will be an ActivePresenter icon  appearing in the system tray.  

The Settings icon placed at the top-right corner of the Record Software Simulation Project 
dialog provides the following options:  

• Recording Settings…: Launch the Recording Settings for Software Simulation 
dialog where you can change the settings for audio and video, cursor and hotkeys. 

• Show Capture Area: Show the blue rectangle which indicates the recorded screen 
area. 

• Show Recording Toolbar: Pop up a toolbar with information and necessary controls 

for the recording. 

 

You can see the sound level from the Audio section. The large counter in the Duration 
section shows the current duration of the recording. The Statistics section shows the 
project statistics in terms of Mode, Frame, and Dropped.  

o Mode: The current recording project mode (Video/Slide). Whenever you scroll the 
mouse or carry a drag-n-drop action, ActivePresenter will automatically switch to 
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the Full Motion Recording mode (Video) to capture it. Otherwise, it will switch back 
to previous capture mode (Slide).  

o Frames: The current frame number of the recording project.  

o Dropped: Show the number of missed frames of the recorded video. 

Click the Settings icon at the top-right corner of the Recording Toolbar to have more 
options in showing or not showing the Statistics, Duration, Audio, and Webcam 
section.  

 

Note: You should not place this toolbar inside the blue rectangle because it will also 
be captured. When capturing full screen, the Show Recording Toolbar option should 
not be selected.  

• Calibrate Audio Input…: Open the Calibrate Audio Input dialog which allows you to 
change the audio input volume automatically or manually. 

How to Stop Recording 

When you’re done with recording a project, stop the recording and start to edit it. Press 
CTRL+END on your keyboard to end the recording.  

Alternatively, you can stop the recording using the Recording Toolbar. On the system tray of 

your computer, click the ActivePresenter icon  to show the toolbar. If the Recording 
Toolbar is currently shown on screen, skip this step.   

• Click the Pause button  to pause the recording for a while. Click on it again to 
continue recording. You can also press SPACE BAR to pause and resume the 
recording.  

• Click the Stop button  to end the recording and step into the editing process. 

• Click the Discard button  to discard the recording. In this case, ActivePresenter will 
offer you three further options:      

o Discard: Abort the current recording without saving the recorded project. 

o Re-capture: Abort the current recording without saving the recorded project and 
start a new recording project with previous settings. 

o Continue: Resume the current recording.
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Working with Themes 

Using Themes

Basically, a theme is a set of design elements which are applied to one or more slides in a 
project. Each theme comprises multiple basic components: 

1. A set of colors (called Theme Colors). Each theme has four colors that can be used 
for text or background. Besides, there are eight additional accents colors for objects. 

2. A set of fonts (called Theme Fonts) that is used for heading and body text. Each theme 
font has a font for heading and a font for body. 

3. Background Style is a combination of background colors and effects such as patterns 
and gradient fills. 

4. Slide Master provides a uniform appearance for your project. Each theme you use in 
your project includes a slide master and a related set of layouts. If you use more than 
one theme, you will have more than one slide master and many sets of layouts. 

When switching to a different theme, all of these components will be updated to reflect the 
new theme. With this in mind, you can change the look and feel of your project without breaking 
any sweat.

ActivePresenter allows you to use different themes for different slides in your project. To see 
available themes, click the Design tab on the Tabbed Toolbar.  

  

As shown in the picture above, there are thumbnail previews of several themes available within 
the theme gallery. Also, you can click the arrow (highlighted in a red square) in the bottom-
right corner of this gallery to see more themes. 

  

The theme currently applied to selected slides will be displayed with a gray outline. In addition, 
it is also placed in a section called This Project. Meanwhile, the Custom section contains all 
themes you created. The third section is where to show built-in themes that come with 
ActivePresenter. 

You can hover the mouse over the thumbnail of theme items to quickly see how the 
appearance of slide will change if you apply that theme to your project. 
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Themes make it easy for you to coordinate colors, fonts, and graphic formatting effects across 
slides and update them quickly. In ActivePresenter, you can change the entire theme or just 
customize theme fonts, colors, or background styles.

Applying & Managing Themes 

As previously stated, using themes is a quick way to control the overall design of your project. 
To apply a theme to your project, you can click the theme thumbnail item in the Design tab. 
After that, all slides which use the same Slide Master as selected slides will change to the new 
theme. Slides based on other Slide Masters will remain unchanged. 

Besides, you can right-click any theme thumbnail to get more options: 

 

• Click Apply to Matching Slides to create the same effect as when you click the theme 
thumbnail.  

• Click Apply to Selected Slides to apply the theme to all selected slides. The option is 
practical when your need is use different themes for different slides.   

• Click Apply to All Slides to apply the theme to all slides in your project. 

• Delete…: This option is available only for custom themes, not supported for built-in 
themes and any themes currently used in your project. Select it to remove the theme 
from ActivePresenter. By doing so, that theme no longer appears in the theme gallery.   

• Click Set as Default Theme to assign the theme as the default for the current project. 
After set a theme as default, the default theme will be used for the new project or new 
capture which you create later.  

Note: If you have any theme (.aptheme) files created before, there are two ways to reuse 
them. Do any of the following: 

• Copy those files to C:\Users\<user_name>\Documents\ActivePresenter Templates 

(for Windows) or /Users/<user_name>/Documents/ActivePresenter Templates (for 

macOS). Then, restart the app, and you will see your themes appear in the theme 

gallery.  

• Click Browse for Themes… and look for a theme file in your file system. 

Applying & Customizing Theme Colors 

As described earlier, ActivePresenter 7 includes sets of built-in theme colors. You can use 
them or create your own sets to fit your need. 

Applying Theme Colors 

To apply Theme Colors, do as follows: 
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1. Go to the Design tab, click Colors  to explore all theme colors available in the 
gallery. The theme colors applied to the currently selected slide are highlighted with 
gray outline. Hover over a set of theme colors to preview what they’d look like if applied 
to the current slide.  

  

2. To apply a theme colors for all slides that share the same Slide Master as the current 
slide, just click the theme colors you want. Or you can also right-click a set of colors 
and choose any of the following:   

o Click Apply to Matching Slides to make the same change as you click a set of 
theme colors.  

o Click Apply to Selected Slides to apply theme colors to all slides you select. If 
change doesn’t satisfy you, you can click Reset Slide Theme Colors to restore 
their original theme colors which are inherited from Slide Master. 

o Click Apply to All Slides to apply theme colors to all slides in your current project. 

o To modify a set of theme colors, click Edit…. You can modify them the same way 
you create custom theme colors. Note that this function is available for custom 
theme colors only. 

o Delete…: This option is available only for custom themes, not supported for built-
in themes and any themes currently used in your project. Select it to remove the 
theme from ActivePresenter. By doing so, that theme no longer appears in the 
theme gallery.   
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Customizing Theme Colors 

ActivePresenter has a built-in facility to create custom theme colors. Before learning how to 
design theme, let take a closer look at the structure of an ActivePresenter theme color.  

As mentioned earlier, a set of ActivePresenter theme colors consists 12 colors, including four 
text/background colors and eight accent colors. The colors should be used as intended. Also, 
make sure that you have eight distinctive colors for your accent ones, and they are different 
from four colors for text/background.  

The following is an example of theme colors in ActivePresenter.  

  

The order of 12 colors is very important. The order of text and background colors defines 
which color will be used as the default text color and default background. Dark 1 and Dark 2 
should always be dark colors. Light 1 and Light 2 should always be light colors. With these in 
mind, a good choice is to keep black and white among the first four text and background colors.  

Once you already designed custom theme colors, the Color Picker will also be updated with 
tints and shades automatically created by ActivePresenter. You cannot control how tints and 

shades are defined but you can adjust them by clicking More Colors .  

Besides, the text and background colors also define Background Styles available in the 
background style gallery.   

 

Let find out how to add and save a custom set of theme colors in ActivePresenter. Do the 
following: 

1. Click Create New Theme Colors… to open the Create New Theme Colors dialog. 
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2. Specify a color in each Color Picker. For more color options, click More Colors… , 

or click Eyedropper…  to select a point in an image for identifying and picking its 
color.  

 

3. Name your new set of them colors and click Save.  

Your theme colors are now saved and always displayed in the Custom section of 
theme color gallery. You can use it whenever you want.  

4. Click Reset if you want to restore the original settings. 

5. To delete custom theme colors, go to the theme color gallery, right-click a custom 
theme color set, and then select Delete. ActivePresenter will remove it from the 
Custom section of the theme color gallery immediately. 

Applying & Customizing Theme Fonts 

Along with Theme Colors, ActivePresenter also allows you to apply a consistent Theme Font 
to your whole project, including the font used for titles, subtitles and text in quizzes as well as 
answers. You can use built-in theme fonts or create your own ones. 
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Here’s how to apply and customize Theme Fonts: 

1. Go to the Design tab and click Fonts  to see the theme font gallery. Hover over 
each font to see its live preview.  

As mentioned above, each set of theme fonts in ActivePresenter consists of a heading 
font and a body font.   

  

o The heading font is used for slide titles.   

o The body font is used for body text on slides, including text that you type into text 
boxes, captions, buttons, and shapes. Besides, it’s also used for the answer 
choices on quizzes. 

2. To apply a set of theme fonts to all slides that share the same Slide Masters as the 
current slide, just click the set you want. You can also right-click it and choose any of 
the following:  
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o Click Apply to Matching Slides to make the same changes as you click a theme 
font. 

o Click Apply to Selected Slides to apply the theme font to all slides you select. If 
changes don’t satisfy you, you can click Reset Slide Theme Fonts (the option 
which is located at the bottom of the Fonts drop-down list) to restore their original 
theme fonts which are inherited from Slide Masters. 
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o Click Apply to All Slides to apply the theme font to all slides in your current project. 

3. To modify a custom theme font, click Edit… This function is not available for built-in 
theme fonts. 

4. To create your own theme font, click Create New Theme Fonts… and then, the 
Create New Theme Fonts dialog appears.  

  

o Select the font for heading and body. You can preview the font in the Sample box.  

o Name the new font and click OK. 

5. To delete custom theme font, go to the theme font gallery, right-click a custom theme 
font, and then click Delete. ActivePresenter will remove it from the Custom section of 
the theme font gallery immediately. 

Applying & Customizing Background Styles 

Each theme has a background which can be plain white, a solid color fill, a gradient color fill, 
or a picture. When you change the theme, the background is replaced as well.  

The Background Styles button is a quick way to change the background color of your project. 
Bear in mind that available background styles will vary according to the theme being used.  

To apply background styles, do as follows: 

1. Click Background Styles  in the Design tab to display available background styles. 
You can hover over each style to see its live preview. 
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2. Click your desired background to apply it to selected slides. Or, right-click a 
background and choose any of the following: 

o Click Apply to Matching Slides to apply the background to all slides that based 
on the same Slide Master as currently selected slides. You can also click the 
background to do that.  

o Click Apply to Selected Slides to apply the background to all slides you select. If 
the change doesn’t satisfy you, you can click Reset Slide Background to restore 
their original slide backgrounds which are inherited from Slide Masters. 

o Click Apply to All Slides to apply the background to all slides in your current 
project.  

3. Each theme has a set of default background styles. But you can customize those 
presets by using the Apply to Reset button in Slide Master.   

Saving Custom Themes 

After customizing your themes, ActivePresenter allows you to save them within the current 
project for reusing later. Do the following: 

1. Click the Design tab. 

2. Click the arrow button in the bottom-right corner of the theme thumbnail gallery to 
expand it. 

3. Click Save Current Theme… 

Once saving it, when you open a different project and click the Design tab, your created theme 
will appear in the Custom section of the theme thumbnail gallery. Then, you can apply it to 
slides in your project. 

To delete custom theme, go to the theme gallery, right-click a custom theme, and then click 
Delete. ActivePresenter will remove it from the Custom section of the theme gallery 
immediately. 
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Using Slide Masters 

Slide Master allows you to easily customize your slides and slide layouts. This feature is 
similar to the one in Microsoft PowerPoint. With this in mind, you can quickly work with Slide 
Masters in ActivePresenter without breaking a sweat. 

Slide Master Overview 

Basically, a Slide Master consists of a master layout and a set of custom layouts. Each layout 
will define placeholders for contents, background, color, fonts, and effects. In addition, 
placeholders also control the position of elements and text formatting on a slide. 

In an individual slide, you can make changes to the design elements provided by the slide 
master. When you change any element on the slide master, all of its corresponding layouts 
reflect the change. 

Each project consists of at least one Slide Master. By using Slide Masters, you can save 
yourself much more time and effort because there is no need to type the same content into 
more than one slide. Input your information just one time, and ActivePresenter automatically 
applies it to the rest of associated slides. This feature is especially useful when you have a 
long project with so many slides. 

Opening Master View 

To switch to the Master View, go to the View tab > Slide Master  . Then, any Slide Master 
previously set up for that project will appear in the left column. If you create a blank project or 
have not designed any Slide Master yet, you will see a default Slide Master.  
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Besides, ActivePresenter also offers a Slide Master tab with a set of buttons for you.  

 

By working with this tab, you can make the adjustments below: 

• Create Slide Masters available for your current project and preserve it to reuse for 
future projects. 

• Insert new layouts with the same background, title, and footer style into which you can 
create your own placeholders. 

• Delete or rename selected layouts. 

• Define which placeholders will be included on a selected layout. 

• Edit the theme applied to a Slide Master. 
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• Control the background color, texture, and graphics. 

• Set the default size for your project. 

While working within the Master View, you can also use buttons in other tabs as described 
below: 

• Home Tab: Format text placeholders, insert shapes, group objects, align objects. 

• Slide Tab: Edit slide background. 

• Annotations Tab: Insert annotation objects, except cursor path, zoom-n-pan, and 
closed caption. 

• Interactions Tab: Insert interactive objects, except types of quizzes. 

• Animations Tab: Animate objects. 

Each Slide Master has at least one layout. In this view, the slide master is the top slide and 
the following are its corresponding layouts. Additionally, the slide master thumbnail is bigger 
than thumbnails of the rest. 

  

Adding Slide Masters & Layouts 

ActivePresenter allows you to add as many Slide Masters and layouts as you want. To add a 
Slide Master, do one of the following actions: 

• In the Slide Master tab, click Insert Slide Master . 

• Right-click any thumbnail on a Slide Master and select Insert Slide Master. 

To insert an additional layout into a Slide Master, do either of the following: 

• In the Slide Master tab, click Insert Layout . 

• Right-click any thumbnail on a Slide Master and select Insert Layout. 
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Managing Slide Masters & Layouts 

Here’s how to manage your Slide Masters and layouts by duplicating, renaming, removing, 
and preserving them: 

Duplicating Slide Master & Layouts 

To streamline the process of creating similar Slide Masters and layouts, ActivePresenter 
allows you to duplicate them. 

To do that, right-click Slide Masters/layouts > Duplicate Master/Duplicate Layout . 

Copying Slide Masters & Layouts 

To copy Slide Masters/layouts: 

• Select Slide Masters/layouts > CTRL+C or right-click it, and then select Copy  from 
the context menu. 

• In terms of copying Slide Masters, click Paste  or Paste (Keep Source Formatting) 

 to duplicate it. 

When it comes to copying one or more layouts, do either of the following, depending 
on your purposes: 

o Press CTRL+V or select Paste from the context menu. ActivePresenter will 
duplicate copied layouts in the current Slide Master. 

 

o Select Paste (Keep Source Formatting) from the context menu. Then, both 
copied layouts and Slide Master from which they inherit properties are duplicated 
as shown in the picture below. 
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Deleting Slide Masters  

You can remove unwanted Slide Masters and layouts. But bear in mind that it’s impossible to 
remove Slide Masters or layouts that are currently being used by one or more slides in a 
project.  

• To delete a Slide Master and all of its corresponding layouts simultaneously, select 

Slide Master > Delete  in the Slide Master tab, or press the DELETE key. 

• To delete layouts only, select layouts > Slide Master tab > Delete or press the 
DELETE key. 

Renaming Slide Masters & Layouts 

If you intend to use many similar Slide Masters or layouts within a project, it’s a good idea to 
give them easily recognizable names. This makes it effortless for you to select and apply them 
later. 

Do any of the following to rename Slide Masters and layouts: 

• Select Slide Masters or layouts > Slide Master tab > Rename . 

• Right-click Slide Masters/layouts > Rename Master/Rename Layout. 

 

After assigning a desired name, click OK. 

Preserving Slide Masters 

The Preserve button comes in handy when you already design a set of Slide Masters for a 
current project and want to use them for future projects. 

To preserve a Slide Master, go to the Slide Master tab > Preserve . Then, a pushpin icon 
will be shown at the top-left corner of the slide master. 
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Keep in mind that when adding new Slide Masters, they will be automatically preserved. 

If you don’t want to preserve a Slide Master anymore, and that Slide Master is not used by 
any slide, when clicking Preserve, a confirmation dialog will appear to ask if you want to delete 
it. 

 

Designing Slide Masters & Layouts 

Inserting Placeholders 

Placeholders are boxes with dotted border on slide layouts, containing multiple types of 
contents, including text, image, video, quiz, and report control. They are designed with tool 
buttons which provide you a quick and easy way to insert contents into slides. Obviously, you 
can place contents on slides by other methods but using placeholders makes it an easy task. 

The following is an example of a slide layout that contains a title text placeholder (1), two 
placeholders into which you can insert contents (2, 3), three of the footer placeholders (4, 5, 
6), a message placeholder (7), and a button placeholder (8).   
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ActivePresenter allows you to insert one or more placeholders into a layout. However, this 
feature is not available for the slide master. 

To add placeholders to a layout, do these steps: 

1. In the Slide Master tab, select a slide layout, and then click Insert Placeholder . 

2. Select a sub-option. Six types of placeholders are described as below: 

o Content : A content placeholder is a combination of five types of content; text, 
image, video, quiz, and report control. This placeholder appears almost like a text 
placeholder but additionally has a small palette of icons in the center. Each of these 
tool buttons is represented for each of four non-text content types. 

o Text : A text placeholder contains text only. 

o Image : An image placeholder has only the Image button which is used to insert 
images.  

o Video : A video placeholder contains the Video button which is used to insert 
videos. 

o Media : A media placeholder contains the Image button and Video button.  

o Question : A question placeholder has nine buttons. Each button symbolizes 
each type of quizzes, including True/False, Multiple Choice, Multiple Response, 
Essay, Fill in Blank, Fill in Multiple Blanks, Sequence, Drag-n-Drop, and 
Rating Scale (Likert). 

o Report : A Report placeholder contains the Report button. You can click it to 
insert a report slide. 

3. (Optional) Drag green handles of the placeholder to resize it or change its location on 
the Canvas. 
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Removing Placeholders 

To remove any placeholder (title, text, date, footer, and slide number) from the slide master, 

select it and press the DELETE key. Or, you can click Master Layout  in the Slide Master 
tab, and then clear any check box.  

 

To remove any placeholder from a layout, select it and press the DELETE key. In case of title 
and footer, you can clear the Title and Footers check boxes in the Slide Master tab. 

Resizing Slide Layouts and Placeholders 

In ActivePresenter, the default slide size when creating a new project is widescreen 
(1280x720). This is also the default size of slide layouts in Slide Masters. However, 
ActivePresenter also allows you to easily change the size of slide layouts and placeholders. 

To do that, click the Design tab > Slide Size . For more details, see Changing Project’s 
Slide Size. 

Another way to resize selected placeholders is by dragging their resizing handles. 
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Applying Themes to Slide Masters 

Using Themes allows you to apply a consistent design to Slide Masters, both the slide master 
and its corresponding layouts.  

Follow these steps below to apply a theme to Slide Masters: 

1. Select Slide Masters > Themes  in the Slide Master tab. 

 

2. In the theme drop-down gallery, do either of the following:  

o Click a theme, and then ActivePresenter will apply the selected theme to all slides 
in the current project. 

o Right-click any theme and select Apply to Selected Slide Master or Apply as 
New Slide Master.  

Case 1: If the selected Slide Master is being used or not preserved, your desired 
theme will be applied to it.  

Case 2: If the selected Slide Master is preserved, ActivePresenter automatically 
adds a new Slide Master based on your desired theme.  

Case 3: If there are multiple selected Slide Masters, ActivePresenter will apply the 
theme to preserved Slide Masters and ones that are being used. They will be kept 
in the Master View while the rest will be removed completely. To change the 
default theme for new projects, right-click a theme, and then select Set as Default 
Theme. 

o To save a theme for reusing in other projects, click Save Current Theme...  

Applying Theme Colors to Slide Masters 

Follow the procedure below: 

1. In the Slide Master tab, click Colors  to preview all of the Theme Colors available. 
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2. To apply a theme color to one or more selected Slide Master, just click it or right-click 
that theme color and select Apply to Selected Slide Masters. The Apply to All Slide 
Masters option is good to go with if you want to make the change for all Slide Masters. 

3. (Optional) To apply a theme color to selected layouts in any Slide Master, right-click 
that color and select Apply to Selected Layouts. 

4. (Optional) To create your own custom theme color, click Create New Theme Colors... 
at the bottom of the theme color gallery. 

5. (Optional) To edit a custom theme color, right-click it and click Edit.... Note that this 
command is not available for built-in theme colors. 

6. (Optional) To delete a custom theme color, right-click it and click Delete.... However, 
built-in theme colors cannot be removed. 

Applying Theme Fonts to Slide Masters 

Follow these steps to do that: 

1. In the Slide Master tab, click Fonts . 
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2. To apply a theme font to Slide Masters, just click that font. This procedure will apply 
the theme font to all selected Slide Masters. Besides, you can right-click the font and 
select Apply to Selected Slide Masters or Apply to All Slide Masters depending on 
your need. 

3. (Optional) In terms of changing a theme font for particular layouts in a Slide Master, 
select them first and right-click your desired font. Then, click Apply to Selected 
Layouts. If changes don’t satisfy you, click Reset Slide Theme Fonts to restore their 
original theme fonts which are inherited from Slide Masters. 

4. (Optional) To create your own custom theme font, click Create New Theme Fonts... 
at the bottom of the theme font gallery. 
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5. (Optional) Regarding custom theme fonts, the Edit and Delete commands are ready 
for use. You can work with them the same way you do with custom theme colors.  

Applying Background Styles To Slide Masters 

Do these actions to apply background styles to Slide Masters: 

1. In the Slide Master tab, click Background Styles . 

  

2. Select Slide Masters. Then, click to apply a background to the selected Slide Masters. 
Alternatively, right-click the background and choose Apply to Selected Slide Masters 
or Apply to All Slide Masters. 

3. (Optional) If you want to change the background color of some selected layouts in a 
Slide Master, click your desired background style. Or, right-click the background style 
and click Apply to Selected Layouts. If you go with the Apply to All Layouts option, 
ActivePresenter changes the background of all layouts in the Slide Master that 
selected layouts inherit from.  

4. (Optional) To customize the background style, go to the Fill and Image sections in the 
Properties pane to design it.   

5. (Optional) Click Reset Background  to return to the original background style if the 
change doesn’t satisfy you. 

6. (Optional) The Hide Background Objects check box is available for slide layouts and 
slides only. When checked, this option hides objects in the Slide Master that is used 
by the slide. 

7. (Optional) Normally, preset backgrounds come with a specific theme. But you can 
customize them the way you want. To do that, go to the Properties pane > 
Background Fill > select your desire colors in the Color Picker > click Apply to Preset 
to open the Preset Backgrounds gallery. Then, click any background style that you 
want to change its color.    
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Closing Master View 

To close the Master View, click Close Master View  in the Slide Master tab. Then, 
changes you made to Slide Masters, and their layouts will be automatically applied to slides 
which are based on them. 

For this reason, when you make any change to Slide Masters, it’s a good idea to review your 
projects for seeing how it affects each slide. Thus, you can notice which slides don’t look 
exactly right the way you want. 

Applying Slide Layouts to Slides 

ActivePresenter offers several ways to apply slide layouts to slides in your current project. You 
can change the layout of existing slides or insert new slides using that layout.  

1. To insert new slides based on a layout, click New Slide in the Home tab. 

2. To change the layout of slides, do any of the following: 

o Select one or more slides in the Slides pane > Home > Layout   > select a 
layout from the layout gallery. The layout you choose will be applied to all selected 
slides. 

 

o Click Layout  in the Slide tab and change the layout for your selected slides. 

o Right-click selected slides in the Slides pane, point to Layout and select a layout 
from the gallery. Then, the layout you choose will be applied to all the slides you 
select.
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Slides 

Inserting Slides 

Inserting slides is one of the very basic and most important steps when creating a project. You 
can use several different methods to create slides, from opening a blank slide to copying 
existing slides from other projects.  

Inserting Blank Slides 

In ActivePresenter, you can create blank projects or insert blank slides into the current one. 

To do the latter, go to the Home tab > New Slide  or go to the Slide tab > New Slide. Then, 
select a slide you want from the slide gallery.  

  

To change the slide layout, click Layout  in the Home or Slide tab. You can choose one of 
the built-in layouts or create your own by using Slide Masters. 

Inserting Slides from Templates 

Instead of choosing a slide from the gallery in the first method, you can click Slides from 
templates... (1) to create new slides based on Templates. Then, the Import Slides from 
Template window appears as below. 
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• Click the Template drop-down button to display the slide template list. You can click 

the Refresh button  to update this list.  

• After selecting the template you want, all slides in that template are shown in the Slides 
section. From here, you can choose your desired slides to insert them into the current 
project or click Select All to add all of them. 

• Drag the Zoom slider to zoom in/out in the Slides section. 

• Once finishing, click Insert Slide. 

Note that if you have any existing slide templates and want them to be displayed in this dialog, 
you can copy the slide template file to C:\Users\<user_name>\Documents\ActivePresenter 
Templates (for Windows) or /Users/<user_name>/Documents/ActivePresenter Templates (for 
macOS). 

Recording News Slides 

This technique is equivalent to Recording Projects, but with the difference that the newly 
captured slides are inserted in the current project, rather than opening up a new project.  

To do that, go to the Home tab > Record Screen  > Record Video  or Record Software 

Simulation  depending on your purposes.  
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Inserting Images as Slides 

If you have a collection of pictures and want to import them into ActivePresenter as slides, this 
command is what you need. Supported image input formats include BMP, PNG, JPG, JPEG, 
JPE, GIF, ICO, CUR, ANI, and XPM.  

To insert images as slides, go to the Home tab > Import Slides  > From Images... . Or, 

go to the Slide tab > Import Images .  

Then, the Insert Images As Slides dialog appears as below: 

  

• Click Add Images From File  to import images from your file system.  

• Click Remove Selected Images  to remove any image from the left list. 

• Click Up  or Down  to change the order of selected images. This order is also the 
order of their appearance in the Slides pane. 

• Click Flip Horizontal  or Flip Vertical  to flip the image. Click Rotate Right 900  

, or Rotate Left 900     to rotate the image. These changes will be applied to it 
appearing on the Canvas as well. 

o While selecting the canvas size, bear in mind the size of images you are using. If 
the Canvas is too small for the image, the image will be clipped.    

o You can re-adjust the canvas size after inserting all images. ActivePresenter 
displays their size, which makes it easy to find the largest height/width and set the 
canvas size accordingly.  

• If you select the Use images as objects check box, each image will be inserted into 
a different slide as an object. Conversely, ActivePresenter will place each image as 
the background of each slide by default.  

• Once completing the task, click OK.   
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Inserting Slides from PowerPoint Presentations  

This method is equivalent to importing slides from PowerPoint Presentation, but the 
difference is that each PowerPoint slide is added to the current ActivePresenter project as a 
separate slide, rather than opening up a new project. 

To insert slides from a PowerPoint Presentation, go to the Home tab > Import Slides > From 

PowerPoint...  or click the Slide tab > Import PowerPoint  . 

The following steps are the same as launching a new PowerPoint project. 

Inserting Slides from Other ActivePresenter Projects 

ActivePresenter allows you to insert slides from other projects. To do that, follow these steps 
below: 

1. Go to the Home tab > Import Slides > From ActivePresenter...  or click the Slide 

tab > Import ActivePresenter . 

2. Click Select All or manually select your desired slides from the Import 
ActivePresenter Presentation window. 

 

 

A quicker way is to use the Copy and Paste commands. The procedures and changes are the 
same as you copy and paste slides.  

However, note that pasted slides and their objects always keep their original sizes and 
positions. Thus, if the original project (which contains the slides to copy from) and the 
destination project (slides will be copied to this project) don’t have the same Canvas size 
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and/or resolution, some inserted objects may lie outside the Canvas. If the original project and 
the destination one are equal in size, object placement will remain unchanged. Therefore, 
always check all imported slides and edit them if necessary.  

Inserting Random Slides 

Inserting Random Slides is usually used in creating test materials (e.g. a project with random 
questions) to make contents appear unpredictable for learners. This concept in 
ActivePresenter is exactly similar to the Random Question concept in other tools. 

To insert a random slide, go to the Slide tab > Random Slide . The inserted slide is 
automatically linked to the first Slide Pool in the project.  

Inserting Report Slides 

ActivePresenter allows you to add report slides for giving learners valuable feedback. See 
Inserting Report Slides for more details.

Managing Slides  

Naming Slides 

It’s always a good idea to give slides recognizable names, so it makes easier for you to find 
them later.  

Changing Slide Names from Properties Pane 

To name a slide, follow these steps: 

1. Select a slide in the Slides pane. 

2. Go to the Properties pane, click the General section, and then type a new name in 
the Name box.  

 

If you want to format the name of slide in a visual way, you can click the button  at the right 
of the Name box to launch the rich text editor. The editor contains the most common formatting 
functions to change the slide name.  
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Or, right-click any slide and click Slides in Titles (or go to the View tab and click Slides In 

Titles ) and select Edit Name  from the context menu.  

Also, you can select multiple slides and follow these steps above to change their names at the 
same time. 

Generating Slide Name from First Shape 

ActivePresenter provides you a command that can quickly generate slide name from the first 
shape for multiple slides.  

To access this function, go to the Slide tab > Batch Operations  > Generate Slide Name 
From First Shape. Then, a dialog will be shown as below: 
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In the first column of this dialog, you can select slides that you want to create new names, 
click Select All to select all slides or click Deselect All to clear all. In the fourth column, click 
each New Name box and type a slide name you want.  

Sorting Slides  

ActivePresenter offers a handy capability which allows you to easily organize slides by 
dragging them to where you want. However, this feature is available only in the Slides In 
Column and Slides In Grid view mode.  

• The default mode is Slides In Column in which the slide thumbnail expands its size 
to fit the available width of the pane.  

 

• The second mode is Slides In Grid in which slides are arranged into multiple columns 
and rows.  
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• The third mode is Slides In Titles in which the pane only displays the names of 
slides. 

 

To sort slides, right-click any slide in the Slides pane and click Slides In Column  or Slides 

In Grid . You can also go to the View tab and click the Slides In Column or Slides In Grid 
button. As you drag the slide over the other slides, they move aside to make space for it. If 
you release the mouse button, the slide will drop into the gap as below.  

 

The current slide is highlighted in dark blue, as shown above. Also note that while a slide is 
dragged, it retains its original sequence number (in the screenshot above, 1). Thus, you can 
remember where to drop the slide back. 

Keep in mind that this feature is not available when slides are in the Slides in Titles view mode.  

Previewing Slides 

After inserting all objects into slides and customizing them the way you want, if you want to 
preview slides, do either of the following: 

• Press the SPACE BAR. 

• Click the Preview button  in the Timeline pane. Besides, you can click the drop-
down arrow of this tool to display the following two options: 

o Preview all: Select it to preview from the first slide to the last one in the opening 
project. 

o Preview from current slide: Select it to preview from the current slide to the last 
one in the opening project. 
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• Right-click a slide and select Play Preview from the context menu. 

Copying & Pasting Slides 

ActivePresenter allows you to copy and paste slides within a project or from a project to 
another. The copied slides will be inserted right after the last selected one in the working 
project. 

To copy and paste slides: 

1. Select slides that you want to duplicate and press CTRL+C or right-click them and 
select Copy. 

2. There are two built-in paste options which allow you to control whether theme fonts are 
replaced. Do any of the following: 

 

Removing Slides 

To delete slides, do one of the following: 

• Select slides and press the DELETE key. 

• Right-click slides and select Delete  from the context menu. 
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Splitting & Merging Slides 

When there is too much content in a slide, chances are that you may want to split the slide 
into two or more slides.  

To split a slide: 

1. Choose a timestamp in the Timeline pane. Note that ActivePresenter will split your 
slide at the Playhead position, so place it at the exact timestamp that you want to split.  

2. Click Split Slide .  

Then, your slide will be automatically split into two slides. The new one is inserted right after 
the original slide, and you can treat it as an independent one. Besides, the new slide contains 
all of the objects, effects, and other attributes in the right side of the Playhead. What’s more, 
ActivePresenter also allows you to split a given slide any number of times.

In case the Playhead position lies in the middle of an object Time Bar, the Time Bar will be 
split at the Playhead position, and the latter part is transferred to the new slide.  

In addition to splitting slide, ActivePresenter also provides the Merge Slides command to 
merge two or more slides into one.  

To merge slides: 

1. Hold CTRL or SHIFT while clicking slides. 

2. Right-click selected slides and select Merge Slides from the context menu. 

Editing Slides 

Editing Slide Properties 

Each slide in ActivePresenter has a certain number of properties shown in the Properties 
pane. You can work with this pane to quickly change the properties of each slide or multiple 
slides at the same time.  

To edit slide properties, go to the Properties pane > Slide Properties tab  and do the 
following: 

• Type a desired name for selected slides in the Name box. You can add the description 
and adjust the duration for them in the respective boxes.  

  

• Format the slide background in the Background Fill section, including fill, opacity, and 
color. If you don’t want to show objects of slide layout that is used by the slide, select 
the Hide Background Graphics check box. 
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• Change the background image in the Background Image section. You can change 
the image and adjust the size and position of background image. This property is 
mainly used for storing recorded steps of software simulations. 

 

• Customize the accessibility of slide in the Accessibility section. To add accessibility 
text and description, clear the Auto Label check box.  

 

Adding Transition Effects 

ActivePresenter offers a range of transition effects to indicate the end of one slide and the 
beginning of another. You can control the style and speed of transition effects and apply 
different effects to different slides in your project. 

Adding Transition Effects  
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To apply a slide transition effect, do as follows:  

1. In the Slides pane, click the slide to which you want to add a transition effect. Select 
multiple slides if needed. 

2. In the Transitions tab, select one of the effects from the transition gallery. 

3. Adjust Effect Options and Effect Duration if needed. 

 

Slide transition effects can also be applied to Slide Master. To do that, click the View tab and 
click Slide Master to open the Master View. Go to the master slide or layouts to which you 
want to apply transition effect then follow the above-mentioned steps.  

Removing Transition Effects 

To remove slide transitions, select the slide you want, and then do one of the following: 

• Go to the Transitions tab and select None from the transition gallery. 

• In the Timeline pane, select the blue diamond that indicates a transition effect on the 
slide bar. Drag the mouse downward out of the Time Bar until the effect Time Bar turns 
into gray, and then release the mouse button to delete the effect. 

Inserting Events and Actions into Slides 

You may want to execute some actions before the slide starts showing or after it hides. In this 
case, you can add On Load and On Unload actions for the slide and then add actions into 
them. For more information, see Events - Actions. 

Editing Background Image by Using Image Editor 

To do that, follow these steps below: 

1. Right-click the background image and select Edit Background Image  from the 

context menu. Or, click the Slide tab > Edit Background Image . Then, 
ActivePresenter will immediately transfer that slide background to the Image editor.  
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2. As might be seen, the layout of the Image editor in ActivePresenter is quite similar to 
that of other basic photo editing tools, and the background is located in the center of 
the Canvas. But the difference is that all tools are placed in a unique tab, called the 
Drawing tab.  

 

From here, you can do whatever you want to make your slide background become 
more amazing. 

3. After finishing the edit phase, click the Save changes button in the Quick Access 
Toolbar to apply the new background image to slide. 
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Inserting & Managing Objects 

Inserting Objects 

When working with ActivePresenter, chances are that you will need a shape to create a drag-
n-drop interaction, a picture to visualize some information, or a video to explain a feature of 
your product. Then, knowing how to insert all of these objects is a must. 

Basically, there are two types of objects in ActivePresenter, namely Non-interactive Objects 
and Interactive Objects. 

1. Non-interactive Objects include shapes, text caption, highlight, spotlight, gesture 
effects, footer, image, YouTube, web object, cursor path, zoom-n-pan, closed 
caption, audio and video.  

2. Interactive Objects include mouse click, key stroke, text box, drop area, button, 
check box, radio button, and questions.  

In ActivePresenter, you can insert all of them into your projects. Click each object above to 
learn how to do that.  

Additionally, ActivePresenter supports the capability to insert objects into multiple slides. This 
feature is functional when some slides in your current project lack a particular object. To do 
that, follow these steps below: 

1. Go to the Slide tab, click Batch Operations .  

2. Select Insert Objects... from the drop-down list and then, the Insert Multiple Slide 
Objects dialog appears as below. 

 

o In the top section, click the Object Type drop-down list to select the object type you 
want to insert. 

o You can insert the selected object into all slides, into the current or specified slides. 
Note that when entering the number of each slide in the Specified Slides box, let 
use the comma to separate them. Or, you can enter a range of slide numbers with 
a hyphen. 

o Once you are satisfied with all new settings, click OK to apply changes. 

3. After inserting an object into a slide, you can right-click it and select Merge into 
Background from the context menu. Then, the object will be merged into the 
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background, and its Time Bar along with all relating animations (if any) will disappear. 
This command is very useful when you want to use image objects as slide 
backgrounds. 

4. (Optional) If you want some objects to appear on many slides in the presentation, you 
can work with the Show over Multiple Slides feature. This command is good to go with 
when the object is your company logo or background music. 

 

To add a logo to all of the slides in your current project like the picture above. First, 
right-click the logo and select Show over Multiple Slides from the context menu. You 
can select Top Layer to show the logo at the top of slides or select Bottom. 

Layer to show the logo at the bottom of slides. When it comes to the company logo, it 
is highly recommended that you should choose Top Layer. After that, the logo is still 
shown in the slide into which you inserted it. So, you have to change its duration to 
make it show in other ones.   

In terms of audio tracks, no matter what you select Top Layer or Bottom Layer, there 
is no difference in the output.  

After that, go to the Timeline, and click the All Slides  button to view all slides in the 
current project (2). This feature allows you to see the objects that span across multiple 
slides. 

Note: ActivePresenter also has a facility to export media objects including audio/video clips 
(both clips inserted from file system and clips you’ve created in ActivePresenter) and images 
to files. To do that, right-click objects and select Export To File... from the context menu. They 
are saved in the PNG (image), WAV (audio) and MP4 (video) formats.

Removing Objects  

If you don’t want an object anymore, do any of the following: 

• Select objects and press the DELETE key. 

• Right-click objects and select Delete from the context menu.  

To delete multiple objects simultaneously, go to the Slide tab > Batch Operations > Delete 
Objects… Then, the Delete Multiple Slide Objects dialog appears. 
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This dialog has three sections as described below: 

1. The Delete Objects section contains a list of all objects. Select objects you want to 
delete.  

2. The In Slides section is where you can specify the slides where you want this mass 
destruction to happen. You should review these selected slides to check out whether 
they include objects needing to be removed or not.  

3. If you also want to delete objects which have been set to show over multiple slides, 
select the Include objects shown over multiple slides check box. Usually, they can 
be background music or corporate logo.
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Managing Objects 

After inserting objects into a slide, you can manage them by moving, aligning, ordering, 
grouping, and removing them. All of these capabilities are at your disposal in ActivePresenter.  

Copying and Pasting Objects 

If there are multiple objects in a project that you want to use the same format, manually editing 
one of them can take a lot of time. Alternatively, you can edit one object, and then use the 
Copy and Paste commands to duplicate it.  

To do that, follow these steps below: 

1. Select objects and press CTRL+C or click the Copy button in the Home tab. Another 
option is to right-click objects and select Copy from the context menu.  

2. You can paste your copied objects into the same slide or in another slide. In case of 
the latter, do either of the following: 

o Press CTRL+V or select Paste from the context menu or click Paste (Use 
Destination Theme) in the Home tab. Then, theme colors and fonts of pasted 
objects will change according to those of new slide. This option is practical when 
you want to change the theme of pasted objects.  

o Select Paste (Keep Source Formatting) from the context menu or click Paste 
(Keep Source Formatting) in the Home tab. In this way, the theme colors and 
fonts of pasted objects will be based on those of copied objects (if any). 

Moving Objects 

When inserting any object into a slide, that object is nearly always located in a default position 
on the Canvas. Then, chances are that you will want to move it to your desired place. 

To change the position of an object, do either of the following: 

• Hover over the object until the pointer turns into a four-way arrow, then click and drag 
the object to the position you want.  

 

• Hover over an object until the pointer turns into a four-way arrow and click to select the 
object. Then, move it by using the arrow keys. That is, press UP/DOWN ARROW to 
move the object to the up/down of the Canvas respectively, and press LEFT/RIGHT 
ARROW to move the object to the left/right of the Canvas respectively. 

You can press CTRL at the same time to accelerate the movement by a factor of 10. 

• Go to the Properties pane > Size & Properties  > Transform > enter values in the 
Left and Top spin boxes. 
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Ordering Objects 

When inserting objects into a slide, it is likely that some of objects are hidden or overlap each 
other. To be more specific, each newly inserted object will cover the previously added object 
partly or fully. In ActivePresenter, this vertical order of object placement is called z-order which 
affects how selected objects will appear on users’ screen. 

 

To change the position of objects on a slide, you can click, drag, and drop each object to 
where you want. However, if you want to adjust them for creating some special effects, take 
further steps below: 

1. Select objects on the Canvas or in the Selection or Timeline pane. 

2. Go to the Home tab > Arrange  or click the Format tab > Order  to access the z-
order tools which are described in the following table: 

Icon Name Hotkey Function 

 

Bring to Front CTRL+HOME Place the selected object at the very top 
of the stack. 

 

Bring Forward CTRL+PAGE UP Send the selected object higher by one 
level in the stack. 
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Send to Back CTRL+END Place the selected object at the very 
bottom of the stack. 

 

Send Backward CTRL+PAGE DOWN Send the selected object lower by one 
level in the stack. 

Keep in mind that you can drag to change the z-order of objects in the Selection pane. 

Grouping Objects 

You can group multiple objects into one object. After that, you can move, resize, rotate or 
change other properties of multiple objects simultaneously. 

Note that this feature is not available for some particular objects, including closed captions, 
audio clips, spotlights, videos, web objects, YouTube objects, zoom-n-pan objects, 
gesture effects, questions.  

Grouping Objects  

The moment you group a set of objects, you will see some kinds of significant changes which 
help you streamline your workflow. First, let find out how to group objects.  

Do the following: 

1. Hold the CTRL key while clicking multiple objects. Then, go to the Home tab > Arrange 

 > click Group  in the Group section to group them. 

Another way is by right-clicking all selected objects and selecting Group from the 
context menu. 

 

Once selected objects are grouped together, ActivePresenter will merge all their 
original Time Bars into one. Then, they will appear as a single object in the Timeline 
with a new name (see a picture below). 
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2. Go to the View tab and click Selection  if you want to know which objects are sorted 
in a group. 

  

3. When you click a group, the group outline is marked with a blue line (1). Subsequently, 
if you click an object in the group, the blue line will turn to the dotted one, and 
ActivePresenter will show green resizing handles for the object (2).  

 



ActivePresenter User Manual  Version 7 

Inserting & Managing Objects > Managing Objects  86 
 

Editing Groups 

To add objects to an existing group, select a group and an object that you want to add to that 

group > Home tab > Arrange  > Add to Group  (in the Group section), or right-click the 
group (or the object) > Group > Add to Group. 

When you add a new object to an existing group or change the position of any object in that 
group, the size of the outline will be extended accordingly.  

Besides, ActivePresenter also lets you create a nested group (means a group as a member 
of another group). Do that by selecting your desired groups and using Add to Group.    

In each group, you can apply the following actions to all objects at the same time: move, rotate, 
resize, change object style, edit line style, fill, add shadow, align, and apply animations. All 
capabilities are accessible by working with the Properties pane and corresponding buttons 
on the Tabbed Toolbar. 

For example, in the picture below, you can see that each individual shape is rotated by 45 
degrees, compared with the entire group which is also rotated by 45 degrees. 

 

ActivePresenter allows you to manage and edit a group or its objects the same way you do 
with a single object. Remember that in terms of customizing a group, all changes will be 
applied to all objects inside it. 

Changing Group Layout to Grid  

Follow these steps to change the group layout to Grid:  

1. Select a group. Then, go to the Properties pane > Size & Properties  > Group 
Layout. 

 



ActivePresenter User Manual  Version 7 

Inserting & Managing Objects > Managing Objects  87 
 

2. Click the Mode drop-down list and select Grid.  

 

The Grid layout ignores the original size properties of all objects in a group. Instead, it 
assigns a fixed size to all of them and is defined by the horizontal spacing, vertical 
spacing, and the number of columns.  

4. (Optional) Enter the number of columns you want in the Number of Column spin box. 
For example, if the number of columns is 2, all objects in group are equally distributed 
into those 2 columns. The number of rows will be automatically counted based on that 
of columns and that of objects in the group. 

5. (Optional) Define the space of objects in group horizontally in the Horizontal Spacing 
spin box. 

6. (Optional) Define the space of objects in group vertically in the Vertical Spacing spin 
box. 

7. For further modification, click Advanced Settings... in the Group Layout section to 
open a new dialog.  

 

Type numbers to the Proportion spin boxes to define the width ratio between columns (1) or 
the height ratio between rows (2). For example, the 1:2:3 ratio in the Row section means that 
the height of the third row is three times more than that of the first one, and 1.5 times as much 
as the second one. If the value is 0, the minimum size of objects will be used. 
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Note that if the size of an object group is too small, ActivePresenter will shrink the frame of 
each object inside it to the smallest size, but keeping text within the frame. Thus, to see the 
clear difference after customizing default settings, you should enlarge the group size.  

Aligning Objects 

The Align button offers several options to arrange objects, which helps you speed up the 
working process.  

1. ActivePresenter has a snap mode for the Canvas which allows you to align objects 

with each other and the Canvas. To activate this mode, click Canvas Snapping  in 
the View tab. After that, whenever you draw, move or resize objects, their edges will 
snap to the nearest orange lines.  

 

2. In ActivePresenter, you can also align objects with the last selected object, which is 
called a reference object or an anchor one. Then, the anchor object shows green 
resizing handles while the rest have white ones.  

To change the anchor object, click one of the currently selected objects without holding 
the CTRL. 

 

To access aligning tools, click the Home or Format tab > Align . There are 13 options in 
the drop-down list, and you can use them to do the following actions: 

a) Align Objects to Each Other 

You can work with these alignment commands to align selected objects along their top, 
bottom, left, and right slides. These options are described as below: 
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Icon Command Function 

 

Align Left The left side of all objects will get aligned with the left of the 
anchor object. Their vertical position will not be affected. 

 

Align Center The center of all objects will get aligned vertically with the center 
of the anchor object. Their horizontal position will not be 
affected. 

 

Align Right The right side of all objects will get aligned with the right of the 
anchor object. Their vertical position will not be affected. 

 

Align Top The top of all objects will get aligned vertically with the top of the 
anchor object. Their horizontal position will not be affected. 

 

Align Middle The center of all objects will get aligned with the center of the 
anchor object. Their vertical position will not be affected. 

 

Align Bottom The bottom of all objects will get aligned vertically with the 
bottom of the anchor object. Their horizontal position will not be 
affected. 

b) Align Objects to The Canvas 

If you want to move two or more selected objects so that their horizontal/vertical center is in 
the center of the Canvas (that is, the center line of selected objects has the same X or Y 
coordinate as the center line of the Canvas width or height respectively), the following 
commands are good to go with.  

These options are described as below: 

Icon Command Function 

 

Center Horizontally All objects will move to the center of the Canvas 
horizontally. Their relative position will not be changed. 

 

Center Vertically All objects will move to the center of the Canvas vertically. 
Their relative position will not be changed. 

c) Distributing Objects 

If you arrange objects in a row or column, you may want them to be an equal distance from 
one another for a neat appearance. Then, you can do this by distributing them horizontally or 
vertically. 

These options are described as below: 

Icon Command Function 
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 Distribute 
Horizontally 

Click to make the horizontal spaces between selected 
objects equal. 

 Distribute Vertically Click to make the vertical spaces between selected objects 
equal.  

Note that these commands work only when more than two objects are selected.  

d) Resizing Objects to an Anchor Object 

If you need to resize two or more objects in ActivePresenter so that they all have the equal 
width and height, you can use the following options in the alignment drop-down list. These 
options can conform selected objects to the same width or height or both.   

These options are described as below: 

Icon Command Function 

 

Make Same Width The height of all other objects is adjusted to match that of 
the anchor object. 

 

Make Same Height The width of all other objects is adjusted to match that of 
the anchor object. 

 

Make Same Size Both the height and width of all other objects are adjusted 
to match those of the anchor object, respectively.  
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Editing Objects  

In ActivePresenter, you can edit objects by using the commands such as rotating, resizing, 
renaming, changing objects styles, and adding animation effects. 

Rotating Objects  

ActivePresenter allows you to rotate almost objects except spotlight, gesture effects, cursor 
path, zoom-n-pan, and closed caption objects. Also, you can rotate multiple objects at the 
same time.  

To rotate an object, do any of the following: 

• Click an object and drag the rotation handle to rotate the object. 

 

• Go to the Properties pane > Size & Properties > Transform > enter the value in the 
Rotation spin box. 

Resizing Objects 

After inserting an object into a slide, you often need to resize them appropriately. For example, 
you may want to scale up a text caption to make the text fit into the object. 

To resize objects, do any of the following: 

• Click an object and hover over one of its resizing handles until the pointer turns into a 
double-headed arrow. Then, drag this arrow to any direction to enlarge or shrink the 
size of the object.  

 

• Go to the Properties pane > Size & Properties > Transform > enter values in the 
Width and Height spin boxes. Select the Lock aspect ratio check box if you want to 
keep the current proportions. That way, once you change the width or height, the other 
parameter will change proportionally. 
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• Select an object and use SHIFT+ARROW to resize it. More specifically, press 
SHIFT+UP/DOWN to decrease/increase the height of objects respectively, and press 
SHIFT+LEFT/RIGHT to decrease/increase the width of objects respectively. 

In case of images and video objects, if you aren’t satisfied with changes, just right-click images 
and select Restore Original Size from the context menu. Then, ActivePresenter will restore 
the original size for them without impacting on other customization.   

Note:  

• An object in a responsive project has a default responsive unit including Top, Left, 
Width (in percentages or pixels), and Height (in percentages, pixels, or auto).  

When you choose the % unit, once you change the device layout, the object size will 
be adjusted correspondingly.   

• The boundary of objects in a responsive project in the smaller layout will be inherited 
from the larger layout.  

For example, if you change an object boundary in the Desktop layout, its boundary will 
be inherited by the Tablet Landscape layout which is smaller than the Desktop layout. 
However, if you change the boundary of an object in the Tablet Landscape layout, its 
boundary will not be inherited by the Desktop layout which is larger than the Tablet 
Landscape layout. 

Editing Object Styles 

Each object style has a separate look and feel in terms of color, transparency, text, shadow, 
and line thickness. The combination of all these attributes is called Style. 

You can use the Quick Style feature to quickly change the style for your objects or create your 
own styles by using available tools.  

Do any of the following: 

• Select an object and click Quick Style  in the Home tab or in the Format tab. Then, 
the Theme Styles gallery appears on the screen. Remember that styles in this gallery 
depend on the theme that you’ve chosen for the current project. Click a style to apply 
it to your object.   
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• Go to the Home or Format tab and click Fill , Line  , Shadow   to design your 
own object style. You can also go to the Properties > Style & Effects tab to fully 
control the style of object. 

• You can change the style for a shape. Then, right-click the shape and select Apply to 
All Shape Objects > Style in the context menu. This way, the new style will be applied 
for all shapes in your working project.   

• When you want to change the shape of an object without impacting all of its properties 
that you’ve customized, the Change Shape tool is what you need. By using it, you can 
quickly adjust the form of selected objects. To do that, select objects and click Change 

Shape  in the Format tab. Then, select your desired shape. 

After finishing the editing, you can right-click the object > select Set as Default Shape from 
the context menu to save and use it later. After that, any new added shape will be this default 
shape. 

In case you want to restore the original default object which comes with ActivePresenter, click 

the ActivePresenter button > Project > Reset Default Objects > click your desired object 
type to reset.   

Adding Animation Effects to Objects 

Animation is a great tool to engage your audience. ActivePresenter allows you to animate 
objects with four types of animation effects: Entrance, Exit, Emphasis, and Motion Path. In the 
Animations tab, entrance effects are colored green, exit effects are colored red, emphasis 
effects are colored yellow, and motion paths are pre-made lines. 
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Entrance effects control how an object enters a slide. These effects start at the start point of 
the object (that is the left edge of the object Time Bar). For example, an object will move slowly 
into a slide with a Float In effect. 

Exit effects control how an object exits a slide. These effects end at the end point of the object 
(that is the right edge of the object Time Bar). For example, with the Zoom Out effect, an object 
will gradually scale down and disappear.  

Emphasis effects animate objects that are already in a slide. These effects make an object 
change its size, transparency, shake, or spin on its center. For example, you can set an object 
to shake with the Teeter effect. 

Motion Path effects move objects already in a slide along a predetermined path, like a line, 
circle, or a star. You can also draw your own paths. 

An animation effect applied to an object has the following generic properties: 

• Start Time: Time in seconds when the effect is set to start playing.  

• Duration: Duration of the effect in seconds. 

• Effect Options: Each animation effect has a different set of options. For example, for 
the Spin effect, you can make an object rotate clockwise or counterclockwise.   

Adding Animation Effects 

Timeline contains animations. As ActivePresenter supports multiple timelines, a single 
object can hold different animations on different timelines. So, make sure that you add the 
right animation effect to the right timeline. 

To apply an animation to an object: 

Select the object you want to animate. 

1. Click the Animations tab, then do one of the following: 

o Click Entrance Effects or Exit Effects to show the effect drop-down list, then 
choose the desired effect.  

o Click Add Animation to choose Emphasis or Motion Path effects. These effects 
will be added at the Playhead position.  

2. Click the Play button  in the Timeline pane or press the SPACE BAR on your 
keyboard to preview animation effects. 

Note that if you want to apply an animation effect to all shapes in the working project, you can 
set the animation effect for a shape. Then, right-click this shape and select Apply to All Shape 
Objects > Animation in the context menu.  

In the Timeline pane, entrance effects are colored green, exit effects are colored red, both 
emphasis and motion path effects are colored yellow.  
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On the Canvas, Motion Path effect appears as a dotted line with a green arrow indicating the 
path’s start and a red arrow indicating its end.  

 

If you choose Custom Path option, you will draw your own path. When you click to draw the 
start point of the path, the pointer turns into a plus sign. When you’re done drawing, double-
click to exit the editing mode. 

You can add more than one animation type to an object and set all the animations to play in 
turn or simultaneously to create stunning visual effect. For example, apply a Fly In entrance 
effect together with a Spin emphasis effect to make a shape fly in while rotating. However, 
keep in mind that always use animations for a purpose. Don’t overuse animations as it can 
distract your audience. 

Editing Animation Effects 

ActivePresenter allows you to adjust the properties of animation effects including timing, 
duration, effect options and so on. To edit an animation, select an animation effect and then 
do one of the following: 

• Open the Animations tab and specify the duration, start time and effect options (if 
any) of the effect. 

• Drag an effect Time Bar in the Timeline to change the duration and timing of the effect.  

• Right-click an effect Time Bar in the Timeline pane and then select Animation 
Settings to open the settings dialog corresponding to each effect type. Edit effect’s 
properties and click OK to save changes.  

 

For Motion Path effect, you can select the path on the Canvas, and then resize it by dragging 
its resizing handles. In addition, right-click the path to choose a desired editing option. 
Specifically, you can edit the individual point of the motion path, lock or unlock a path, or 
change its direction. 
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• To move an entire motion path, click and drag the path to the position you want. 

• To change the shape of a motion path, right-click the path and then click Edit Point. 
Square black handles appear on the path. Drag each handle to move that portion of 
the path.  

 

• For open paths like Lines, Arcs, and Turns, right-click the path and then click Close 
Path to make the object return to its start point. A linear path is added from the previous 
end point to the start point.  

 

• For closed paths like Shapes, Loops, and Stars, right-click the path and then click 
Open Path to separate the start and end point.  

 

• Select Revert Path Direction to exchange the start and end point of the path. 
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Removing Animation Effects 

To remove an animation effect, do one of the following: 

• Select the object, go to the Animations tab and select None from the effect list. 

• In the Timeline pane, select an effect Time Bar. Drag the mouse downward out of the 
Time Bar until the effect Time Bar turns into gray, and then release the mouse button 
to delete the effect. 

• Right-click the effect Time Bar in the Timeline pane and select Remove Animation 
from the context menu.  

For Motion Path effects, you can also select it on the Canvas and press the DELETE key to 
delete. 
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Object States  

A state is a collection of visual elements defining the look and feel of a specific object. Some 
objects have only one state while others have multiple states by default. 

The following picture illustrates a typical example of using Object States in ActivePresenter. 
As you may know, a button often has four states: Normal, Hover, Clicked, and Disabled. The 
button is in the Normal state when you don’t point or hover it. The Hover state means that you 
hover over the button. The Down state is when you click the button, and when it isn’t available, 
it is in the Disabled state. By working with the Object States pane, you can change the 
appearance of each state to interact with your audience.  

 

Knowing how to use Object States in ActivePresenter will bring a lot of advantages to you.  

• Develop interactive contents easily without using multiple objects or constantly hide 
and show them in a single project. 

• Declutter and simplify the Timeline. For example, to change the color of any image 
based on viewer actions, just use different colored states for a single image rather than 
inserting many objects with separate colors.  
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Keep in mind that Object States are not available for zoom-n-pan, cursor path, and closed 
caption.  

Opening Object States Pane 

The Object States pane is not shown by default. To turn it on, go to the View tab and click 

Object States .  

  

Below are some different concepts relating to Object States in ActivePresenter 7:  

• Normal state: Each object always has a Normal state which cannot be deleted and 
renamed. 

• Custom state: An object can have multiple Custom states. They inherit visual 
properties from Normal state. Obviously, you can also customize them in your own 
way.  

• Default state: The Normal state of an object is its Default state. But you can change it 
by setting a new state as a Default one. This is also the initial state of an object. (Keep 
in mind that the initial state can be changed.) 
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• Active state: During the Edit States mode, the state you select will be called an Active 
state. When ending this mode, the Active state is always the Default one.  

Besides, the Edit States mode has a toolbar as you can see in the picture above. You can use 
buttons on this toolbar or in the context menu of selected resources to manage resources. 
The availability of commands on the toolbar or in the context menu depends on the selected 
resources.    

Note: If you previously don’t select any object, the Edit State button is unavailable. Besides, 
when you select an object and edit its states, all other objects in the current slide will be grayed 
out and unclickable.  

Opening Edit States Mode 

After inserting an object into a slide, you can add states to it by accessing the Edit States 
mode.  

To open the Edit States mode, go to the Object States pane > Edit States. 

In the Edit States mode, ActivePresenter allows you to do actions below:  

Adding New States to Objects 

To insert a new state for the selected object, do the following: 

1. Click the Add State button  in the Edit States mode or right-click the Normal state 
(Default state)/Custom state and click Add State. 

2. Rename the new state (optional) and click OK. 

Bear in mind that in this case, the newly added state will always inherit all properties from the 
Normal state.  

 

Duplicating States 

Duplicating existing states allows you to add more states which have the same properties with 
them. You can duplicate both Normal and Custom states.  

Do either of the following: 

• Select a state and click the Duplicate State button . 

• Right-click a state and select Duplicate State from the context menu. 

Removing States from Objects 

If you don’t want a state anymore, you can remove it by using one of the following ways: 

• Select a state and click the Remove State button .  

• Right-click a state and select Remove State from the context menu.  
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• Select a state and press the DELETE key. 

Note that you can’t remove the Normal state.   

Renaming States 

If you want to change the name of a state, do any of the following: 

• Select a state and click the Rename State button . 

• Right-click a state and select Rename State from the context menu. Then enter a 
unique name in the pop-up dialog and click OK to finish. 

Once finishing, the name shown at the bottom-left corner of the state thumbnail will be 
changed. Note that this capability isn’t available for the Normal state.  

Resetting States 

If you customize a state, and the changes don’t satisfy you, ActivePresenter allows you to 
restore its original properties. 

Do either of the following: 

• Select a state and click the Reset State button . 

• Right-click a state and select Reset State from the context menu. 

Note that this capability isn’t available for the Normal state. 

Setting States as Default 

ActivePresenter allows users to label a state as a default one which is always selected out of 
the Edit States mode. Do either of the following: 

• Select a state and click the Set as Default State button .  

• Right-click a state and select Set as Default State from the context menu.  

Editing States 

In the Edit States mode, you can change the appearance of any state, including text, shape, 
color, effects, placement, and size. All of these tasks can be done the same way you edit a 
particular object. 

Besides, ActivePresenter also allows you to create drag-n-drop interactions for object 
states and add events to states like a single object.  

Mind the following: 

• In terms of the image object, you can change the image of each state. To do that, 
select your desired state, go to the Properties pane >  Style & Effects tab > Fill > 
Image Fill > click From File… or From Project....  

• In terms of the radio button and check box objects, it’s possible to change the 
properties of their states like Fill, Mark, and Border. Select your desired states and go 
to the Format tab to do that.  

• There are some constraints when changing visual properties of a state.  
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        Mode 

Properties 

Edit States mode Other modes 

Rotation, size, 
and position 

When active state is normal state, 
ActivePresenter updates all visual 
properties of other states which 
inherit from normal state. 

When active state is custom state, 
ActivePresenter removes inheritance 
of changing property of this state. 

With any state, ActivePresenter 
changes other states with the 
same transformation matrix in the 
case of moving, rotating and 
resizing. 

Others 
When active state is normal state, 
the app updates all visual properties 
of other states which inherit from 
normal state. 

When active state is custom state, 
the app removes inheritance of 
changing property of this state. 

If the default state is normal state 
or inherits from normal state, the 
app updates all visual properties 
of normal state and other states 
which inherit from normal state. 

If default state is not normal state 
and doesn’t inherit from normal 
state, the app only updates the 
default state. 

Object Templates  

The Object Templates pane comprises object templates. Each object template includes one 
or more object template items. These items can be annotation or interactive objects or object 
groups.  

By default, ActivePresenter gives you a “Default” object template. But, you can create your 
personal object templates for specific purposes. For example, create an “Icons” object 
template to put all icons into it. So, it’s easier to reuse those icons later.  

The Object Templates pane is a practical feature to add, save, and reuse objects within a 
project or across other ones. ActivePresenter stores object templates in 
C:\Users\<user_name>\Documents\ActivePresenter Templates (for Windows) or 
/Users/<user_name>/Documents/ActivePresenter Templates (for macOS) with the *.apobject 
extension. You can add/rename/remove object template files or transfer them between 
computers. 

Managing Object Templates Pane 

Opening Object Templates Pane 

To open the Object Templates pane, go to the View tab and click Object Templates .
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Adding Objects to Object Templates  

During the working process with ActivePresenter, you can add created objects (except zoom-
n-pan, cursor path, and closed caption) to object templates for reusing them later. 

To do that, follow these steps below: 

1. Right-click an object/object group. 

2. Select Add to Template from the context menu. 

When you select multiple objects at once, and add them to the Object Templates pane, 
ActivePresenter will place selected objects to the same object template rather than distributing 
them to each new individual object template. In this case, their position and alignment will 
remain unchanged.  

Generally, an object template item has the same properties as the original object, even events 

and actions. But there are some exceptions. For example, assume that you have the object A 

with the action “Show object B” when clicked. If you add these objects to the object template 

simultaneously, the event and action remain. Otherwise, if you just add the object A to the 

object template, the action will be removed. 

Renaming Object Template Items 

To rename any object template item in the Object Templates pane, right-click it and click 
Rename. 

Removing Object Template Items 

To remove any object template item from the Object Templates pane, just right-click it and 
click Delete.  
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Using Object Template Items 

ActivePresenter allows you to reuse object template items in Object Templates. Rather, you 
can insert your desired object template items into the selected slide. Then, edit them normally. 

To add any object template item in the Object Templates pane to a slide, do one of the 
following: 

• Double-click an object template item in the pane. 

• Right-click an object template item in the pane and click Insert.   

• Select an object template item in the pane. Then, drag and drop it to the Canvas.  

Note: At the bottom of the Object Templates pane, there is the Keep Source 

Formatting check box. It is selected by default. This means when you add any object template 

item to a slide, their font and colors still remain the same as the source formatting. If you 

deselect this check box, font and color of inserted object template items will change according 

to the Theme Colors and Theme Fonts of the slide to which they are added 
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Non-Interactive Objects  

Non-interactive objects add value to slides visually. They do not interact with users by 
responding to their actions. Therefore, non-interactive objects do not change the course of the 
presentation in response to user input, such as going to a certain slide, pausing/resuming 
playback, etc. 

Non-interactive objects are listed as follows: 

Object Icon Usage 

Shape 

 

Insert a shape on/around the point of interest.  

Text Caption 

 

Insert text to explain contents. 

Highlight 

 

Overlay a colored semi-transparent area on a part of the screen 
to highlight it. 

Spotlight 

 

Overlay a dark screen on the display area, allowing only a 
certain area to be fully visible.  

Gesture 
Effects  

Insert a widget that shows how the viewer interacts with the 
application on the touch screen. 

Footer 

 

Insert date, slide number, and text into the bottom of the slide. 

Image 

 

Insert an image into a slide. 

Audio  

 

Insert an audio into a slide. 

Video 

 

Insert a video into a slide. 

YouTube  

 

Embed a YouTube video within a slide. 

Web Object 

 

Embed a website within slide.  

Cursor Path 

 

Handle mouse movements and clicks to simulate user activities. 

Zoom-n-Pan 

 

During rendering, zoom in the virtual camera on a part of the 
screen to show it in more details. 
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Closed 
Caption  

Closed captions are like subtitles on movies (text that can be 
read at the bottom of the screen). Viewers can control whether 
to show or hide CC on the screen. 

Shapes  

Overview of Shapes 

ActivePresenter offers five groups of ready-made shapes including basic shapes, callouts, 
lines and arrows, block arrows, and stars. You can insert and modify shapes with ease.  

 

To insert a shape, open the Annotations tab or the Home tab > Shapes > select a shape in 
the drop-down list. The shape will be automatically inserted into a slide.  

 

The initial fill color, line color, text color, and font of the shape are determined by the theme 
you are using for your project. However, the look and feel of the shape is always customizable 
by using commands provided in the Format tab or Home tab, or in the Properties pane. See 
Editing Objects for more details. 

Most of the time, after inserting a shape, you have to move and resize it to the position and 
size you want.  

• Drag the shape to a new position. 
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• Drag the resizing handles to resize the shape. If you scale down the shape too much, 
some text within the shape may be clipped or hidden, so be careful when resizing the 
frame. 

Further adjustments to shapes include: 

• Drag the rotation handle to rotate the shape. 

• Drag the yellow diamond  to change the dimensions/appearance of the shape. If the 
shape includes a pointer, you can make it point at anywhere in your slide. Just click 
and drag the yellow diamond at the end of the pointer. 

• Click inside the shape to enter text (hover over the shape until the cursor turns into a 
text cursor and click to enter text). For a text caption, click the default text to add text. 
You can also right-click the shape and select Edit Text from the context menu or press 
F2 on your keyboard. Use commands in the Home tab to format text. 

• Change the shape style with Fill, Line, and Shadow properties. 

• Use the Format tab > Change Shape to switch to a different shape type. 

• Arrange the shape with Order, Group, and Align tools. 

• Use the Animations tab to add animation effects to the shape. 

• Use the Timeline pane to change the timing and duration of the shape. 

• Use the Properties pane to change the size and position and other properties of the 
shape. 

If you customize a shape and then want to use the same formatting on future shapes of the 
same project, you can right-click the shape and select Set as Default Shape. That way, the 
current formatting will be set as default and used each time you insert a new shape in the 
project.  

Drawing Freeforms  

ActivePresenter provides four types of drawing tools including Line, Curve, Freeform Shape, 
and Freeform Scribble, allowing you to draw your own lines and shapes. 

Drawing Lines 

To draw a line, open the Annotations tab or the Home tab > Shapes > Lines & Arrows > 

Line . Follow these steps: 

1. As soon as you select the Line drawing tool, the cursor changes into a cross hair . 
Click anywhere on the Canvas to set the start point. Move the mouse without releasing 
the mouse button to draw the line.   

Hold down the SHIFT key while drawing a line to make a truly horizontal, vertical, or 
diagonal straight line. You can draw a 0, 30, 45, 60, 90, 120, 135, 150, and 180-degree 
line.  
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2. Release the mouse button to set the end point of the line. The line has resizing handles 
at both ends, allowing you to drag to lengthen or shorten it.  

To move the line, hover over it until the pointer turns into a four-way arrow, then click 
and drag to the position you want. 

 

3. Click anywhere on the slide to deselect the line. 

Drawing Curves 

To draw a curve, open the Annotations tab or the Home tab > Shapes > Lines & Arrows > 

Curve . Follow these steps: 

1. As soon as you select the Curve drawing tool, the cursor changes into a cross hair 
. Click anywhere on the Canvas to set the start point and move the mouse to a different 
position to form a line.   

 

2. Press the mouse button to curve the line. As you move the mouse, the curve changes 
correspondingly. 

 

3. Move the mouse and press the mouse button again to add turns to the curve. Each 
time you click, a new curve is added. 

 

4. To finish drawing a curve, do either of the following: 
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o To leave the curve open, double-click where you want to end the curve. 

o To close the curve, move the mouse near the start point. The curve gets filled to 
indicate that it is closed. Then double-click near the start point to get a curved 
shape filled with a solid color.  

 

Drawing Freeform Shapes 

Freeform Shape drawing tool has a dual capability as you can draw both curves and straight 
lines. To draw with the Freeform Shape tool, open the Annotations tab or the Home tab > 

Shapes > Lines & Arrows > Freeform Shape  . 

Follow these steps: 

1. As soon as you select the Freeform Shape drawing tool, the cursor changes into a 

cross hair . Click anywhere on the slide to set the start point. Now you can: 

o Release the mouse button and place the cursor elsewhere, then click to draw a 
straight line.  

Hold down the SHIFT key while drawing a line to make a truly horizontal, vertical, 
or diagonal straight line. You can draw a 0, 30, 45, 60, 90, 120, 135, 150, and 180-
degree line. 

 

o Hold down the mouse button and draw as if you are using a pencil to mimic drawing 
with a pencil on paper. That way you can draw freeform lines. 

 

2. To finish your drawing, do either of the following: 

o To draw an open shape, simply double-click when you are done. 

o To draw a closed shape, move the mouse over the start point of your drawing. The 
shape gets filled to indicate that it is closed. Double-click near the start point to get 
a closed shape.  
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You can alternate between straight and freeform lines within the same line shape. To do that, 
while drawing, keep holding down the mouse button and move the mouse to draw freeform 
lines. Whenever you want to draw straight lines, release the mouse button and simply move 
the mouse and click to set the end point of the straight line, then you can keep holding down 
the mouse button and repeat the cycle. 

Drawing Freeform Scribbles 

The Freeform Scribble drawing tool is almost similar to the Freeform Shape tool as you can 
mimic drawing with a pencil on a paper. However, there is one essential difference between 
these tools. Once you start drawing with the Freeform Scribble tool, you have to keep holding 
down the mouse button until you finish as the point where you release the mouse button will 
be the end point of your drawing.  

Thus, with Freeform Scribble you cannot draw a perfect straight line as with the Freeform 
Shape tool. Besides, you don't need to double-click to set the end point of the line - just release 
the mouse button and get your drawing finished. 

Open the Annotations tab or the Home tab > Shapes > Lines & Arrows > Freeform 

Scribble . 

1. As soon as you select the Freeform Scribble drawing tool, the cursor changes into a 

cross hair . Click anywhere on the Canvas to set the start point. Move the mouse 
without releasing the mouse button to draw the shape. 

 

2. To finish your drawing, do either of the following: 

o To draw an open shape, simply release the mouse button when you are done. 

o To draw a closed shape, move the mouse over the start point of your drawing. The 
shape gets filled to indicate that it is closed. Release the mouse button near the 
start point to get a closed shape.  
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Editing Drawn Shapes 

You can change a shape’s appearance after drawing it by opening the Edit Point mode. To do 

that, right-click a shape and select Edit Point  .  

In the Edit Point mode, the shape is outlined by a red dashed line. There are some small black 
squares indicating the anchor point where a curve ends or where two line segments meet. For 
example, there are five anchor points (equivalent to five black squares) in the following shape. 

 

In the Edit Point mode, do either of the following to edit a shape’s appearance: 

• Place the cursor on an anchor point - the cursor will change to a hand pointer. Click 
and drag the anchor point to sharpen or smooth a corner or a curve. A red dashed line 
appears indicating changes. 

 

• You can also alter the shape’s appearance without repositioning the anchor point. 
When you click to select an anchor point, two blue handles appear with white squares 
at their ends. These white squares are control points with which you can adjust the 
degree of the curve or line on either side of the point in relation to the next point along 
the line.  
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• If you want to straighten a curved segment between two anchor points, right-click along 
the segment and select Straight Segment.  

 

• Hover over the outline of the shape until the cursor changes to a hand pointer. Click to 
add a new anchor point, then drag the anchor point to put another corner or curve in 
the shape. 

• Right-click an anchor point (a small black square) and select an option to make 
necessary adjustments to the anchor point and the shape as well.  

 

o Select Delete Point to delete an anchor point. The selected anchor point will 
disappear, making the shape change accordingly. 
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o Select Smooth Point to switch to Smooth Point mode. In this mode, the two 
handles point in exactly the opposite direction (180 degrees) from each other. 
They’re also positioned the same distance away from the anchor point. 

 

o Select Straight Point to switch to Straight Point mode. In this mode, the two 
handles point in exactly the opposite direction (180 degrees) from each other. 

 

o Select Corner Point to switch to Corner Point mode. In this mode, the two handles 
go off in different directions. This is the default mode. 

 

o Select Close Path to close an open shape. A linear path is added from the previous 
end point to the start point. 
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o Select Open Path to open a closed shape right at the selected point.

 

o Select Exit Edit Point to exit the Edit Point mode. 

Text Caption 

Text caption is a rectangle shape that can contain multi-line formatted text. You can use text 
captions to direct attention toward certain areas in a slide, give viewers extra information, or 
explain important concepts.  

To create a text caption, go to the Home tab or the Annotations tab > Text Caption . 

 

To add text to the text caption, click the default text to open the inline text editor, then enter 
text.  

In fact, text caption is a variant of the shape object, where only the text is given prominence, 
and the Fill and Line properties of the shape are muted. Therefore, the discussion for shapes 
also applies here.  
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Highlight 

Highlight is a transparent, colored rectangle shape that can be placed over a certain area in a 
slide to draw attention to the area. To insert a highlight, go to the Annotations tab > Highlight 

.  

You can adjust the formatting, color, transparency, and size of highlight objects to fit the target 
area. 

Think of highlight as a variant of the shape object, where the text and border line are removed 
and the background is made semi-transparent (50% transparency). Therefore, the discussion 
for shapes also applies here. 

Spotlight 

Spotlight retains the original brightness within the shape and darkens the rest of the screen, 
creating an effect like you are watching a dark screen with a search light. Thus, it is able to 
instantly draw your attention to even a tiny part of the screen. 

To insert a spotlight, go to the Annotations tab > Spotlight . 

 

Spotlight is actually a more aggressive version of highlight, where the rest of the screen is not 
darkened. It is also a shape object with special properties. For that reason, the discussion for 
shapes also applies here, but there are two exceptions: 

• In the Properties pane, the Style & Effects tab shows the properties of the area that 
lies OUTSIDE the shape (not inside it). 

• Spotlight object doesn’t have the Rotation property. 
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Gesture Effects 

Gesture effect is usually used in demonstration mode to show how the viewer interacts with 
the software on the touch screen. Basically, it looks like an animated GIF image. 
ActivePresenter provides 14 types of gesture effects.

 

To insert a gesture effect, go to the Annotations tab > Gesture Effects  > select from the 
drop-down list.  

To change a gesture effect, go to the Properties pane > Size & Properties > Gesture Effects 
and select a new gesture effect from the Type drop-down list: 

 

Note that gesture effect object doesn’t have the Rotation property.  

Footer 

You can add date and time, slide numbers, and text to the bottom of the slide in your project. 

Open the Annotations tab > Footer . A dialog appears as below:



ActivePresenter User Manual  Version 7 

Non-Interactive Objects > Image  118 
 

 

• Select Date, and then do one of the following: 

o Click Update Automatically if you want the date to reflect the current date each 
time you open or print the project. 

o Click Fixed if you want to set the date to a specific date, and then in the Fixed box, 
type the date that you want. 

• Select Slide Number if you want to add slide numbers. 

• Select Footer if you want to add text to the center bottom of the slide. Then type what 
you want in the Footer box. 

• Select Don’t show on title slide to keep all the date, slide number, and footer from 
appearing on the title slide. 

• Click Apply to apply footer to the current slide. Click Apply to All to apply footer to all 
slides. 

Image 

Images are a good visual to enhance the contents of your project. Depending on the context 
of the project, images may be screenshots of applications, drawings (electrical, civil, 
mechanical, etc.), or photos of persons, products, places, buildings, etc. 

ActivePresenter currently supports five image types: PNG, JPG, JPEG, BMP, and GIF. 

You can use two commands to insert images into ActivePresenter.  

• Open the Annotations tab > Image  and choose one or more images. Besides, 

insert images into a side by dragging image files directly from the Explorer or from the 

Resources pane. 

• Second, use the Screenshot command to take a screenshot of anything on the 

screen. Details about this command are described in the following part. 
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Screenshot 

ActivePresenter has a built-in facility to capture screenshots. 

A typical application has a top level window, which in turn may have child windows that appear 
to accomplish different tasks. The windows form a hierarchical tree. A window at any level 
(top/child) has objects (menus, panes, toolbars, controls, etc.). ActivePresenter allows you to 
take a screenshot of any of these windows/objects, which is then inserted into the current slide 
of your project. 

ActivePresenter provides four different ways of taking a screenshot, which can be selected by 

opening the Annotations tab > Screenshot , and then selecting either of the four 
screenshot modes. 

 

Four Screenshot modes are described as below. 

Window 

To capture a screenshot of the target window or any object in it, select the Window mode 
. ActivePresenter can capture a window at any level of the application. 

Use the mouse to select a window or its object (for example, toolbars, panes, menus, etc.). 
You can use the mouse click on the screen and the target application normally as this does 
not trigger a screenshot. 

As you move the mouse over different parts of the screen, ActivePresenter shows a red 

dashed outline  around areas that can be captured. 

When you find the correct area to be captured, press the PRINT SCREEN key on your 
keyboard or CTRL+Click. ActivePresenter will capture the screenshot and place the image 
on the current slide. 

Note that ActivePresenter cannot detect some objects in certain target applications. This is 
because those applications have not provided MSAA interface for those controls. 
ActivePresenter typically captures the whole toolbar, because it is usually the lowest child 
level window. 

Object 

To capture a screenshot of any object in any window, select the Object mode . 

As you move the mouse over different parts of the screen, ActivePresenter shows a red 

dashed outline  around areas that can be captured. 

When you find the correct area to be captured, press the PRINT SCREEN key on your 
keyboard or CTRL+Click. ActivePresenter will capture the screenshot and place the image 
on the current slide. 

https://en.wikipedia.org/wiki/Microsoft_Active_Accessibility
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Note that ActivePresenter cannot detect some objects in certain target applications. This is 
because those applications have not provided MSAA interface for those controls. Typically, 
ActivePresenter can capture the individual tools on any toolbar, depending on the accessibility 
support level of the target application. 

Full Screen 

To capture a screenshot of the entire screen of your PC, select the Full Screen mode . 
(Some screen-capturing applications call this “desktop” mode.) 

ActivePresenter will minimize its own window, and capture whatever visible on your computer 
screen. This may be a single application (running with its window maximized), or several 
windows of different applications. 

ActivePresenter will then place this image on the current slide. Be careful that the screenshot 
is very likely to be larger than your slide. If you resize it to fit the slide size, the details in the 
image will get blurred, and the viewer may not be able to read specific details. 

Application or Region 

To capture a screenshot of the top-level window of the target application, or a rectangle region 

of the screen, select the Application or Region mode . 

Immediately, a target-seeker window and a dialog appear. The target-seeker window has a 
blue border line and a cross hair in the middle. The cross hair is just a visual reminder that this 
is a target-seeker window. 

• Drag and position the window around the target part of the screen. 

• Resize the window by dragging its handles (small squares at the corners and middle 
of all edges). 

 

The Take Screenshot command window works as follows: 

https://en.wikipedia.org/wiki/Microsoft_Active_Accessibility
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• Screenshot Usage: Insert the screenshot as an image into the current slide, and/or 
as a background image of a new slide that will be inserted below the current slide. 

• Screenshot Size: Set the size precisely instead of setting the size visually by adjusting 
the target-seeker window. When you set the size, the target-seeker window resizes to 
that specified size. The Preset Sizes button allows you to select from several 
predefined sizes. 

• Application: Provide a drop-down list of all current applications running on the PC that 
have a visible window. Generally, you need to take the screenshot of an application, 
so this list should satisfy your needs. 

o Fit To Application: Resize the target-seeker window to fit into the application 
window. 

o Fit To Boundary: Resize the application window to fit into the target-seeker 
window. 

• Wait for: Specify a delay (in seconds). Use this delay to quickly interact with the target 
application and capture its response. 

To take a screenshot, click the Take Screenshot button. 

Screenshot Options 

ActivePresenter provides four options to adjust screenshot settings. To access these options, 
click Annotations > Screenshot > Options.   

• Capture Window Shadow: When an application window is in non-maximized state, 
the Windows Operating System casts a drop-shadow around its border. 
ActivePresenter has the option to capture this shadow while taking a screenshot of the 
target window. 
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Note that this drop-shadow is treated as a part of the image but not the Shadow 
property of the screenshot. In other words, you can add one more shadow to this 
captured image with a different set of parameters (color, distance, angle, etc.) 

• Process Rounded Corners: When an application window is in non-maximized state, 
the Windows OS offers an option to display rounded corners. ActivePresenter has the 
option to capture those rounded corners. If you turn off this option, the captured image 
will have sharp corners. 

• Use Opaque Background: Windows 7 and later have the option to use Aero theme, 
where the border of windows appears semi-transparent. While the windows look great, 
they mess up the screenshot, because any text/images in the background will also 
show up through these border. ActivePresenter has the option to replace this 
transparency in the screenshot with an opaque border.  

• Show Usage Guide: Show a yellow text box that describes how to capture the 
screenshot when capturing windows or objects. If you are apt to forget the shortcuts, 
leave this display on. 

Note that the first three options work only when capturing a window at any level but not when 
you capture a region or an object. 

Exporting Screenshots & Images 

ActivePresenter allows you to export images from projects. You can export the image you’ve 
inserted into your project or the ones that you’ve created within your project. Currently, you 
can export images to three file formats: PNG, JPG, and BMP. 

To export images, do the following steps: 

1. Select an image either on the Canvas or in the Timeline. 

2. Right-click and select Export To File…. 

3. Specify the file name, file format, and file location, then click Save to export. 

YouTube Video 

ActivePresenter allows you to stream YouTube videos in your project by embedding them in 
a slide. Do the following steps: 

1. Click Annotations > YouTube . 

2. Type the URL of the YouTube video that you want to embed. 

3. Click the Preview button or press ENTER to load and preview the video within the 
dialog. 

4. Specify playback options for the video. 

5. Click OK to finish. 
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Below are available playback options: 

• Autoplay: Make the video start playing as soon as the slide’s timeline reaches the 
start of the video object.  

• Hide Annotations: Hide annotations in the video. 

• Hide Controls: Hide the media controls for the video. Remember that without controls, 
you can still play or pause the video by clicking it. 

• Disable Scaling: Keep embedded content the same when scaling a slide (for example, 
in the AutoFit mode of the presentation, when zooming and panning). This option is 
turned on by default. 

• Play Specific Part: Embed just a part of the video. Select this option and enter the 
start time and the end time (in seconds) in the spin boxes. 

For example, if a video is of 2 minutes, and you want it to start playing at the 20th 
second and stop at the 60th second, enter 20 and 60 in the two box respectively. 

After embedding a YouTube video within an object in a slide, you can resize the YouTube 
object to the desired size. In case you aren’t satisfied with the change and want to back to the 
original size, right-click the object and select Restore Original Size from the context menu. 

You can also update the video thumbnail to the latest thumbnail on YouTube and to the current 
object size in ActivePresenter. Just right-click the object and select Update Thumbnail from 
the context menu.
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To change a YouTube video, go to the Properties pane > Size & Properties > YouTube and 
click the Edit button. 

 

Note: 

• YouTube video only works in HTML5 output, in other outputs, it is exported to image. 

• Due to technical limitation, there is no warranty that the playback of a YouTube video 
will always synchronize with the playback of the project. 

• On mobile devices, only user-initiated playback is acceptable. So, viewers need to click 
a YouTube video to play it even when the Autoplay option is selected. You should not 
select the Hide Controls option when creating contents for mobile devices. 

Web Object 

You can directly embed content from a website within a slide. Web objects are a great way to 
enhance your project with web-based resources such as websites, games, social media, 
reference material, etc. 

Note that web object only works in HTML5 output, in other outputs it will be exported to image.  

To add a web object, do as follows: 

1. Click Annotations > Web Object . 

2. Enter the URL of the website or HTML code that you want to embed. 

3. Click the Preview button or press ENTER to load and preview the web object within 
the dialog. 

4. Specify scrolling and scaling behaviors for the object.  

5. Click OK to finish. 
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To customize a web object, do any of the following: 

• Scrolling: Allow scrolling down the contents. 

• Disable Scaling: Keep the content the same when scaling a slide (for example, in the 
AutoFit mode of presentation, when zooming and panning).  

After embedding a website within an object in a slide, you can resize the web object to the 
desired size. In case you aren’t satisfied with the change and want to back to the original size, 
right-click the object and select Restore Original Size from the context menu. 

You can also update the thumbnail to the latest thumbnail and to the current object size in 
ActivePresenter. Just right-click the object and select Update Thumbnail from the context 
menu. 

To change a web object, in the Properties pane, go to the Web Object section, then click the 
Edit button.
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Cursor Path 

Cursor path enables you to simulate mouse movements and clicks, which is extremely useful 
for software training and simulations.  

 

In practice, cursor path objects get generated in two different ways: 

• During the capturing phase, ActivePresenter records your mouse movements and 
converts them into cursor paths. (The figure above shows only one segment. In real 
life, ActivePresenter creates a complex path with multiple segments.) 

• During the editing phase, you can edit the captured path or insert cursor paths by 

clicking Annotations > Cursor Path  . 

In general, the idea is to add or delete nodes in the path, and to drag to place them over 
buttons or other clickable objects on the Canvas. Optionally, you can add click points, where 
ActivePresenter produces the clicking sound in the rendered project. 

 

Each cursor path consists of three parts: a start point (1), an end point (2) and a dotted line 
(3) presenting the movement path of the pointer between these two points. 

• A half of the dotted line towards the start point has a green color, and its remaining 
half gradually turns red toward the end point. 

• A red arrow shows the direction of the cursor movement. The spacing between dots 
indicates the speed of the cursor on screen, that is, closely spaced dots mean slower 
speeds. Imagine the dots to be plotted at regular intervals of time; so the faster the 
cursor moves across the screen, the farther are the dots. If the dots are too closely 
spaced, the line appears as solid instead of dotted. 

• When you click the start point, a square appears to denote that the start point is 
currently selected. ActivePresenter shows a control point (4) associated with the end 
point, and it is always tangent to the path.  
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In the example above, a start point (1) is clicked, so ActivePresenter shows a control 
point (4) associated with an end point (2). You can change the shape of the path by 
moving the control point.  

Changing Path’s Shape 

When you insert a cursor path object into a slide, the whole object is selected so that you can 
move it to another position on the slide. Remember that only one path can be added to each 
slide. If you want to change the position of the start or end point of the path, do as follows: 

1. Click anywhere on the Canvas to deselect the path. 

2. Click the start point or end point and drag it. 

 

The default cursor path is more or less a straight line, but you can totally adjust its shape. 
Hover anywhere over the dotted red/green line and you can see that the pointer changes to a 
pencil (1). Click to add a point (2) and drag that point (3) to change the shape of the cursor 
path (4). 

 

Any given path segment can be made a curve or a straight line. Just select the start point and 
from the context menu, select Straight Cursor Path or Curved Cursor Path.  
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You can change the shape of the curve by moving the control point. The following image 
shows two sets of experiments: 

 

• Within each row, the diamond  is increasingly shifted away from the end point. (See 
the progression between images 1→2→3 and images 4→5→6). 

• Within each column, the diamond is rotated around the end point by 45°. (Compare 
image 1-4, 2-5, and 3-6). 

Observe that: 

• As the yellow diamond  is moved away from the end point, the path becomes more 
curved. (Observe the progression in images 1→2→3 and also images 4→5→6). 

• As the diamond is turned away from the straight line connecting the start point and the 
end point, the curve also moves away from the center line. This shift is even more 
pronounced when the diamond is farther away from the end point. (Compare images 
1-4, 2-5, and 3-6). 
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Changing Cursor Style 

To add a cursor image to a point or replace the original pointer with other shapes, do as 
follows: 

1. Click a point. 

2. Go to Properties > Cursor. 

3. Click the Change Cursor drop-down button to open the cursor gallery. From here you 
can choose the cursor image you want.   

 

In the following example, several points were added to the original path. The cursor for each 
of those interim points was also changed. When rendered, this path will keep changing the 
cursor shape along the way. 
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Changing Path’s Timing 

Take a look at the cursor movement in time. The following screenshot shows the actual 
movement on the screen and corresponding Timeline view. 

 

The screenshot shows the 3rd segment with four instants 1-4 marked on both the Canvas and 
the Timeline. From the Timeline, you can see that: 

• The gray vertical line (1) starts the life of the segment. 

• The instant when the cursor starts moving is marked with a red vertical line. During the 
1→2 gap, the cursor is at rest (there is no movement), this is the Start Duration of the 
cursor. The green line spans the Moving Duration of the cursor. 

• The instant when the cursor stops moving is marked with a second red vertical line. 
During the 3→4 gap, the cursor is at rest (there is no movement), this is the Stop 
Duration of the cursor. 

• The second gray vertical line (4) denotes the end of the segment. 

You can drag the lines above to adjust where the movements of the cursor begin and how 
long they last. 

Adding Click Points 

The yellow diamond  on the Time Bar represents a click point. This is where 
ActivePresenter simulates a click by creating a “click” sound and click effect. 

You can convert any point along the cursor path into a click point by doing the following steps: 

1. Click a point. 
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2. Go to Properties > Cursor > Click Point. 

3. Select a desired type of click point from the Type drop-down list. Select None if you 
don’t want to add a click point.  

4. Further customize the click point with other options like Click Sound, Click Time, and 
Click Effect. 

5. Click the Apply To All button to apply changes to all click points of the same type.   

 

Composing Cursor Paths 

Here are a few tips for composing a realistic-looking cursor path: 

• Avoid showing the mouse all the time. It is OK if the mouse vanishes from the scene 
for a while. 

• Remove aimless wandering of the mouse: It is too much distracting. Replace them with 
straight segments. 

• Avoid using the mouse as a presentation pointer. Jabbing the pointer at something 
may be OK for live demo, but in an annotated presentation, this is a sure sign of 
laziness. Instead, use shapes, zoom-n-pan, spotlight, or other types of annotations. 

• The resting periods are important in realistic depiction of the mouse movement. In fact, 
they contain the clicking points (you cannot click while the mouse is moving). 

• When you are narrating something, keep the mouse at rest. 

• Before clicking any important control, first prepare the viewer, by (a) describing which 
control you are going to click, and (b) what will be the consequence of that action. That 
way, viewers will be able to observe the action closely and correlate the happenings 
on the screen. It is a poor practice to first do something and then tell the viewer about 
what you did. While viewers struggle to make sense of what you said, they would lose 
track of what you say next. 

Continuation of Cursor Paths between Slides 

Normally, when you drag the start or end points of a path, ActivePresenter will also move the 
corresponding end point on the previous or next slide to ensure a smooth movement of the 
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cursor in the rendered presentation. That’s thanks to the Cursor Snapping tool  in the View 
tab. 

Let us explain this with an example: In the following figure, the end point of the cursor path (1) 
in a slide has the same coordinates as the start point of the cursor path (2) on the next slide. 
As result, when the rendered presentation transitions from the first slide to the next one, the 
movement of the cursor appears to be continuous (without any jerks). 

 

If you move the end point (or the start point) on any slide, ActivePresenter automatically moves 
the corresponding point on the other slide, to again match their coordinates: 

 

If you don’t want the cursor path to move continuously between slides, go to the View tab and 

turn off Cursor Snapping . 

Besides, in rare cases, the cursor path can be out of sync. For example, when you delete a 
slide that is in the middle, or delete the cursor path on that slide. This results in an abrupt 
movement of the mouse cursor in the rendered presentation when the slide changes. 

To avoid this, you can again “stitch together” the ends of cursor paths of adjoining slides. Do 
as follows: 

• Right-click the start point, click Snap to Previous. 

• Right-click the end point, click Snap to Next. 

This will snap the start or end point of the cursor path on the current slide to the corresponding 
end or start point of cursor path on the previous or next slide. 
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Zoom-n-Pan 

Zoom-n-pan shows ActivePresenter where to zoom during playback. You can also use this 
tool when you want your audience to focus on a specific part instead of the whole screen.  

Consider this object with an example: 

In the following screenshot, the image of the Taj Mahal occupies the entire screen. Now 
imagine you were standing on the right minaret. You would like to zoom in that minaret.

 

To insert a zoom-n-pan object, do as follows: 

1. Click Annotations > Zoom-n-Pan . The zoom-n-pan rectangle appears on the 
slide. That resizable rectangle must always match its aspect ratio to the project’s 
aspect ratio. 

2. You can change the size and position of the zoom-n-pan rectangle directly on the slide. 
Move the rectangle over the minaret. Make it small enough so that the zoomed-in view 
focuses there. 

3. In the Timeline, adjust the timing and duration of the zoom-n-pan object. 
ActivePresenter will start to zoom in at the start point of the object and end at the green 
diamond. The zoom should not be too fast, otherwise it becomes nauseating. 

You can also change those properties in the Properties pane and select the mode in which 
the zoom effect will be shown in the Show In Mode section.  
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When the slide is rendered, the camera shows the entire scene, and then zooms in and 
simultaneously pans sideways to the minaret. Note that the zoom-n-pan object has a one-way 
effect: When it ends, it does not restore the zoom back to normal. So, the camera will keep 
looking at the minaret till the slide ends. 

Fortunately, there is a trick: Use another zoom-n-pan object to zoom back to normal. Resize 
the rectangle to cover the entire slide. In the Timeline, place it apart so that you have a few 
seconds of close up at the minaret (the camera should not start zooming out abruptly). Set its 
duration so that the zooming out is smooth and unhurried (it should not be too fast). The 
combined effect of the two zoom-n-pan objects will be what you need. 
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Closed Caption 

Closed caption (CC) is exactly like subtitles you see during a movie. Actually, the key term is 
captions. The qualifier term “closed” means that the user (and not the author) has the power 
to display or hide the CC lines. 

 

The above screenshot shows only one CC line, which typically lasts for a few seconds on 
screen. A typical slide would have tens (or hundreds) CC lines. The screenshot below shows 
three CC lines in the Timeline pane. The duration of each line is shown with a rectangle (Time 
Bar). 
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A closed caption object is quite different from other object types: 

• A slide may have no CC line or multiple CC lines. All CC lines in a slide are considered 
as one CC object. 

• The CC lines are arranged in time order and there is no overlapping in time between 
CC lines. That means only one CC line can be displayed at a time. 

• You cannot switch the order of the CC lines. 

• You can only toggle the lock and visibility state of all CC lines at a time by clicking the 

 and  icons on the left side of the Timeline pane. (As all CC lines are considered 
as one CC object.) 

• The visual properties of all CC objects can only be set globally in the project: You 
cannot set a different visual property for each CC object. In other words, if you change 
the style of the CC on one slide, it will be applied to the CC on all other slides of that 
project. 

• CC lines are often converted into speech. When converted, all lines of a CC object 
produce a combined single audio object.  

Adding Closed Captions 

To add a CC line to a slide, do the following steps: 

1. In the Timeline pane, place the Playhead at the timestamp that you want to add the 
CC line. If the timestamp is not specified, ActivePresenter will append the new CC line 
to the end of all existing CC lines. 

2. Click Annotations > Closed Caption  or click the Insert Caption button  in the 
Timeline pane. A Time Bar will appear in the closed caption line.  

3. Drag the CC Time Bar to adjust the start time and duration of the closed caption. 

To remove one or more CC lines from the slide, select them and press the DELETE key.  

To edit the text of a CC line, do as follows: 

1. In the Timeline pane, place the Playhead at the timestamp that the CC line is 
displayed. 



ActivePresenter User Manual  Version 7 

Non-Interactive Objects > Closed Captions  136 
 

2. Click the CC object on the Canvas to start editing with commands provided in the 
Home tab (2). You can change the font, size, color, and style of the text. 

 

To adjust the CC line, select it in the Timeline and go to the Properties pane. Note that you 
can select multiple CC lines along the Timeline. 

• Open the Style & Effects tab to change the fill style, color, and opacity for the CC. 

• Open the Size & Properties tab > Caption to specify the exact start time and duration 
of selected CC line in seconds. Also, specify the Text To Speech properties (voice, 
speed, volume) for converting the text in selected CC lines to audio. 

 

Adjusting Closed Captions in Timeline 

If you have annotated the slide with shapes and zoom-n-pan, your closed captions and Text 
To Speech (TTS) must refer to the feature that is being highlighted at that particular moment. 
However, this does not happen automatically. There may be several sync problems: 

• The CC may run into the subsequent scene which has no relation to what the CC is 
talking about. 

• The converted audio may interfere with an audio embedded within the slide during 
capturing phase.  
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• The converted audio may overlap with TTS audio of other objects (shapes, for 
example). 

• The converted audio may overlap with other stand-alone audio/video objects. You 
have to check the project for these problems and sort them out. 

To synchronize the CC with your annotations, go back to the slide and look at the Timeline. 
Each CC appears in the Timeline as a separate Time Bar. Look at its relationship with other 
objects in the Timeline, and adjust the Time Bars. 

• Display each CC for adequate time so that your audience can read it comfortably. The 
longer the CC is, the more time it needs to be shown. 

• If you have used TTS narration, it needs to be read fully while the corresponding 
feature is still highlighted. 

This is not a problem for most objects, as you can simply lengthen their Time Bars in the 
Timeline. In case of videos, you can freeze the frame for a few moments till the narration and 
CC play out. After that, resume the playback. 

When you adjust the CC Time Bars in the Timeline, changes are reflected in the Closed 
Caption editor. Consider the following example: 

The following screenshot shows the Taj Mahal project. It shows three Time Bars in the closed 
caption line, which means there are three captions. 

 

The Time Bars in the Timeline were adjusted as follows: 

• The first CC introduces the Taj Mahal; therefore, it must start after a couple of seconds. 
The start time of the Time Bar was pushed back by 1 second. The duration of the CC 
was adjusted so that the audience can read the text comfortably. 
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• The intent was to zoom in a minaret (2a), and reveal an amazing fact that the minarets 
are intentionally built tilted, so that from afar, they actually look perfectly vertical. So 
the zoom-n-pan (2b) takes the audience to the minaret. 

• Once the view is zoomed in, the second CC is displayed. Since this is a longer 
sentence, more time is given to it. 

• Another zoom-n-pan brings the view back to normal. This is intentionally done at a 
faster pace, because it only reverts to the full view that was already there. After that, a 
small gap is allowed so that the audience can reorient themselves. 

• Finally, the third caption starts. Adequate time is given so that the audience can read 
it comfortably. 

Here are some tips for manipulating CC lines that can help you position the CC Time Bars 
correctly (for example, to synchronize with the audio): 

• You can select multiple CC Time Bars by using SHIFT+Click (to select all adjoining 
Time Bars) and/or CTRL+Click (to select all non-adjoining Time Bars). 

• You can shift multiple selected CC Time Bars simultaneously by dragging the mouse. 

Converting Closed Captions to Speech 

To convert a CC into speech, right-click the CC and select Convert Closed Caption to Audio 
from the context menu.  

The conversion process starts. After that, ActivePresenter will ask whether to extend the 
duration of the CC object to match the duration of the converted speech. 

 

Click Yes if you want to match both the durations for the currently selected CC. You can select 
the check box at the bottom to always extend the duration of the CC to match that of the 
converted speech from now on. 

Note: It’s possible to adjust the speed and/or volume of a CC and apply the same setting to 
other CC lines. To do that, right-click a CC and select Apply Speed/Volume For All Caption 
Nodes from the context menu.  

Besides, ActivePresenter provides a batch operation to convert all CC objects into speech in 
one stroke. 

Open the Slide tab > Batch Operations > Convert Closed Captions To Audio. The 
following dialog appears: 
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1. In the top section, define the slides where you want to convert CC to speech. 

o You can do the conversion on all slides of the project, on the current or specific 
slides. 

o To limit the conversion only to specific slides, enter the comma-separated list in 
the input box. You can enter a range by separating the slide numbers with a 
hyphen. For example, “3-6” means slide number 3, 4, 5, and 6. 

2. Click the Change Default Settings button to set the Text To Speech parameters. You 
can select the TTS voice and adjust the speed and volume in the Text To Speech 
dialog: 

 

o To check the settings, enter a test sentence in the Preview input box, and click the 
Speak button to listen to the voice. 
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o If the results are not OK, change the parameters and try again. Repeat the cycle 
till you are satisfied. 

o If your settings are too unsatisfactory, click the Reset button and start over. 

o When you are satisfied, click OK to return to the main dialog. 

3. In the main dialog, the check box at the bottom (3) extends the duration of each CC 
object to match the duration of the converted speech. This may cause sync problems, 
so you have to check out the project carefully. 

Note that even when you have already converted many CC objects, you can still launch this 
batch operation safely, without any adverse effects. 

Miscellaneous Tips 

Here are some general tips for using closed captions: 

• Always ensure correct spellings. 

• Use words that match the actual voice narration. Do not try to paraphrase; otherwise 
the audience may find it hard to read the CC. 

• Use punctuation to clarify the meaning. If a sentence ends normally, use the 
appropriate mark (.?!) at the end. However, a sentence that is left unfinished should 
end with an ellipsis (…). 

• Translate foreign words in parenthesis ( ). 

• Use italics (or ALLCAPS) to denote a new word or a heavily emphasized part of 
speech. 

• Show music or other sound effects in square brackets, such as [music], [door slams], 
[crowd at the bar], or [laughter]. 

• Use square brackets to describe any mood conveyed through voice modulation, such 
as [whispers], [shouts], [menacingly], [croons], [sobs]. Always use the appropriate 
word to convey the degree of intensity of an action. For example, chuckles, smiles, 
laughs, and guffaws are all different. Similarly, door closes and door slams convey 
entirely different moods. 

• When the speaker is off screen, identify him/her by name. 

• When more than one person is on screen, identify the speaker by name.  

• As a rule, show only one line of closed captions at a time. 

An exception is when multiple people speak simultaneously. In that case, it is OK to show their 
sentences together; but always maintain the correct sequence (a sentence that starts first 
should be listed at the top of the CC stack). 

Another exception is when one person is interrupted by another. Here, end the first 
(interrupted) sentence with a dash “–“; and place the second (interrupting) sentence in the 
second line.

 

  

https://en.wikipedia.org/wiki/Punctuation


ActivePresenter User Manual  Version 7 

Audio & Videos > Overview of Audio & Videos  141 
 

Audio & Videos 

Overview of Audio & Videos 

Inserting Audio & Videos 

In ActivePresenter, you can insert audio and video tracks into your slides to engage your 
audience. ActivePresenter currently supports audio/video formats as follows: 

• Audio: MP3, OGG, WMA, and WAV. 

• Video: MP4, MKV, WMV, FLV, AVI, and WebM. 

Inserting Audio  

An Audio object is displayed on the Canvas as the  icon and its Time Bar is displayed in the 
Timeline. The Canvas icon is just a visual indicator to remind you that there is an audio object 
on the slide. Its placement on the Canvas does not matter as this icon is not visually rendered 
in the final output. 

In a recorded project, a new audio object is created when you narrate the operation of the 
target software and record system audio. 

Later, during the editing phase, you can add audio objects to the slide in three different ways: 

• Insert an audio file. 

• Record a new audio track. 

• Convert text to speech. 

To insert an audio file into a project, click Annotations > Audio  > From File… and choose 
an audio file you want to insert. You can also drag an existing audio file from Explorer or the 
Resources pane and drop it onto the Canvas. 

To insert an empty audio object which will be later used for recording or converting text to 

speech, click Annotations > Audio  > Create New. 

For recording a new audio track or converting text to speech, you can refer to the Audio tab 
for more details. 

Depending on how the audio objects are created, they are displayed in three different ways: 

• When an audio object is inserted into a slide, an Audio icon  is displayed on the 
Canvas (only in the editing mode; not in the output). The Timeline displays the Time 
Bar of the audio object. 

• When an audio track is attached to an object (for example, the audio attached to a 
shape), the Timeline displays its waveform bar within the target object Time Bar. There 

is no Audio icon  on the Canvas. 

• When a closed caption is converted into audio, a separate audio object is created. The 
Timeline shows a separate audio object Time Bar. 

In all cases, the object Time Bar in the Timeline shows the actual audio waveform, which 
facilitates editing. 
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Inserting Video 

To insert a video into a slide, click Annotations > Video  > From File… and select an 
existing video file to insert. You can also drag an existing video file from Explorer and drop it 
onto the Canvas. 

To record a video from webcam, click Annotations > Video  > Webcam Recording. A 
dialog appears allowing you to record your webcam. 

 

a) Webcam 

• Device: Any detected webcam device will appear in the Device drop-down list. Select 
the webcam device you want to use from the list.  

• Refresh: Click the button to refresh the Device list. 

• Properties: Click the button to adjust video signal and camera control. 

• Settings: Click the button to fine-tune video format and compression. 

b) Audio 

• Device: Any detected audio input device will appear in the Device drop-down list. 
Select the device you want to use from the list. 
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• Volume: Click the button to adjust the input audio signal level for the audio input 
device. 

• Calibrate Input…: Click the button to open the Calibrate Audio Input dialog. From 
here you can change the audio input volume automatically or manually. 

Typically, after inserting a video, the next step is to resize and reposition the video frame. Do 
that by dragging the resizing handles on all edges and corners. 

You can insert multiple frames into a slide and play multiple videos simultaneously. 

• Play two videos side by side in a before-after scenario, or 

• Play multiple videos side by side to compare different techniques (for example, bowling 
action, batting strokes, biking posture, running, etc.). 

Playback Options 

You can go to Properties > Media > Audio/Video > Playback Options to control how an 
audio/video plays. There are three generic options: 

• Loop: Make the audio/video replay continuously. 

• Autoplay: Make the audio/video start playing as soon as the object starts showing.  

• Show Media Controls: Display a separate playbar for the audio/video in HTML5 
output. This playbar allows users to control the playback. 

For audio tracks, there is one specific option named Background Music. Select this option to 
set an audio track as background music of the presentation. See Background Music for more 
details. 

Exporting Audio & Video 

ActivePresenter allows you to export audio and video object. You can export the audio/video 
tracks you’ve inserted into your project or the ones that you’ve created within your project.  

To export audio/video tracks, do the following steps: 

1. Select an audio/video track. 

2. Right-click and select Export To File… from the context menu. 

3. Specify the file name, file format, and file location, then click Save to export. 

Currently, ActivePresenter lets you export audio/video tracks to the file formats as follows: 

• Audio: MP3, OGG, and WAV. 

• Video: MP4, MKV, WMV, FLV, AVI, and WebM.

Basic Editing  

Range-Editing 

The Timeline pane has four Range-edit commands  that work only when a 
range is defined first. 
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Consider these commands with the following examples, in which each command is used in 
two different circumstances: (a) when none of the objects are selected, and (b) when some 
objects are selected. 

Each set has three screenshots: (1) the original objects, (2) result when none of the objects 
are selected, and (3) result when some objects are selected. 

Cuting Range 

The Cut Range command  places the cut contents on the clipboard. You can paste these 
contents into the current slide or the new one. 

The following example shows the effect of the Cut Range command when no objects are 
selected on the slide: 

 

Original slide 

 

No object selected 

The slide and all objects are edited. 
The entire slice of the range (with 
the parts of objects enclosed in it) is 
cut away. Thus, the slide duration is 
reduced by the duration of the 
range. 

If an object spans on both sides of 
the range, its remaining parts are 
joined. (Shape 1). 

Shape 4 is deleted, because it is 
completely inside the range. 

When some objects are selected, the Cut Range command behaves differently, as shown in 
the following example: 
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Original slide 

There are two identical sets of 
objects (1-6; 7-12). 

Only one of the two sets is selected 
to show the difference. 

 

At least one object selected 

Only selected objects are edited. 
The slide itself and unselected 
objects (7-12) are not affected at all. 

For the selected objects only: The 
range is folded up and then 
removed. Any object parts that lie in 
the range are deleted (Shape 3 & 5). 
Shape 4 is deleted, because it is 
completely inside the range. 

Objects/parts that follow the range 
are shifted to the left by the duration 
of the range (Shape 1, 2, & 3). 

If a selected object spans on both 
sides of the range, its remaining 
parts are joined (Shape 1). 

Copying Range 

The Copy Range command  copies parts of objects that fall inside the range, and puts them 
on the clipboard. 

• If there is no selected object, the Copy Range command checks all objects on the 
slide. 

• If there is at least one selected object, the Copy Range command checks only these 
selected objects. 

• If an object does not have any part inside the range, it is not copied. 

The following figure illustrates these conditions: 
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No object selected 

 

Some objects selected 

 

 

All objects’ paths falling inside the range are pasted at 
the Playhead position. 

 

Only parts of selected objects falling inside the range 
are pasted at the Playhead position. 

Note that the lower figures show fresh slides into which the clipboard contents are pasted. 
Just imagine that a slice is taken out of the original slide, and placed at the Playhead position 
on the current or another slide. 

Deleting Range 

The Delete Range command  works just like the Cut Range command, except for one 
difference: The Delete Range command is used to delete the contents inside the range; 
whereas the Cut Range command “cuts” the contents from the range and places them on the 
clipboard, then you can paste them where you want. 

In short, the Delete Range command stands for removing while the Cut Range command 
stands for reallocating.  
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Cropping to Range 

The Crop to Range command  simply deletes everything but what is inside the range. 

 

Original slide 

 

No object selected 

Only the contents of the range are 
retained, and the rest is deleted. 
Thus, the slide duration is reduced 
to the duration of the range. 

If an object does not have any part 
inside the range, it is dropped. 
(Shape 2 & 6). 

When there are some selected objects, the Crop to Range command behaves differently, as 
shown in the following example: 

 

Original slide 

There are two identical sets of 
objects (1-6; 7-12). 

Only one of the two sets is selected 
to show the difference. 



ActivePresenter User Manual  Version 7 

Audio & Videos > Basic Editing  148 
 

 

At least one object selected 

Only selected objects are edited. 
The slide itself and unselected 
objects (7-12) are not affected at all. 

The parts of the selected objects 
that lie inside the range are retained. 

If a selected object does not have 
any part inside the range, it is 
deleted entirely from the slide. 
(Shape 2 & 6). 

Splitting & Joining Audio/Video Objects 

Splitting Audio/Video Objects 

The Split Audio/Video Objects command  splits the selected audio/video object at the 
Playhead position. 

 

• The Timeline shows the latter part as a new object, but it is still placed in the same 
object line with the other one. 

• The split parts are treated as new project-level resources (which appear in the 
Resources pane), and can be further used on any slide within the project. 

• In case of audio objects, each split part is shown as a separate Audio icon  on the 
Canvas. However, all these icons are stacked together, so you can only distinguish 
between them when you drag them apart. 

Joining Audio/Video Objects 

The Join Audio/Video Objects command  joins the selected objects (either audio or video). 
You can join an audio object with other audio objects; and a video object with other video 
objects, but cannot join an audio object with a video object. 

When you select audio/video objects for joining, here's how ActivePresenter handles the job: 

• In the background, ActivePresenter maintains four separate lists of selected 
audio/video objects: 

o Selected audio objects on the current slide. 
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o Selected video objects on the current slide. 

o Selected audio objects that show over multiple slides. 

o Selected video objects that show over multiple slides. 

• Within each list, ActivePresenter sorts the objects by their start time in ascending order: 
If two or more objects (in each list) have the same start time, ActivePresenter sorts 
them by their z-order in ascending order (that is the bottom-up order in the Timeline). 

• For each list that contains at least two objects, ActivePresenter joins the objects in the 
order of their sorting. 

• The combined object is assigned to the first object in the list. All other objects in the 
list are deleted. 

• If any of the objects has effects applied to it (for example, silence, volume change), 
they are burned in before joining with the other objects.  

• If the source audio/video resource is logical (that is, created by any of the following 
operations: Cut, Crop, Paste, Delete, Split, Join, Insert Time, or Adjust Volume) and 
not used by any object, it will be deleted from the Resources pane. If it is a physical 
resource, or is currently in use, it still appears in the Resources pane. 

In addition, the newly joined object is added to the Resources pane.    

• The original audio/video objects may not have identical properties (for example, height, 
width, aspect ratio, resolution, fps, bit rate). ActivePresenter solves this problem by 
using all parameters of the first resource for its output. 

Within a project, the resources are joined only virtually: The actual joining of the objects takes 
place only when the presentation is exported (rendered), at which time ActivePresenter 
converts all objects from their respective formats into the desired formats and joins them 
directly. 

Changing Playback Speed 

Changing the speed of a video or an audio can be useful in many different situations. For 
example, you are creating a tutorial showing how to export videos in ActivePresenter. The 
time when you have to wait for the exporting process to complete should be speeded up to 
save the duration of your tutorial. 

In that case, you can use the Change Playback Speed command  in the Timeline pane to 
make that part of the video run faster. That way you will save the duration and the file size of 
video and provide better viewer’s experience. 

You can also use this command to slow down your video, making it look professional like the 
slow motion scene on TV. 

The command is only active when there is a selected audio/video object or a selected range 

of audio/video object in the Timeline pane. When you click the  button, the following dialog 
appears: 
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The input is a relative value in range 10%-1000%. ActivePresenter will scale the current speed 
of the selected range using this value. In case you want to quickly reset to the original speed 
of the selected range, select the Reset to original speed check box. 

Adjusting Volume Control 

If the slide has multiple concurrent audio tracks, you will have to ensure that only one of those 
tracks is dominant at a time, and the other tracks are either muted or with lowered volume. 
This balance keeps changing: In other parts of the slide, you may have to give dominance to 
other tracks. This is where the Adjust Volume control comes in handy. 

When you click the Adjust Volume button , the following dialog appears: 

 

Note that this is a relative volume scale, with a default value of 100% (means original volume). 
It can adjust the volume from 0 (means mute) to 500% (means original volume x 5). You can 
select the Mute check box to quickly silence the track. 

• The original track is not affected at all. You can revert to the original volume at any 
time. 

• If this control is used to mute a track, it does not affect the original duration of the track, 
because unlike the Freeze-Frame control, this control does not insert an additional 
period of silence. 

In short, the trick is to first set a range, and then select each of the audio/video objects and 
adjust their volume individually. Only the dominant track retains its full volume (or it may even 
be boosted), while you need to lower the volume for the non-dominant tracks (or even mute 
them altogether). 

These adjustments would be applied within the range only. Set another range in another part 
of the time axis and repeat this. This time a different track may be dominant. 

ActivePresenter displays the audio waveform proportional to its actual volume. So if you have 
applied volume control within a range, or muted the track within a range, it will be displayed 
as below: 
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• The 1-2 stretch is muted (the audio waveform appears as a straight line).  

• In the 2-3 stretch, the volume is boosted (the audio waveform appears bigger). 

• The 3-4 stretch is of original volume.  

• In the 4-5 stretch the volume is lowered (the audio waveform appears smaller). 

In all cases, the start and end points are marked with red vertical marker lines. Note that these 
markers cannot be moved within the Time Bar, because they actually denote the range in 
which the volume is altered. 

If you want to reverse the effect (for example, to make the volume normal), do as follows: 

1. Remember to turn Snap mode on by clicking the View tab > Timeline Snapping . 

2. Click anywhere on the Ruler to start a new range. 

 

3. Drag the Playhead to the start marker of the range. 

 

4. Drag the Playhead to the end marker of the range. 

 

5. Click the arrow next to the Adjust Volume button , select the Restore Original 
Volume option from the submenu. The Adjust Volume effect in the selected range will 
be removed, restoring to the original volume.   
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Advanced Audio Effects 

ActivePresenter supports advanced audio effects letting you improve your audio quality in 
general and recording quality in particular. Advanced audio effects including Audio Fade In 
(1), Audio Fade Out (2), and Audio Noise Reduction (3) are accessible from the Timeline 
pane. 

 

Audio Fade In/Out 

When you add an audio to a slide, you may often end up with a sudden start or end that can 
be rough on the ears. Audio Fade In and Audio Fade Out come in handy to smooth the 
beginning and end of an audio track. Fade In (1) begins with silence and gradually becomes 
louder until full volume while Fade Out (2) makes an audio progressively softer until it can no 
longer be heard.                                                                                                                      

 

The shape of the fade is linear as the volume rises or falls at a constant rate. Visually, it looks 
steady like a pair of straight lines from silence up to the original volume and vice versa. You 
can apply these effects several times to strengthen the fade. 

To apply Audio Fade In/Out, do as follows: 

1. Specify the audio range you want to apply the effect. 

2. In the Timeline pane, click Audio Fade In  or Audio Fade Out . Apply the effects 
several times if needed. 

Audio Noise Reduction 

Your recordings often have some background noise, regardless of the microphone quality. 
Audio Noise Reduction can reduce constant background noise such as tape hiss, electric fans 
or hums. This effect doesn't work well with inconstant noise like talking or music and is often 
best done by trial and error. You may have to try the effect several times until getting the best 
result. 

To apply Audio Noise Reduction, follow the two steps below: 

Step 1. Getting Noise Profile. 

1. Specify the range that contains only background noise. Note: If the selected range is 
too short, Getting Noise Profile will be not executed. You must select a minimum 2048 
samples, or about 0.05 seconds at 44100 Hz sample rate. 

2. In the Timeline pane, click the arrow next to the Audio Noise Reduction button , 
then select Get Noise Profile from the submenu. 
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Noise profile that you got will be stored in program. It will be lost if you close program or 
replaced by other noise profile when you get noise profile again. If there are different types of 
noise in different positions in the audio track, you should repeat the process several times. 
Pick the profile for the first type of noise, reduce the noise for it, then pick the next type and 
reduce that until you get your desired result. 

Step 2. Reducing Noise. 

After getting noise profile, you can apply Noise Reduction to a certain range in the audio track 
or to the entire track. You can even apply the effect to multiple tracks simultaneously. 

1. Specify the ranges or the audio tracks you want to apply Noise Reduction. You 
shouldn't choose a very short range because a longer selection is better to get a more 
accurate picture of the noise. 

2. In the Timeline pane, click the Audio Noise Reduction button . The Noise 
Reduction dialog appears offering necessary controls to reduce noise.  

 

You are free to adjust the Noise reduction, Sensitivity, and Frequency smoothing 
controls. 

o Noise reduction (dB): Start at 12 and adjust as needed. This controls the amount 
of volume reduction applied to the identified noise. Higher values reduce higher 
amount of volume reduction, making the noise quieter but can distort the audio 
track. Keep this control as low as possible. 

o Sensitivity: Start at 6.00 and adjust as needed. This controls how much of the 
audio will be considered noise, on a scale from 0 (off) to 24 (maximum). Greater 
sensitivity will remove more noise but can damage the track. Keep this control as 
low as possible. 

o Frequency smoothing (bands): Start at 3 and adjust as needed. This control is at 
values of 1 or higher. It spreads the noise reduction into the specified number of 
neighboring bands. Smoothing can make the desired audio less clear, so set the 
value to 0 if your desired signal is strong and of wide frequency range and the noise 
is low. 

3. Click OK to apply the effect to the selected ranges/audios with the current effect 
settings. 

Sometimes a recording has no noise sample available as in a tape recording of a song - there 
is no part that contains only background noise. In that case, you can create a recording made 
in identical conditions that contains silence only then use a noise sample from that to reduce 
noise from the recording you want. 

If the Noise Reduction effect doesn’t work as well as you expect, that is, it removes not enough 
noise or removes too much and damages the audio track, you can press CTRL+Z and try 
Noise Reduction again with different settings. You don’t have to get a new Noise Profile if you 
think the existing is good enough.  
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Freeze-Frame Control 

The Freeze-Frame control works on both audio and video objects, as described below:

• If the selected track is a video track, the control pauses the video for any desired 
period. 

• If the selected track is an audio track, the control inserts an interval of silence. 

To insert a Freeze-Frame control into an audio/video track, do the following: 

1. Select the audio/video object. You can select multiple objects at once.  

2. Seek the Playhead along the Timeline Ruler to the timestamp where you want to pause 

the track. This activates the Insert Time button  in the Timeline pane.  

3. Click the Insert Time button to open the Insert Time dialog.  

4. Specify the duration of the control and click OK to finish. 

 

A yellow diamond and a yellow bar will get superimposed on the audio/video object Time Bar. 
While the yellow diamond specifies the point to play the click sound of the Cursor effects, the 
yellow bar represents the pause you’ve inserted into the audio/video object.  

 

• If you have defined the Freeze-Frame duration in the previous step, the yellow bar is 
adjusted to this duration. However, the usual practice is to drag the diamond and the 
right-side edge of the yellow bar to change the start time and duration of the control. 
During this dragging operation, ActivePresenter shows precise timestamp on the Ruler 
(as in case of entrance/exit markers). 

• Each Freeze-Frame control extends the host track by its duration. In other words, if 
you insert an n-second pause in an audio/video track, its total duration will be increased 
by n seconds. 

• You can insert any number of pauses in any selected track. The only condition is that 
two pauses cannot overlap. 

To remove the Freeze-Frame from its host track, in the Timeline, click the pause and drag it 
downward out of the Time Bar of the host track. Keep dragging till the pause turns gray, and 
then release the mouse button. The pause will disappear, and the duration of the host track 
will be reduced by the duration of the pause. 

So why don't we simply split the track, and shift the latter part to achieve the same end-result? 
The answer here is that Freeze-Frame control has two benefits: 

• It is easier to remove (to reverse its effect). 
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• It does not create extra resources by splitting the original object. 

Note that this control also works on other types of elements in ActivePresenter. Basically, it 
inserts an interval of time into the selected object at the position of the Playhead. For example, 
if the duration of a shape is 3 seconds (3000 ms) and you insert 2 seconds (2000 ms) into its 
duration, then the total duration of the shape will be 5 seconds (5000 ms). 

In case that there is no selected object in a slide, the control will insert an interval of silence 
into the entire slide and all objects that appear at the Playhead position (object 2 & 3). Other 
objects that do not intersect with the Playhead (object 1) will not be affected at all. 

 

Pausing Video Tracks (Freezing Scenes) 

When the slide is played in preview mode (or exported), the host video is paused for the 
duration of the Freeze-Frame control. However, the other objects on the slide are played 
normally. 

Sometimes a video contains a significant scene, which lasts only for a few seconds. The scene 
is over before the audience has enough time to absorb the important clues. If this were a live 
lecture, you would pause the video and explain various parts of the frozen scene to your 
audience. But that is impossible in a self-running video. 

This is where the Freeze-Frame comes in hand. It allows you to pause a video for a certain 
duration. You can extend this pause as long as you want, and add a commentary track or 
annotations to analyze the frozen video frame. 

 

In the above example, the video in Video_1 object is frozen, and an audio commentary is 
introduced in the pause. During this time, an annotation shape is also displayed on the screen, 
and two closed caption lines appear. While the video is paused, all these other objects are 
played normally. 

Note that you can insert any number of Freeze-Frame controls in a video track. This allows 
you to pause the video any number of times and explain those frames to your viewers. 

Pausing Audio Tracks (Inserting Silence) 

When a Freeze-Frame control is inserted in an audio track, it inserts an interval of silence. 
When the slide is played in preview mode (or exported), the host audio track is paused for the 
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duration of the Freeze-Frame control. However, the other objects on the slide are played 
normally.

Normally you would only apply this control to a significant audio track that needs to be 
synchronized with the visual part of the presentation (for example, you would not need it for 
background music track). A typical example is to re-sync a stand-alone commentary track with 
the rest of the slide by holding it off for a few seconds. 

Blur Effect for Videos 

Blur effect is used for hiding sensitive information such as identity, email address, etc. You 
can insert one or multiple Blur effects into a video. To insert a Blur effect, select the video 
object and do the following steps: 

1. Specify the position where you want the Blur effect to start showing. 

2. Click the Insert Blur Area button  in the Timeline pane. 

3. In the pop-up dialog, specify the duration of the effect, then click OK. 

4. Adjust the size and the position of each keyframe in the effect to match the contents 
of the video. 

Blur effect is represented in the Timeline as a green bar when selected. When not selected, it 
is light blue: 

 

In the Properties pane, a Blur effect has the following properties: 

 

Property Description 

Blurriness The higher value, the lesser detail of contents. 

Blur Orientation Select from: Horizontal and Vertical, Horizontal, and Vertical. 

Mask Type Set the form of the Blur area. Select from Rectangle and Ellipse. 

To change these properties, select the blur Time Bar in the Timeline to open the Blur Effect 
section in the Properties pane. 

In case the target object maintains the same size and position, you only need to change the 
start time and duration of the Blur effect by dragging the blur Time Bar in the Timeline.  
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On the other hand, if the target object changes its size and position, you have to insert more 
keyframes to cover it precisely. Each keyframe marks one specified area in the video. Then 
the size and the position of the Blur effect at any timestamp will be interpolated from the values 
of nearest keyframes on the left and right of the timestamp. The more keyframes you insert, 
the more exactly the Blur effect and the moving object path fit. 

To add more keyframes, specify the video object Time Bar. Then, do as follows: 

1. Seek the Playhead along the Timeline Ruler. 

2. Adjust the blur area size and position on the slide by dragging the blur object’s handles. 
ActivePresenter will automatically insert a new keyframe each time you change the 
size. You can also add new keyframes by clicking the Add/Remove Keyframe button 

 in the Timeline pane.  

From the position of the Playhead, to navigate to the next keyframe, click the Go to 

Next Keyframe button , to navigate to the previous keyframe, click the Go to 

Previous Keyframe button . 

To delete the effect, drag the Time Bar downward until it grays out and release the mouse 
button. Do the same to delete blur keyframes. Or you can place the Playhead at its timestamp 
(with the support of the Snap mode) then select the Add/Remove Keyframe button to delete 
it.

Cursor Effects in Recorded Videos 

When you record a screencast, you can record the mouse cursor and edit the Cursor effects 
of the recorded video after that. To enable this feature, select the two options Record Mouse 
Cursor and Make Cursor Editable for Full Motion Recording selected in the Cursor tab of the 
Recording Settings.  

To change the Cursor effects of a recorded video, you need to select the video and go to 
Properties > Media > Cursor Effects. The Cursor effects have the following options

Property Function 

Render Cursor Display the cursor, highlight effect, click effects, and play the click 
sounds when playing the video. 

Cursor Highlight Additional contents drawn around the cursor to highlight it. 

   

Type Type of highlight effect. Select from: None, Circle, and Square. 

Size Size of highlight effect. It is the radius of the circle in the Circle highlight 
or half of the width of the square in the Square highlight. 

Color The color which is used to draw the highlight. 

Opacity The opacity which is used to draw the highlight. 

Click Effects  Play a sound and render an animation when the mouse is clicked. You 
can customize the Left-Click Effect, Right-Click Effect, and Left Double-
Click Effect separately. 
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Click Sound The sound which is played when a mouse button is pressed. 

Click Effect The animation effect which is rendered when a mouse button is 
pressed. Select from: None, Circle, Concentric Circles, and Square. 

Size The size of the click effect. 

Color The color which is used to draw the click effect. 

Opacity The opacity which is used to draw the click effect. 

Picture-In-Picture Effect for Videos 

A picture-in-picture (PIP), also known as a Video Overlay, is when two media streams share 
the same display screen, the smaller one is superimposed on the bigger one. Normally, the 
main one is displayed on the entire screen, and the small one is displayed in a small window 
located in any part of the screen.  

The media streams can be two video clips or a logo placed at the corner of a video clip. You 
can use the picture-in-picture effect to insert an additional video (such as a webcam video) 
into the main video, creating the effect you often see in eLearning courses or how-to videos. 

 

ActivePresenter allows you to use picture-in-picture effect in video editing. Do as follows: 

1. Insert a superimposed video (or an image) into a slide. 

2. Drag and drop the superimposed to any place or corner of the main video.  

Keep in mind that the two videos shouldn’t be placed in the coincident position; 
otherwise, they will overlap each other, making the effect ineffective.  

3. Resize the superimposed to the size you want. 

4. Change the timing of the superimposed by dragging its Time Bar along the Timeline. 

5. Add animation effects or other effects to edit it (optional). 
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6. Insert a zoom-n-pan to make the audience focus on the superimposed instead of the 
entire screen (optional).  

Green Screen Effect for Videos 

Green screening, technically known as chroma-keying, is the technique of masking a video by 
keying out a background of a consistent color, so you can put one video on top of another. 
You often see this technique in movie stunts or in weather forecast where a presenter stands 
in front of a moving weather map. 

Basically, green screening works as your tool chooses a specific color and makes it 
transparent - all pixels having that color become transparent. Although it’s called green 
screening, you don’t have to use a green screen all the time. In fact, any solid color can be 
used theoretically, but green is the most commonly used because it provides a good contrast 
and luminescence and rarely occurs on human body.  

 

To apply Green Screen effect, do as follows: 

1. Select a video object. 

2. In the Properties pane, select Media > Green Screen Effect. 

3. Specify a color in the Color Picker.  

4. Move the Tolerance slider to adjust the range of color to key out. Higher values key 
out a wider range of color near the key color. 

If you don’t satisfy with the result, click the Reset Color button to revert all changes. 

Background Music  

ActivePresenter makes background music possible. Background music plays across slides in 
the background of the slide show. Background audio can be music, sound effects, etc. 

To set an audio track as background music, bear in mind the following: 

• Background Music: Go to the Properties pane > Media > Audio > Background 
Music to make the track continue playing when the presentation is paused. That way, 
in an interactive presentation, while the presentation pauses to wait for user input, 
background music still plays. 

• Loop: Go to the Properties pane > Media > Audio > Loop to make the track replay 
automatically when the playback is finished. After selecting Loop, you can drag the 
end point of the audio Time Bar to the duration you want.  
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You can also right-click the audio Time Bar and select Play to the End of Slide to 
make the audio duration equal the slide duration.  

• Play over Multiple Slides: Your presentation may have more than one slide. If you 
want background music to play continuously throughout all slides, right-click an audio 
object, click Play over Multiple Slides > Top Layer or Bottom Layer. Note that the 
layer you place the audio object only affects the stack order of objects in a slide.
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Interactive Objects 

In ActivePresenter, you can make your projects interactive by using various types of interactive 
objects. They are special objects designed to respond to user input in a predefined manner. 
Users can interact with them using keyboards, mice, or other input devices. 

Interactive objects not only change the course of the presentation based on user input, but 
also keep track of user activities (for example, assess user performance in a test). Interactive 
objects are listed as follows: 

Object Icon Usage 

Mouse Click 

 

Respond when the user clicks in a predefined area. Use of 
modifier keys (ALT, CTRL, and SHIFT) is also allowed.  

Key Stroke 

 

Respond to an individual key on the keyboard or a hotkey (such 
as CTRL+SHIFT+P). 

Text Box 

 

Respond when the user enters specific text (string). 

Drop Area 

 

Respond when the user drops a drag source onto it. 

Button 

 

Respond when the user clicks it. 

Check Box 

 

Respond when the user clicks a check box. 

Radio Button 

 

Respond when the user clicks a radio button. 

Questions 
 

ActivePresenter allows you to insert nine different types of 
questions (True/False, Multiple Choice, Multiple Response, 
Essay, Fill in Blank, Fill in Multiple Blanks, Sequence, Drag-n-
Drop, and Rating Scale). 

The question and options appear on the screen, and the viewer 
is expected to respond within a predefined time. ActivePresenter 
can be programmed to take different actions depending on 
whether the response is correct or incorrect; or if the viewer fails 
to respond within the time limit. 

Events & Actions 

Interactive objects come with events and actions. For any of these objects, you can specify 
the events (for example, “when the mouse rolls over this shape”), and what actions should be 
taken for those events (for example, “display the hint message”). 
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In older versions of ActivePresenter, interactions are managed in the Event Editor dialog. From 
version 7, the Event Editor no longer exists. Instead, you can set up and manage interactions 

in the Interactivity tab  of the Properties pane. 

Events  

Events are used to trigger actions - in other words, when an event is detected, one or more 
actions are provided as a response.  

Events available for objects and slides are explained as below: 

Event  Description 

On Click This event is available for Mouse Click, Button, Drag Source, Drop 
Target (not including Drop Area), Shapes (including all message 
types), and Image. It occurs when users click these objects. 

On Key Press This event is only available for Key Stroke. Users can define 
actions for each Key Stroke value. All keys except WINDOWS key 
are supported.  

Note that there are different keyboards for different languages. 

On Text Enter This event is only available for Text Box. Users can define actions 
for each entered text value. 

On Check This event is only available for Check Box and Radio Button. It 
occurs when the object is clicked. 

On Drag Start This event is only available for Drag Source. It occurs when the 
object is dragged from its location. 

On Drag End This event is only available for Drag Source. It occurs when users 
release the mouse button (end the dragging) while dragging the 
object. 

On Drag Enter This event is only available for Drop Area and Drop Target. It 
occurs when the Drag Source enters the Drop Area/Drop Target. 

On Drag Leave This event is only available for Drop Area and Drop Target. It 
occurs when the Drag Source leaves the Drop Area/Drop Target. 

On Accept This event is available for Drop Area and Drop Target. It occurs 
when any accepted Drag Source is dropped onto the Drop 
Area/Drop Target. 

On Reject  This event is available for Drop Area and Drop Target. It occurs 
when any rejected Drag Source is dropped onto the Drop 
Area/Drop Target. 
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On Correct This event is available for all graded interactions. It occurs when 
users give a correct response. 

On Incorrect This event is available for all graded interactions. It occurs when 
users give an incorrect response. 

On Complete This event occurs when the Question is answered or the Text Box 
is filled. It is only available when the mode of the Question or Text 
Box is survey. 

On Incomplete This event occurs when the answer is incomplete, for example: 

• Users leave a field blank in the Text Box object or Question 
objects that contain a text box (Fill in Blank, Fill in Multiple 
Blanks, and Essay). 

• Users leave all check boxes or radio buttons unchecked in 
case of True/False, Multiple Choice, or Multiple Response. 

• Users leave all drop targets empty (contain no drag source) 
in Drag-n-Drop question. 

On Timeout This event is available for all graded interactions. See Common 
Question Properties for details.  

It occurs when viewers don’t respond within the specified time. 

On Rollover This event is available for Mouse Click, Key Stroke, Text Box, 
Button, Check Box, Radio Button, Drag Source, Drop Area, Drop 
Target, Shapes (including all message types), and Image.  

It occurs when the mouse rolls over the shape of the object (enters 
the boundary of the shape). 

On Rollout This event is available for Mouse Click, Key Stroke, Text Box, 
Button, Check Box, Radio Button, Drag Source, Drop Area, Drop 
Target, Shapes (including all message types), and Image.  

It occurs when the mouse rolls out of the shape of the object (exits 
the boundary of the shape). 

On Swipe Left This event is available for Button, Drop Target (not including Drop 
Area), Shapes (including all message types), and Image.  

It occurs when users swipe across these object to the left on the 
touch screen. 

On Swipe Right This event is available for Button, Drop Target (not including Drop 
Area), Shapes (including all message types), and Image.  

It occurs when users swipe across these object to the right on the 
touch screen. 
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On Swipe Up This event is available for Button, Drop Target (not including Drop 
Area), Shapes (including all message types), and Image.  

It occurs when users swipe across these object to the top on the 
touch screen. 

On Swipe Down This event is available for Button, Drop Target (not including Drop 
Area), Shapes (including all message types), and Image.  

It occurs when users swipe across these object to the bottom on 
the touch screen. 

On Load This event is only available for Slide. It occurs when the slide starts 
displaying. 

On Unload This event is only available for Slide. It occurs right before the slide 
ends. 

Actions 

Actions are always paired with events, that is, they occur in response to events. For example, 
when you click a link in a slide, a new browser tab or window automatically opens.  

See Adding & Removing Actions for more details about how to work with actions. 

Action Description 

Presentation 

Continue 
Presentation  

The action depends on the current state of the presentation: 

• If the presentation is playing, this action does not change 
anything. 

• If the presentation has paused, this action will continue 
playing the presentation from the time it pauses. 

You can pause a presentation in two ways: 

• Go to Properties > Interactivity > General and select the 
Pause presentation to wait for user input check box for 
any interactive object. That way when the object is played, 
the presentation will pause.  

You can choose between pausing the presentation just 
before hiding the object or pausing it after showing the 
object for a specific amount of time.  
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• Execute the Pause Presentation action (see below). 

Pause Presentation The presentation’s main stream is halted (all objects stop playing 
against the time) but the user can still interact with interactive 
objects. 

The presentation is paused indefinitely, until one of the following 
actions is executed: Continue Presentation, End Presentation, Go to 
Slide, Go to Slide at Index, Go Forward, or Go Backward. 

End Presentation Exit the presentation. 

Slide 

Go to Slide Go to a specified slide. Note that the link is made to a specific slide: 
If you move that slide to a new position, the link will follow it, and 
jump to the new position. If the target slide is deleted, the link gets 
dissolved automatically. 

Go to Slide at Index Go to a slide which has a specified index. Note that when you add, 
remove, or shuffle slides, another slide may take the place of the 
current slide. Regardless of that, this command will jump to the nth 
slide in the order. 

Go Forward Go forward by a specified number of slides. Note that the target is 
not a specific slide: The jump will land on any slide that is presently 
n slides away from the current slide. 

Go Backward Go backward by a specified number of slides. Note that the target 
is not a specific slide: The jump will land on any slide that is 
presently n slides away from the current slide. 

Object 

Show Object Show shapes, images, audio, and video objects. Users can block 
subsequent actions until this action is completed. Otherwise, 
subsequent actions will be executed right after the object is 
displayed. 

Hide Object This action is used to hide any objects which are displayed by the 
Show Object action before they disappear automatically. 

Highlight Object This action is used to highlight an object to draw users’ attention to 
that object. 

Change Object 
State 

Change the display state of an object. 
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Play Audio This action is used to play audio resource. It is similar to the Show 
Object non-blocking action with audio object, except it does not 
require that an audio object is inserted earlier. 

Clear User Input This action clears whatever users entered in a specified interactive 
object, for example: 

• It clears text in all text fields for Text Box and Question 
objects that contain a text box. 

• It unchecks the check boxes or radio buttons for Question 
objects. 

• It sends dropped drag sources to their original position. 

Submit This action sends whatever users entered in a specified interactive 
object to the presentation to evaluate. 

Timeline 

Start Timeline  Start the playback of the target timeline. 

Pause Timeline Pause the playback of the target timeline. 

Continue Timeline Resume the playback of the target timeline. 

Miscellaneous 

Adjust Variable Change the value of a variable. 

Send Email This action launches default email client program installed on user 
PC, and loads the previously configured contents in the mail 
(including recipient address, subject line, etc.) 

Note that the email is not sent silently or automatically: The user 
must manually press the send button. The user can also modify 
the email contents before sending. 

Open Webpage Open a specified URL. You can specify whether to open it in the 
current window or to use a different window.  

Remember that the interactive presentations are always delivered 
through a browser window. 

Execute JavaScript Execute a specified JavaScript. 

Setting Up Interactions 

The following chart shows the events for each interactive object.  
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Mouse Click Y          Y Y   Y Y Y  

Key Stroke  Y         Y Y   Y Y Y  

Text Box   Y        Y Y Y Y Y Y Y  

Button Y              Y Y Y Y 

Check Box    Y           Y Y Y  

Radio Button    Y           Y Y Y  

Drag Source Y    Y Y          Y Y  

Drop Area        Y Y Y Y Y Y   Y Y Y  

Drop Target  Y      Y Y Y Y      Y Y Y 

Question - 
True/False 

          Y Y  Y Y    

Question - 
Multiple 
Choice 

          Y Y  Y Y    

Question - 
Multiple 
Response  

          Y Y  Y Y    

Question - 
Essay  

            Y Y Y Y Y  

Question - 
Fill in Blank 

  Y        Y Y  Y Y Y Y  

Question - 
Fill in 
Multiple 
Blanks  

          Y Y  Y Y    
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Question - 
Sequence 

          Y Y   Y    

Question - 
Drag-n-Drop  

          Y Y  Y Y    

Question - 
Rating Scale 
(Likert) 

            Y Y Y    

As mentioned earlier, all the interactions are managed in the Interactivity tab of the 
Properties pane, in a section called Events - Actions. To open the section, select an object 
and do either of the following: 

• Open the Interactions tab > Event . 

• Go to the Properties pane > Interactivity  > Events - Actions.  

Mouse Click  

Mouse clicks are interactive objects placed at areas in a slide where users must click to trigger 
the next action. You can use mouse click objects in software simulations to teach the use of 
applications. For example, place a mouse click object on buttons or menus where users must 
click to perform a certain task in the application. 

To insert a mouse click, do either of the following: 

• Open the Interactions tab > Mouse Click .  

• Open the Home tab > Interactions  > Mouse Click . 

By default, a mouse click consists of three separate elements: (1) a target area, (2) a Correct 
message, and (3) an Incorrect message.

  

You can optionally add a Timeout message and a Hint message. To add a message, select 
the object and click Interactions > Message. 

When the interactive presentation is played, the mouse click object displays only the target 
area and waits for the user to click anywhere on the slide. You can prompt the user to click in 
a specific area by inserting a shape with some guidance. 

If the user action is correct, a Correct message appears. If not, an Incorrect message appears. 
For example, if the predefined value is CTRL+Left click, but the user clicks on the target area 
without holding down the CTRL key, he is doing incorrectly. 
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To define a correct action, do as follows: 

1. Select the target area element. 

2. Go to Properties > Interactivity > General > List of Correct Values. 

3. Hover over the Correct Value box and click mouse (Left click, Right click, and Left 
double-click) with(out) optional modifier keys (SHIFT, CTRL, and ALT) to define a 
value. 

4. Click the Remove button  to remove a value you don’t want. 

For Score settings, see Score & Reporting. 

To set up events and actions for the mouse click object, access the Events - Actions section 
in the Properties pane. 

Note that you can make the target area invisible (by setting the line to None in the Properties 
pane) if you don’t want to reveal the correct click area to the user. However, this is not 
recommended. Instead, use the Show In Mode property of the object. That is more flexible 
and useful, especially when you want to show the object in some modes (for example, 
Demonstration and Tutorial) but hide it in other modes (for example, Practice and Test). 

For example, suppose you want to show a world map and question the user about the location 
of a certain city. Place the target area on that city, and make it invisible. Now the user can only 
see the map. If the user clicks on the correct area, the object shows him a Correct message. 
If he clicks any wrong location on the map, the object shows him an Incorrect message.  
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Key Stroke 

Key strokes are interactive objects that respond when users press a key or combination of 
keys on their keyboard.  

To insert a key stroke, do either of the following: 

• Open the Interactions tab > Key Stroke .  

• Open the Home tab > Interactions  > Key Stroke . 

By default, a key stroke consists of three separate elements: (1) a target area, (2) a Correct 
message, and (3) an Incorrect message. 

  

You can optionally add a Timeout message and a Hint message. To add a message, select 
the object and click Interactions > Message. 

When the interactive presentation is played, initially the key stroke object displays nothing. It 
just waits for the user to enter a hotkey (such as CTRL+SHIFT+P), and ignores any text string. 
If the entered hotkey matches the reference, a Correct message appears. If not, an Incorrect 
message appears. For example, if the predefined value is ALT+A, but the user presses the A 
key without holding down the ALT key, he is doing incorrectly.  

Be sure to fully test your key stroke in your published output to avoid any unexpected behavior. 
Don’t use keys or key combinations that are common in browsers (CTRL+F, ALT+D, etc.). 
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To define a correct action, do as follows: 

1. Select the target area element. 

2. Go to Properties > Interactivity > General > List of Correct Values. 

3. Click inside the Correct Value box and press a key with optional modifier keys (SHIFT, 
CTRL, and ALT) to define a value. 

4. Click the Remove button  to remove a value you don’t want. 

For Score settings, see Score & Reporting. 

Apart from the primary behavior, the key stroke object also has secondary behaviors. Set up 
all those behaviors in the Events - Actions section in the Properties pane. 

Text Box 

Text boxes are interactive text fields which allow users to enter text directly onto a slide. Text 
boxes provide a great way to test user knowledge and collect information from users.  

To insert a text box object, do either of the following: 

• Open the Interactions tab > Text Box .  

• Open the Home tab > Interactions  > Text Box . 

By default, a text box consists of three separate elements: (1) a target area, (2) a Correct 
message, and (3) an Incorrect message. 
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You can optionally add other messages. To add a message, select the object and click 
Interactions > Message. 

When the interactive presentation is played, the text box object displays only the target area 
and waits for the user to enter text strings. 

• If the user enters a text string, it appears in real time in the target area. 

• If the entered text exceeds the area, the text is shifted so that the insertion point is 
always visible. You will have to resize the area manually. 

• If the Submit key is enabled, the entered text is validated when the user presses the 
Submit key. 

• If the Submit key is not set, the text is validated whenever the user presses any key. 
As long as the entered text is a partial match for the reference text, ActivePresenter 
will wait for the user to input more text. However, the moment the last entered character 
is found to be different, it will be deemed as incorrect. 

• If the entered text matches the reference text, ActivePresenter displays a Correct 
message. 

• If the entered text does not match the reference text, ActivePresenter displays an 
Incorrect message. 

By default, a text box validates user input as correct or incorrect. If you want to disable 
validation, you can set the mode to survey. To do that, go to the Properties pane > 
Interactivity > Score & Reporting > Mode. This may be useful when you want to ask viewer 
name or other information. 

To define a correct action, do as follows:

1. Select the target area element. 

2. Go to Properties > Interactivity > General > List of Correct Values. 

3. Click inside the Correct Value box and press a text string to define a value. 

4. Click the Remove button  to remove a value you don’t want. 



ActivePresenter User Manual  Version 7 

Interactive Objects > Drop Area  173 
 

 

For Score settings, see Score & Reporting. 

Apart from this primary behavior, the text box object also has secondary behaviors. Set up all 
those behaviors in the Events - Actions section in the Properties pane.  

Drop Area 

You should read Creating Drag-n-Drop Interactions to have basic concepts of drag-n-drop 
before reading this section. 

To insert a drop area object, do either of the following: 

• Open the Interactions tab > Drop Area . 

• Open the Home tab > Interactions  > Drop Area .  

By default, a drop area consists of four separate elements: (1) a drag source, (2) a drop area, 
(3) a Correct message, and (4) an Incorrect message.
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For Score settings, see Score & Reporting. 

To set up events and actions for the drop area object, access the Events - Actions section in 
the Properties pane. 

Button 

Button is an interactive object that allows you to redirect the viewer to specific contents when 
they click it (a slide, for example). 

To insert a button object, do either of the following: 

• Open the Interactions tab > Button .  

• Open the Home tab > Interactions  > Button .  

 

Button objects have the following characteristics: 

• You need to set actions for the button in the Properties pane > Interactivity > Events 
- Actions section. 

• Buttons don’t validate user input as correct or incorrect. When the viewer clicks a 
button, actions registered with the On Click event are executed. 

• Buttons have no Report ID and Score settings so they don’t appear in the report. 

• Buttons come with four prebuilt states (Normal, Hover, Clicked, and Disabled) which 
control their appearance when users interact with them. You can modify the prebuilt 
states or create additional states if needed. For more details about states, see Object 
States. 

After customizing a button, you can set it as default style for all new buttons in the current 
project. To do that, right-click the button, and select Set as Default Button.  

In case you want the new default style to take effect to existing buttons in the same project, 
right-click a button > Apply to All Button Objects > Style. 
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Check Box  

ActivePresenter comes with a variety of ready-made check box styles to help you create 
interactions in your course.  

 

To insert a check box, do either of the following: 

• Open the Interactions tab > Check Box . 

• Open the Home tab > Interactions  > Check Box . 

Once the object is in your slide, you can move, scale, or customize it as desired. To format a 
check box, select it, then go to the Format tab and do as follows: 

• Change the styles: Use the check box drop-down gallery to select a ready-made style 
to customize the button. 

• Change the colors: Initially, check boxes use their default style in which button colors 
come from your theme colors. However, you can always use custom colors to design 
your check boxes. Do the following: 

o Check Box Fill: Define the background color of the button. 

o Check Box Border: Define the color and style of the button’s border. Choose 
Weight to change the border thickness. 

o Check Box Mark: Define the color of the check mark when the button is checked. 

• Set the default styles: You can set a certain check box as the default style so that the 
same attributes will be applied to all new check boxes in the same project. To do that, 
right-click a check box, and select Set as Default Check Box. 

In case you want the new default style to take effect to existing check boxes in the 
same project, right-click a check box > Apply to All Check Box Objects > Style. 

Check box objects come with eight prebuilt states (Normal, Hover, Down, Disabled, Normal 
Checked, Hover Checked, Down Checked, and Disabled Checked) which control their 
appearance when users interact with them. You can modify the prebuilt states and create 
additional states if needed. For more details about states, see Object States. 

To set up events and actions for the check box object, access the Events - Actions section 
in the Properties pane.

Radio Button 

ActivePresenter comes with a variety of ready-made radio button styles to help you create 
interactions in your course.  

 

To insert a radio button, do either of the following: 

• Open the Interactions tab > Radio Button . 
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• Open the Home tab > Interactions  > Radio Button . 

Once the object is in your slide, you can move, scale, or customize it as desired. To format a 
radio button, select it, then go to the Format tab and do as follows: 

• Change the styles: Use the radio button drop-down gallery to select a ready-made 
style to customize the button. 

• Change the colors: Initially, radio buttons use their default style in which button colors 
come from your theme colors. However, you can always use custom colors to design 
your radio buttons. Do the following: 

o Radio Fill: Define the background color of the button. 

o Radio Border: Define the color and style of the button’s border. Choose Weight to 
change the border thickness. 

o Radio Mark: Define the color of the radio dot when the button is checked. 

• Set the default styles: You can set a certain radio button as the default style so that 
the same attributes will be applied to all new radio buttons in the same project. To do 
that, right-click a radio button, and select Set as Default Radio Button. 

In case you want the new default style to take effect to existing radio buttons in the 
same project, right-click a radio button > Apply to All Radio Button Objects > Style. 

Radio button objects come with eight prebuilt states (Normal, Hover, Down, Disabled, Normal 
Checked, Hover Checked, Down Checked, and Disabled Checked) which control their 
appearance when users interact with them. You can modify the prebuilt states and create 
additional states if needed. For more details about states, see Object States.

To set up events and actions for the radio button object, access the Events - Actions section 
in the Properties pane. 

Questions  

Questions are interactive objects which contain multiple child objects. Questions can be 
configured to use for one of the following two purposes: (1) assessing learner performance 
(graded mode) and (2) collecting viewer feedback (survey mode).  

ActivePresenter allows you to insert nine different types of questions: 

• True/False 

• Multiple Choice 

• Multiple Response 

• Essay 

• Fill in Blank 

• Fill in Multiple Blanks 

• Sequence 

• Drag-n-Drop 

• Rating Scale 

For more details about question properties, see Common Question Properties.
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Creating Quizzes 

Common Question Properties 

Components of a Question Slide 

A typical question slide in ActivePresenter is composed of four parts. Two main parts are the 
group of answers and the title of the slide. Two others are feedback messages and buttons 
put in the slide layout.  

 

• Title (1): The title of a question.  

• Answer (2): The answer of the question. The number of answers depends on the types 
of questions.  

• Feedback Messages (3): A question may have up to five types of feedback message 
(Correct, Incorrect, Timeout, Incomplete, and Hint).  

To insert a feedback message into the question, select the answer part of the question 

> Interactions tab > Message  > select a message from the drop-down list. 

Alternatively, you can right-click the answer part of the question > Insert > select a 
message from the pop-up menu.  

• Buttons (4): ActivePresenter 6 has four predefined button types which are Back, 
Clear, Skip, and Submit. ActivePresenter 7 only has Submit. However, you can insert 
other buttons and customize them, and then set the Events - Actions for them 
regarding your purposes.  

To insert a button into a question, do one of the following:  

Open Slide Master > Interactions tab > Button , or Slide Master > Home tab > 

Interactions  > Button . 
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ActivePresenter allows you to edit the Events - Actions of the question, which is important in 
creating quizzes. To open the Events - Actions section, do one of the following:  

• Select the question > Interactions tab > Event . 

• Select the question > Properties pane > Interactivity tab  > Events - Actions.  

After that, the Properties pane will show all the necessary tools and properties allowing you 
to edit and customize events and actions of the question. 

Graded and Survey Mode of Questions 

A question can be used for assessing learner performance (Graded mode) and collecting 
viewer feedback (Survey mode). You can change this setting for a question by selecting the 

question > Properties pane > Interactivity tab  > Score & Reporting > Mode > 
Graded/Survey. 

The table below shows the differences between Graded mode and Survey mode. 

Mode Graded Survey 

User validation Correct/Incorrect/Incomplete Complete/Incomplete 

Score setting Yes No 

Purpose Assessment Information Gathering 

Action entries in the Event 
Properties pane 

On Correct 
On Incorrect 
On Incomplete 
On Timeout 

On Complete 
On Incomplete 
On Timeout 
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Creating Drag-n-Drop Interactions 

Drag-n-drop interactions provide an effective way to make your eLearning courses more 
interesting and engaging. Through this activity, learners can evaluate what they have learnt, 
and become involved with the content as opposed to passively reading the information on the 
screen or watching videos.  

In ActivePresenter, a drag-n-drop interaction needs an object that can be dragged, and a place 
or an object to drop it. ActivePresenter calls them drag source and drop target respectively. 
You can convert any object and group into a drag source or a drop target, except: 

• Footer, audio, zoom-n-pan, cursor path, closed caption, and question objects.  

• Objects showing across multiple slides. 

• Objects showed by Show Object actions. 

• Objects as elements in questions, except drag-n-drop question. 

• Object groups which have at least a child object as a drag source or drop target.   

Drag Source 

By default, a light green marker is displayed to indicate that an object is a drag source. This 
marker doesn’t appear in any output format but the editor. You can hide it by going to the View 

tab and click Drag-n-Drop . 

 

To convert objects into drag sources, follow these steps: 

1. Select objects. Note that you can convert multiple objects at once. 

2. Go to the Properties pane > Interactivity > Drag-n-Drop > Drag Source. 

 

Use these options to adjust the properties of drag sources: 

o Effect: Specify a type of effect for selected drag sources. The effect is displayed 
when learners drag these objects. For example, if the Zoom effect is assigned to 
an object (also a drag source), when learners drag the object, it will be zoomed 
out. 
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o Revert: Define whether the selected drag sources are sent back to their original 
positions if they are dropped outside the drop targets. 

Drop Target 

When an object is set as a drop target, it will be surrounded by a light orange marker. This 
marker is also used only in the editor and doesn’t appear in any output format. You can hide 

it by going to the View tab and click Drag-n-Drop . 

 

Do the following steps to convert objects into drop targets: 

1. Select objects. Note that you can convert multiple objects at once. 

2. Go to the Properties pane > Interactivity > Drag-n-Drop > Drop Target. 

 

To adjust the properties for drop targets, do the following: 

o Effect: Specify the effect for selected drop targets. The effect is displayed when 
users drag any drag source over one of these objects.  

o Accept List: List drag sources that can be dropped onto the selected drop target. 
If a dropped source is accepted, it snaps to the drop target based on Snap 
Behavior, and an On Accept event is triggered.  

If a dropped source is rejected, it will be sent back to its original position, and an 
On Reject event is triggered.  
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When you click the button  next to the Accept All box, the Accept List dialog 
will appear.  

 

o Snap Behavior: Specify properties of drag sources after they are dropped onto 
one of selected drop targets. Select Size to resize drag sources. Select Opacity 
to set the opacity level for drag sources from 0 to 255. The higher the value, the 
more opaque the drag sources. Select Position to define the location of drag 
sources. This gives you three options: 

Absolute: Keep drag sources at the same position as where users drop them.  

Anchor: Snap drag sources to an anchor in the drop target. Users can select 
one of nine anchors in the Direction drop-down list, such as Top Left, Top Right, 
and Top Center.  

Tile: Arrange drag sources so that they fill the drop target without covering each 
other. Users can select one of eight tiling directions in the Direction drop-down 
list, like From Top, Left to Right. 

o Accepts: Specify the number of drag sources that can be accepted by the drop 
target. The default value is infinite, but it’s possible to change the finite value from 
1 to 10. In this case, you can define what happens when you reach maximum 
accepts: 

Reject: The drop target doesn’t accept the new dropped object. The dropped 
object is sent back to its original position, and the On Reject event is triggered.  

Replace the Last: The last dropped object is sent back to its original position, 
and the new dropped object is accepted. Of course, the On Accept event is 
triggered in this case.  

Drag Drop Connector 

After defining drag sources and drop targets, the next step is to connect them. Connecting a 
drag source to a drop target denotes that dropping the drag source to the drop target is a 
correct action. To map a drag source to the correct drop target, select the drag source, and 
then drag the marker appearing at the center of the drag source to the correct drop target.  
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To remove a correct drag-n-drop interaction, do either of the following: 

• Click the orange connection line and press the DELETE key. 

• Right-click the orange connection line and select Delete from the context menu.  

Note: 

• It is impossible to connect a drag source to a drop target that isn’t element of a Drag-
n-Drop question since the drop target doesn’t validate the drop action as correct or 
wrong.  

• You can also define correct drag source - drop target pairs in the Events - Actions of 
drop area and Drag-n-Drop question.  

• One drag source can be connected to multiple drop targets. When taking the output 
simulation, learners can drag the source to one of the targets.  

• Multiple drag sources can be connected to one drop target. When taking the output 
simulation: 

o If the drop target is a drop area, learners can drag one of the sources to the drop 
area.  

o If the drop target is an element of a Drag-n-Drop question, learners have to drag 
all of the sources to the drop target.  

Tips for Creating Drag and Drop Interactions 

Below are some tips and tricks which will help you to design impressive drag-n-drop 
interactions: 

• If you want to assess learners’ responses instantly when they drop a drag source, and 
you need only one drop target, let use drop area interaction. Otherwise, Drag-n-Drop 
question is likely suitable for your needs.  

• You should insert all objects before converting them to drag sources/drop targets and 
connecting them. This will reduce your editing time because ActivePresenter allows 
editing multiple objects at once.  

• You should rename drag sources/drop targets to meaningful names before connecting 
them. This will help you to identify them easily in the Events - Actions section.  

• In case of drop area, make sure that drag sources don’t start exiting before the drop 
area pauses for learners’ responses. You can view and adjust their timing properties 
in the Timeline pane. 
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• You can edit shapes as drag sources/drop targets the same way you do with a single 
object, such as changing shapes, adding text, and changing other properties.   

• If you have two overlapped drop targets, when a drag source is dropped onto the 
overlapped area, the drop target that has higher z-order will process the dropped 
source. You should set the z-order properly to get desired results.
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Creating Quizzes 

Quizzes are critical elements of a test. They allow you to test or track performances of learners, 
collect information and opinions of viewers, and so much more.  

There are nine types of questions in ActivePresenter: True/False, Multiple Choice, Multiple 
Response, Essay, Fill in Blank, Fill in Multiple Blanks, Sequence, Drag-n-Drop, and Rating 
Scale (Likert).  

 

To create a question, open the Interactions tab and select the question you want to have. Or 

you can open the Home tab > Interactions button  > select a question. After that, 
ActivePresenter will create a new slide containing that question.  

True/False 

This type of question allows learners to select either True or False for an answer.  

To create a True/False question, do one of the following:  

• Open the Interactions tab > True/False .  

• Open the Home tab > Interactions button  > True/False .  

The question will appear on the Canvas as shown in the screenshot below:  

 

Each question must have two answers (True and False), and you cannot remove or add more 
answers to it. However, you can let answers display in a different layout: Select answers > 

Size & Properties tab  > Group Layout > set 2 as the Number of Column.  
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To set the correct answer, double-click the radio button that corresponds to the correct answer 
choice.  You can change the answers to Yes and No if needed.  

Go to the Properties pane > Interactivity tab  > Scores & Reporting to select the question 
mode and set properties for it. 

Go to the Properties pane > Interactivity tab  > Events - Actions to have more setting for 
question events and actions. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > select Set as Default True - False Question from 
the pop-up menu. 

Multiple Choice 

This type of question allows learners to select only one answer for a question. 

To create a Multiple Choice question, do one of the following: 

• Open the Interactions tab > Multiple Choice  .  

• Open the Home tab > Interactions button  > Multiple Choice  .  

The question will appear on the Canvas as shown in the screenshot below:  

 

You can change the question layout: Select answers > Size & Properties tab  > Group 
Layout.  

You can add more answers to the question by selecting answers and clicking the green button: 
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To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple answers, hold CTRL while clicking them, and then press the DELETE key. 

To set a correct answer for the question, double-click the radio button that corresponds to the 
correct answer choice. Remember that you can set only one answer as a correct answer for 
a Multiple Choice question, which means you can only select one button.  

Go to the Properties pane > Interactivity tab  > Scores & Reporting to select the question 
mode and set its properties. 

Go to the Properties pane > Interactivity tab  > Events - Actions to have more settings 
for question events and actions. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > select Set as Default Multiple Choice Question 
from the pop-up menu. 

Multiple Response 

This type of question allows learners to select multiple answers for a question.  

To create a Multiple Response question, do one of the following:  

• Open the Interactions tab > Multiple Response . 

• Open the Home tab > Interactions button  > Multiple Response . 

The question will appear on the Canvas as shown in the screenshot below:  
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You can change the question layout: Select answers > Size & Properties tab  > Group 
Layout.   

You can add more answers to the question by selecting answers and clicking the green button: 

 

To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple answers, hold CTRL while clicking them, and then press the DELETE key. 

To set correct answers for the question, double-click the check boxes that correspond to the 
correct answer choices. Unlike a Multiple Choice question, you can set more than one correct 
answer for a Multiple Response question.  

Go to the Properties pane > Interactivity tab  > Scores & Reporting to select the question 
mode and set properties for it. 

Go to the Properties pane > Interactivity tab  > Events - Actions to have more settings 
for question events and actions.  

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > select Set as Default Multiple Response Question 
from the pop-up menu.  

Essay 

This type of question contains a multiple-line text box that allows learners to input text.  
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To create an Essay question, do one of the following: 

• Open the Interactions tab > Essay  .  

• Open the Home tab > Interactions button  > Essay .  

The question will appear on the Canvas as shown in the screenshot below: 

 

Click the answer text box, and go to the General section of the Properties pane to set the 
correct answer list for the question.  

Go to the Properties pane > Interactivity tab  > Scores & Reporting to select the question 
mode and specify its properties. 

Go to the Properties pane > Interactivity tab  > Events - Actions to have more settings 
for question events and actions.  

Fill in Blank 

This type of question contains a single-line text box that allows learners to input text. 

To create a Fill in Blank question, do one of the following:  

• Open the Interactions tab > Fill in Blank .  

• Open the Home tab > Interactions button   > Fill in Blank .  

The question will appear on the Canvas as shown in the screenshot below:  
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Click the answer text box, and go to the General section of the Properties pane to set the 
correct answer list for the question. To know more details about it, see General Section. 

Go to the Properties pane > Interactivity tab  > Scores & Reporting to select the question 
mode and set properties for it.  

Go to the Properties pane > Interactivity tab  > Events - Actions to have more settings 
for question events and actions. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > select Set as Default Fill in Blank Question from 
the pop-up menu. 

Fill in Multiple Blanks 

This type of question contains some single-line text boxes that allow users to input text. It is 
often used in the test that requires learners to fill missing words in a paragraph.  

To create a Fill in Multiple Blanks question, do one of the following: 

• Open the Interactions tab > Fill in Multiple Blanks .  

• Open the Home tab > Interactions button  > Fill in Multiple Blanks .  

The question will appear on the Canvas as shown in the screenshot below: 
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You can change the question layout: Select answers > Size & Properties tab  > Group 
Layout.  

Each question can have more than one answer. Each answer contains a label and a text box. 
You can add more answers to the question by selecting answers and clicking the green button: 

 

To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple answers, hold CTRL while clicking them, and then press the DELETE key. 

Click the answer text box, and go to the General section of the Properties pane to set the 
correct answer list for it. 

Unlike a Fill in Blank question, a Fill in Multiple Blanks question has more than one text box, 
you have to set the correct answer list for each of the text boxes separately.  

Go to the Properties pane > Interactivity tab  > Scores & Reporting to select the question 
mode and define properties for it. 

Go to the Properties pane > Interactivity tab  > Events - Actions to have more settings 
for question events and actions.  

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > select Set as Default Fill in Multiple Blanks 
Question from the pop-up menu. 
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Sequence 

A Sequence question contains at least two answers that require learners to arrange in the 
right order. To create a Sequence question, do one of the following: 

• Open the Interactions tab > Sequence .  

• Open the Home tab > Interactions button  > Sequence .  

The question will appear on the Canvas as shown in the screenshot below:  

 

You can add more answers to the question by selecting the answer section of the question 
and clicking the green button:  

 

Initially, each answer is a shape with text inside. Click the shape and replace the text. All the 
normal shape’s properties apply to this type of shapes, which means you can customize them 
just like customizing a normal shape.  

The order of answers you set is the correct answer for the question. To change that order, 
click and drag shapes to desired positions. However, before dragging, make sure that the 
None mode is selected in the Group Layout section. Otherwise, you cannot change the shape 
position. 

To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple of them, hold CTRL while clicking them, and then press the DELETE key. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > select Set as Default Sequence Question from the 
pop-up menu.  
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Drag-n-Drop 

Before creating a Drag-n-Drop question, you should take a look at Creating Drag-n-Drop 
Interactions to understand what drag sources and drop targets are. You can also have some 
basic concepts about drag and drop to make the most out of a Drag-n-Drop question. 

A Drag-n-Drop question is a type of question that includes multiple drag sources and drop 
targets that require learners to match correctly.  

To create a Drag-n-Drop question, do one of the following: 

• Open the Interactions tab > Drag-n-Drop .  

• Open the Home tab > Interactions button  > Drag-n-Drop .  

The question will appear on the Canvas as shown in the screenshot below:  

 

Each drag source and drop target is a shape with a clickable Image button  inside. You can 
click this button to quickly add images, or you can type text in the shape. All the normal shape’s 
properties apply to this type of shapes, which means you can customize them just like 
customizing any normal shape.  

To insert more drag sources and drop targets, select the drag sources and drop targets, and 
click the green button that appears:  
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By default, a question has two columns, one for drag sources, and the other for drop targets. 
But you can change its layout if needed: Select drag sources and drop targets > Size & 

Properties tab  > Group Layout.  

To set correct drag source and drop target pairs for an answer, you have to match them by 
selecting the drag source, and dragging the marker that appears at the center of it to the 
desired drop target.  

You can change the drag source and drop target position by clicking and dragging them to the 
desired position. However, before doing that, make sure the None mode is selected in the 
Group Layout section of the Size & Properties tab. Otherwise, you cannot change the shape 
position.  

To delete a drag source or drop target, select it and press the DELETE key on your keyboard. 
If you want to delete multiple of them, hold CTRL while clicking them, and then press the 
DELETE key. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > select Set as Default Drag-n-Drop Question from 
the pop-up menu.  

Note: A drop target in a Drag-n-Drop question should accept one drag source. In cases that 
you want to create a quiz containing a drop target that accepts multiple drag sources, you 
should use the drop area object.  

Rating Scale (Likert) 

This type of question contains one or more answers used for taking a survey from users, not 
for an assessment. 

To create a Rating Scale question, do one of the following: 

• Open the Interactions tab > Rating Scale (Likert) .  

• Open the Home tab > Interactions button  > Rating Scale (Likert) .  

The question will appear on the Canvas as shown in the screenshot below:  
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You can add more columns to the question or delete them, which means adding or deleting 

radio buttons in each answer: Select answers > Size & Properties tab  > Group Layout > 
change the value in the Number of Column spin box.  

Each answer has a label and multiple radio buttons. You can add more answers to the 
question by selecting answers and clicking the green button: 

 

To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple answers, hold CTRL while clicking them, and then press the DELETE key. 

Since this type of question is used to take a survey from users, it only has the Survey mode. 
It doesn’t have the Graded mode.  

Go to the Properties pane > Interactivity tab  > Events - Actions to have more settings 
for question events and actions.   

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > select Set as Default Likert Question from the pop-
up menu.  

Question Randomization 

In designing eLearning courses, designers often create a set number of questions for learners 
to retake a quiz multiple times. But the challenge is that learners can quickly finish the quiz by 
skipping questions asked before when they retry the same quiz over and over. Then, a good 
solution is to randomize questions that learners see each time they take the quiz. 

By randomizing questions, each student will be presented with a unique test which makes it 
very difficult to collaborate with others during the exam.  

In ActivePresenter, you can easily accomplish these by working with the Slide Pools feature. 
Furthermore, using Slide Pools also provides you an effective way to manage and organize 
relating questions. 

Opening Slide Pools Pane 

Basically, a Slide Pool is a collection of slides which don’t appear directly in eLearning 
quizzes. It serves the purpose of slide randomization which can be usually seen in creating 
test materials. A Random Slide is used to pick a slide in a pool randomly. 

To access the Slide Pools pane, go to the View tab and click Slide Pools . Then, the Slide 
Pools pane appears. 
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To preview each slide in the Slide Pools pane, just click them, and ActivePresenter will display 
its live preview on the Canvas.  

By default, each project has a pool without any slide. You can create Slide Pools as many as 
you want, and manually add slides to them.   

Managing Slide Pools 

In ActivePresenter, you can add, rename, and delete Slide Pools with ease. Do the following: 

1. Click the Add button  to insert a new pool. ActivePresenter allows you to create 
multiple pools in a project. 

2. Click the Rename button  to change the name of a pool. 

3. Click the Delete button  to remove the opening pool from the Slide Pools pane. 

4. Click the Import Pool button  to import a pool from other ActivePresenter projects, 
and then insert them into the current pool. When clicking this button, the Select a 
project dialog appears, and you can browse the folder containing the file you want to 
import. After selecting your desired project file, ActivePresenter displays the Import 
Slide Pools window as you can see in the screenshot below. From here, you can 
preview and choose your desired pool to import. 
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There are two main boxes in this window as described below: 

o The Pools box on the left is where to show pools available in the project which 
you’ve selected from your file system. 

o The Slides box on the right displays all slides in each pool on the left, and you can 
change the view mode by clicking the Small or Large button. 

To import a pool from other projects, select a desired pool in the Pools box. Then, click 
Append Pools to import a pool from other projects as a new pool. All existing pools 
are still kept or click Replace All Existing Pools to import a pool as a new pool and 
replace all previously created pools in the current project. Finally, click OK to finish. 

5. Click the About button  to view more information about the selected pool. 

6. To show other pools, click the Pool drop-down list (1) and select a desired pool. Then, 
all slides in the pool will be displayed in the Slide Pools pane. 

7. To change the order of slides in the Slide Pools pane, just select a slide thumbnail 
and drag it to where you want.  

Editing Slides in Slide Pools 

ActivePresenter provides a number of commands and tools to edit slides in the Slides pane, 
from changing their appearance to making them interactive by inserting events and actions. 
In the Slide Pools pane, all of these features are available.  

Here are the capabilities you can do with slides in a pool: 
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• Cut/copy/paste/delete slides.  

• Edit slide properties, including name, description, duration, background fill, 
background image, and accessibility.  

• Insert types of annotations and edit their properties.  

• Add interactions (events and actions) to slides.  

Adding Slides to Slide Pools 

Placing slides in a pool makes it easier for you to manage and use them later for creating 
random questions. To do that, do the following: 

1. Select slides. You can add multiple slides to Slide Pools simultaneously. 

2. Right-click selected slides, select Move Slide To from the context menu, and select 
your desired pool. 

Note: You can’t move Random Slides to Slide Pools. Besides, moving slide layouts in Slide 
Masters to Slide Pools is not supported as well. 

Drawing Slides from Slide Pools 

After creating slide pools and adding slides into them, you can draw one or more slides from 
those slide pools to create dynamic quizzes in your ActivePresenter courses. ActivePresenter 
also allows you to randomize them to keep quizzes from being predictable.  

To draw slides from Slide Pools, do either of the following: 

• Right-click slides in the Slide Pools pane, and click Move Slide To > Slides from the 
context menu.  

• The more flexible way is using Copy and Paste commands. Just, copy desired slides 
in a pool, define a location in the Slides pane, and then press CTRL+V.  

Using Random Slides 

As mentioned above, ActivePresenter uses the Random Slide concept instead of the Random 
Question one in other applications. By working with this feature, you can create a unique set 
of questions for each learner.  

Be careful that some features which are very familiar with normal slides aren’t available for 
random slides, such as changing layout and renaming.  
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To insert a Random Slide, do the following: 

1. Specify a location where you want to add a Random Slide in the Slides pane.  

2. Go to the Slide tab, and then click Random Slide .  

3. The inserted Random Slide is automatically linked to the first Slide Pool in the opening 
project. To change the linked pool, select the Random Slide > Properties pane > Slide 
Properties > Linked Pool > select your desired pool from the Linked Pool drop-down 
list.  

 

4. To add interactions to selected Random Slides, go to the Properties pane > 
Interactivity > Events - Actions > change events and actions for Random Slides the 
same way you do with a normal slide.  

Note: 

• You can add many Random Slides to a project. Besides, if you want to create a random 
quiz with n question, you have to add n random slides.  

• You can’t insert Random Slides in Slide Masters.  
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• Random Slides don’t have any properties. So, it’s impossible to insert interactivity for 
this kind of slide.  

• Annotations and Interactive objects aren’t available for Random Slides.  

• You can’t create questions within Random Slides. The questions must be existed in 
the linked slide pools first. 

• To ensure that all learners get a quiz that is equally difficult, it’s important to set the 
difficulty level for each question. Then, sort the questions based on their degree of 
difficulty into separate pools in the Slide Pools pane. In this way, you will have 
individual pools for each difficulty level with a certain number of questions, such as 10 
difficult questions, 10 moderate ones, and 10 easy ones for a quiz. 

• A good advice is that all questions in any random quiz should have the same score.

Inserting Report Slides 

Questions and knowledge checks are crucial to an eLearning course to track learners. Along 
with multiple types of questions, ActivePresenter also lets you create a report slide to 
summarize the performance of learners. You can track all the graded questions in a course or 
just some of them, depending on your preferences. 

To create a Report Slide, click Slide > Report Slide .  

The Report Slide has 11 default parameters. The first 10 parameters consist of a parameter 
name on the left and a reference to the corresponding variable on the right.  
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Report’s parameters can be shown or hidden using the Properties pane. Access the 
Interactivity tab > Report Display. A check mark next to each parameter indicates that it is 
visible. To hide a parameter, uncheck the box corresponding to it.  
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Variables & JavaScript  

Variables  

Overview of Variables 

In ActivePresenter, you can add extra functionality with variables. Variables are used to collect 
and store information that can be retrieved throughout the project. The information stored in a 
variable can change but the operations on the variable remain the same.  

Also, a variable can hold only one piece of data at the same time. For example, you can create 
a variable to hold learner feedback. The variable holds any text-based entry learners input, 
but it can hold only one feedback at a time. Each time a learner enters a new feedback, the 
variable will update with the new and latest entry.  

To access variables, open the Home tab > Variables. You can use both system and user 
variables.  

• System variables are predefined variables ActivePresenter provides. Any adjustments 
to these variables are not allowed. System variables are listed in the System tab.  

• User variables are created by users. You can create, modify, and delete these 
variables in the User tab. 

Variables have four types of information: 

• Name: Specify a unique name for the variable. The name should be descriptive and 
intuitive enough and associated with the data stored. For example, a variable storing 
learner name would be called learnerName.  

• Type: Represent what kind of data is stored with the variable. Select from three types: 
true/false, text, and number. 

o True/False variables, also called boolean variables, have only two possible values, 
true or false. These variables enable you to make decisions, and therefore have a 
better control over your flow. 

o Text variables, also called string variables, hold text-based values (strings). For 
example, text variables can be used to store names, passwords, or information 
extracted from a table. 

o Number variables, also called integer variables, hold numeric values. Number 
variables are used to store numeric information. They can be used to capture and 
track learner scores, number of attempts, and any other types of statistic. 

• Value: The data stored within a variable is called a value, and it can be of multiple 
types as mentioned above.  

Normally, when you create a variable, you define the variable name and type. For 
values, you can provide an initial value to occur at all references to that variable in the 
project. If you don’t assign an initial value, default values for text and number variables 
appear as blank spaces. For true/false variables, the default value is true. 

• Description: Optionally provide a description for the variable. You can use it as a note 
of the variable’s usage. 
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System Variables 

A list of all system variables are shown in the Home tab > Variables > System tab as in the 
picture below. Besides the variable name, type and default value, the list also counts the 
number of time the variable is used. 

 

Below is the list of system variables in ActivePresenter. Note that system variables have four 
types in total, including: true/false, text, number, and command. Command variables are 
system-specific variables used to control the player. 

Name Type Description 

apVersion  TEXT Returns the version of the 
application.  

apAuthor TEXT Returns the name of the project 
author. 

apHomepage TEXT Returns the home page of the 
project. 

apCopyright TEXT Returns the copyright information 
of the project. 
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apProjectName TEXT Returns the project name. 

apDescription TEXT Returns the project description. 

apPlayMode TEXT Returns the current operation 
mode of the presentation. 

apCurrentSlideLabel TEXT Returns the current slide name. 

apElapsedTime TEXT Returns the elapsed time in the 
format hh:mm:ss since the 
presentation started playing. 

apElapsedTimeMs NUMBER Returns the elapsed time in 
milliseconds since the presentation 
started playing. 

apRemainingTime TEXT Returns the remaining time in the 
format hh:mm:ss. 

apRemainingTimeMs NUMBER Returns the remaining time in 
milliseconds. 

apTotalSlides NUMBER Returns the total number of slides 
in the project. 

apTakenSlides NUMBER Returns the number of taken slides 
in the project. 

apQuizScore NUMBER Returns the total score. 

apQuizScorePercentage NUMBER Returns the total score as 
percentage. 

apQuizMaxScore NUMBER Returns the highest score. 

apQuizPassed TEXT Returns the result of the quiz as 
passed or failed. 

apQuizPassedBool TRUE/FALSE Returns the result of the quiz as 
true (passed) or false (failed). 

apQuizTotalInteractions NUMBER Returns the total number of 
interactions in the project. 

apQuizTakenInteractions NUMBER Returns the number of taken 
interactions in the project. 

apQuizUnTakenInteractions NUMBER Returns the number of 
unanswered interactions in the 
project. 

apQuizCorrectInteractions NUMBER Returns the number of correct 
interactions in the project. 
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apQuizIncorrectInteractions NUMBER Returns the number of incorrect 
interactions in the project. 

apDetailedResult TEXT Returns the detailed report. 

apDetailedResult2 TEXT Returns the detailed report with 
correct responses. 

apCurrentTime TEXT Returns the current time in the 
format hh:mm:ss. 

apCurrentDay NUMBER Returns the day of the week. The 
range is from 1 (Sunday) to 7 
(Saturday). 

apCurrentHour TEXT Returns the current hour in the 24-
hour format. 

apCurrentMinutes TEXT Returns the current minutes in the 
format mm. 

apCurrentMonth TEXT Returns the current month in the 
format mm. 

apCurrentYear TEXT Returns the current year in the 
format yyyy. 

apCurrentLocaleDate TEXT Returns the current date in the 
format of the locale on the viewer's 
computer. 

apProjectLocaleDate TEXT Returns the current date in the 
format of the project language. 

apDateMMDDYYYY TEXT Returns the current date in the 
format mm/dd/yyyy. 

apDateMMDDYY TEXT Returns the current date in the 
format mm/dd/yy. 

apDateDDMMYYYY TEXT Returns the current date in the 
format dd/mm/yyyy. 

apDateDDMMYY TEXT Returns the current date in the 
format dd/mm/yy. 

apDateYYYYMMDD TEXT Returns the current date in the 
format yyyy/mm/dd. 

apDateYYMMDD TEXT Returns the current date in the 
format yy/mm/dd. 

apCurrentSlideIndex NUMBER Gets or set the current slide index, 
starts from 1. Set the value to a 
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number to go to the slide at that 
index number. 

apPause TRUE/FALSE Set or checks if the presentation is 
paused. Set the value to true to 
pause the presentation. 

apResume TRUE/FALSE Set or checks if the presentation is 
playing. Set the value to true to 
continue the presentation. 

apProgress NUMBER Gets or set the current progress of 
the presentation in milliseconds. 
Set the value to a number to go to 
a specific time of the presentation. 

apSpeed NUMBER Gets or set the playback speed. 
The range is from 50% to 200%. 

apMute TRUE/FALSE Mutes or unmutes the audio. Set 
the value to true to mute the audio. 

apVolume NUMBER Gets or set the audio volume. The 
range is from 0 (mute) to 100 
(maximum). 

apCCVisible TRUE/FALSE Shows or hides the closed caption. 
Set the value to true to show the 
closed caption. 

apToolbarVisible TRUE/FALSE Shows or hides the player toolbar. 
Set the value to true to show the 
toolbar. 

apTOCVisible TRUE/FALSE Shows or hides the table of 
contents. Set the value to true to 
show the table of contents. 

apCmdNextSlide COMMAND Set the value to true to go to the 
next slide. 

apCmdPreviousSlide COMMAND Set the value to true to go to the 
previous slide. 

apCmdFirstSlide COMMAND Set the value to true to go to the 
first slide. 

apCmdLastSlide COMMAND Set the value to true to go to the 
last slide. 

apCmdHistoryBack COMMAND Set the value to true to go to the 
previously visited slide in the 
navigation history. 
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apCmdHistoryForward COMMAND Set the value to true to go to the 
next slide in the navigation history. 

apCmdEnd COMMAND Set the value to true to end the 
presentation. 

apCmdRestart COMMAND Set the value to true to restart the 
presentation. 

apCmdShowAbout COMMAND Set the value to true to show the 
information dialog. 

User Variables 

Creating User Variables 

To create a new variable, do as follows: 

1. Click Home > Variables to open the Variables dialog. 

2. In the User tab, specify the variable name, type, initial value, and description (if any). 
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3. Click Save to save the variable. The new variable will appear in the variable list at the 
bottom of the dialog. 

4. Click Discard to abort the process without saving the variable. 

Updating User Variables 

You can update your user variables at any time you want. Note that you can only change the 
variable name, value, and description. The variable type cannot be changed. 

1. Click Home > Variables to open the Variables dialog. 

2. In the User tab, select a variable from the variable list. 

3. Modify the variable information and click Update to save the changes. 

Deleting User Variables 

You can delete only user variables.  

1. Click Home > Variables to open the Variables dialog. 

2. In the User tab, select a variable from the variable list.  

3. Click Remove to delete the variable. 

References 

Reference is a way to retrieve and display the data stored in variables. By adding a reference 
to the variable, not only can you retrieve and display the data but you can also verify whether 
the variable is working correctly or not.

For example, in the first slide of a quiz, you're asked for your name. Type your name and click 
the Next button to start your quiz. In the final slide, the name you entered appears with your 
score and other information. In that case, the variable gets your name once you type it in the 
first slide, and in the final slide, the variable reference displays that piece of information. 

The formatting for reference variables is always the same.  

%VariableName% 

When you preview or publish the project to HTML5, ActivePresenter replaces the variable 
names with the actual values of the variables they reference. 

You can insert a reference into a shape or any objects having editable text with the following 
steps: 

1. Click the text area to open the inline text editor. 

2. Click Home > Reference to open the Variables dialog.   

3. Select a desired variable from the variable list. 

4. Click OK to finish.   

5. Adjust the formatting of the reference as normal. 
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Custom JavaScript in HTML5 Output 

ActivePresenter allows retrieving elements of presentation in the HTML5 output by exposing 

the JavaScript API. You can write custom script in the following areas: 

• The Event tab of a project (ActivePresenter button > Project > Properties > Event). 

• The Execute JavaScript action in the Evens - Actions section of the Properties pane. 

You can access the presentation by using the global object prez. The prez is a global object 

which has the following methods: 

Method Description 

object(name) Gets the object in the current slide from name. If not 
found, search control shows over multiple slides in the 
bottom layer, then the top layer. 

slideCount() Returns the number of slides in the presentation. 

showSlideAt(index, 

time) 

Returns false if the index is out of range. 

• index: Slide index, starts from 1. 

• time: Jumps to the specified time stamp (in 

milliseconds) in the slide. Time can be omitted. If 
omitted, then time equals 0. 

currentSlideIndex() Returns the current slide index, starts from 1. 

nextSlide() Goes to the next slide. Ends the presentation and 
returns false if the current slide is the last one. 

previousSlide() Goes to the previous slide. Returns false if the current 

slide is the first one. 

firstSlide() Goes to the first slide. If the current slide is already the 
first one, replays it from the beginning. 

lastSlide() Goes to the last slide. If the current slide is already the 
last one, replays it from the beginning. 

historyBack() Goes backward in slide navigation history. 

historyForward() Goes forward in slide navigation history. 

time() Returns the current time stamp of the presentation in 
milliseconds. 

time(time) Goes to the specified time stamp (in milliseconds) of the 
presentation. 

duration() Returns the total duration (in milliseconds) of the 
presentation. 
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restart(slideIndex, 

time) 

Restarts the presentation from slide index (start from 1), 
at specified slide time stamp (in milliseconds). All 
previous results are cleared. 

end() Ends the presentation. 

startTimeline(name, 

callback) 

Starts the interactive timeline which has the specified 
name, and executes the callback (if specified) when the 
timeline is complete. Don't use this method for the main 
timeline. 

pauseTimeline(name, 

paused) 

Pauses or resumes the interactive timeline which has 
the specified name. Don't use this method for the main 
timeline. 

paused() Returns true of the main timeline is paused, false 

otherwise. 

pause(paused) Pauses or resumes the main timeline of the 
presentation.  

speed() Returns the current playback speed (normal speed value 
is 1). 

speed(speed) Sets the playback speed. Possible values are 0.5, 1, 1.5, 
2. 

volume() Returns the current volume. 

volume(volume) Adjusts the volume of the player (volume value is from 0 
to 1). 

muted() Returns true if the presentation is muted, false 

otherwise. 

mute(muted) Mutes or unmutes the presentation. 

closedCaptionVisible() Returns true if the closed caption is shown, false 

otherwise. 

showClosedCaption(show) Shows the closed caption. If show equals true, then 

show the closed caption, otherwise hide the closed 
caption. 

tocVisible() Returns true if the table of contents is shown, false 

otherwise. 

showToc(isShow) Shows the table of contents if isShow equals true, 

otherwise hide table of contents. 

toolbarVisible() Returns true if the player toolbar is shown, false 

otherwise. 

showToolbar(show) Shows the player toolbar. If show equals true, then 

show the player toolbar, otherwise hide the player 
toolbar. 
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showAbout() Shows the information dialog. 

submit() Submits all interactions in the current slide. 

clear() Clears all user input in the current slide. 

interactionCount() Returns the number of interactions. 

takenInteractionCount() Returns the number of taken interactions. 

takenSlideCount() Returns the number of taken slides in the project. 

score() Returns the total score. 

percentageScore() Returns the score in percentages (0 - 100). 

maxScore() Returns the highest possible score of the presentation. 

result() Returns the result of the quiz as passed or failed (true 

equals passed, and false equals failed).  

reportData() Returns the report object (see Report In JSON Format) 
section for its properties). 

elapsedTime() Returns the elapsed time in milliseconds since the 
presentation started playing. 

remainingTime() If in Test mode and Total Max Time is defined, return the 
remaining time in milliseconds till the max time expires. 
Otherwise, returns duration() - time(). 

variable(name) Get variable value. 

• name: The string name of the defined variable 

(“apVersion”, “apAuthor”, etc.). e.g. : to get the 
presentation’s version, you can use script 
variable(“apVersion”). 

variable(name, value) Set variable value. 

• name: The string name of the defined variable. 

• value: Value of variable, can be string or 

number. 

version() Returns the version of the application. 

author() Returns the name of the project author. 

homePage() Returns the home page of the project. 

copyright() Returns the copyright information of the project. 

name() Returns the project name. 

description() Returns the project description. 
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playMode() Returns the current operation mode of the presentation 
('Demo', 'Tutorial', 'Practice' or 'Test'). 

 

The Object object has the following methods. Note that for text box, both html and text 

method set/get text box value as plain text. 

Method Description 

name() Returns the name of the object.  

visible() Returns the object’s current visibility state. Note that 
child object is actually visible if it is visible() and all 

its ancestors are visible(). 

show() Show the object. 

show(effectType, 

duration, options) 

Show the object with effect. 

• effectType: Use any of the following values. 

(You need to add AP.EffectType. prefix for 

accessing these values.) 
o FADE_IN 

o FLY_IN 

o PEEK_IN 

o FLOAT_IN 

o WIPE_IN 

o ZOOM_IN 

o GROW_TURN_IN 

o SHAPE_IN 

o SWIVEL_IN 

o BOUNCE_IN 

o EXPAND_IN 

o SPINNER_IN 

o STRETCH_IN 

o COMPRESS_IN 

• duration: In milliseconds. 

• options: AP.EffectDirection or { 

  direction: AP.EffectDirection, 

callback: Optional callback called when 

effect completes, callback is bound to the 
object ('this' is the object). 

} 

AP.EffectDirection: Use any of the following 

values. (You need to add AP.EffectDirection. 

prefix for accessing these values.)  

o BOTTOM 

o LEFT 

o RIGHT 
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o TOP 

o BOTTOM_LEFT 

o BOTTOM_RIGHT 

o TOP_LEFT 

o TOP_RIGHT 

o IN 

o OUT 

o CLOCKWISE 

o COUNTER_CLOCKWISE 

hide() Hide the object. 

hide(effectType, 

duration, options) 

Hide the object with effect. 

• effectType: Use any of the following values. 

(You need to add AP.EffectType. prefix for 

accessing these values.) 

o FADE_OUT 

o FLY_OUT 

o PEEK_OUT 

o FLOAT_OUT 

o WIPE_OUT 

o ZOOM_OUT 

o GROW_TURN_OUT 

o SHAPE_OUT 

o SWIVEL_OUT 

o BOUNCE_OUT 

o CONTRACT_OUT  

o SPINNER_OUT 

o STRETCH_OUT 

o COLLAPSE_OUT  

• duration: In milliseconds 

• options: AP.EffectDirection or { 

 direction: AP.EffectDirection, 

callback: Optional callback called when 

effect completes, callback is bound to the 
object ('this' is the object) 

} 

See the values of AP.EffectDirection in the 

description of the show function. 

animate(effectType, 

duration, options) 

Animate the object. 

• effectType: Use any of the following values. 

(You need to add AP.EffectType. prefix for 
accessing these values.) 

o PULSE 

o TEETER 
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o SPIN 

• duration: In milliseconds. 

• options: AP.EffectDirection or { 

  direction: AP.EffectDirection, 

callback: Optional callback called when 

effect completes, callback is bound to the 
object ('this' is the object). 

} 

See the values of AP.EffectDirection in the 

description of the show function. 

html() Returns html text (all variables are replaced by their 
actual values before returning). 

html(htmlText) Sets html text, returns this object. 

• htmlText: HTML string. 

text() Returns plain text (all variables are replaced by their 
actual values before returning). 

text(plainText) Sets plain text, returns this object. 

• plainText: Plain text string. 

cursor(strCursor) Sets cursor for object, strCursor is CSS cursor 

(“busy”, ”crosshair”, “help” , etc). 

left() Returns the left of the object in pixels. 

left(value) Sets the left for the object. Value can be pixel number 
(e.g. 100), or string (e.g. '20%'). 

top() Returns the top of the object in pixels. 

top(value) Sets the top for the object, value as left. Value can be 
pixel number (e.g. 100), or string (e.g. '20%'). 

right() Returns the right of the object in pixels. 

right(value) Sets the right for the object, value as left. Value can be 
pixel number (e.g. 100), or string (e.g. '20%'). 

bottom() Returns the bottom of the object in pixels.  

bottom(value) Sets the bottom for the object, value as left. Value can 
be pixel number (e.g. 100), or string (e.g. '20%'). 

width() Returns the width of the object in pixels. 
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width(w) Sets the width for the object, value as left. Value can be 
pixel number (e.g. 100), or string (e.g. '20%'). 

height() Returns the height of the object in pixels. 

height(h) Sets the height for the object, value as left. Value can be 
pixel number (e.g. 100), or string (e.g. '20%'). 

size() Returns the size of the object in pixels {width, 

height}. 

size(w, h) Sets the size for the object. w, h can be pixel number 
(e.g. 100), or string (e.g. '20%').. 

state() Return the name of the current state. 

state(stateName) Change object state to the state named stateName 

fillSolid(color) Change fill color of object.  

• color: CSS color (e.g. 'red', '#FF0000', 'rgb(255, 

0, 0)', 'rgba(255, 0, 0, 0.5)'. 

rotate() Returns the current rotation in degrees. 

rotate(degree) Rotates the object, value is number in degrees. 

rotateBy(deltaDegree) Rotates the object by an additional delta in degrees. 
E.g., if currently the object rotates by 30 degrees, 
rotateBy(40) will make the object rotate by 70 

degrees. 

• deltaDegree: Number in degree. 

translate() Returns the current translate transform {translateX, 

translateY}. 

translate(translateX, 

translateY) 

Uses translate transform to move the object from its 
original position by an amount of translateX, 

translateY along X, Y axis, respectively.  

• translateX, translate are numbers in pixels. 

Note that object position returned by left(), 

top(), right(), bottom() doesn't change. 

translateBy(deltaX, 

deltaY) 

Uses translate transform to move the object from its 
current position by an amount of deltaX, deltaY along 

X, Y axis, respectively.  

• deltaX, deltaY are numbers in pixels. Note 

that object position returned by left(), top(), 

right(), bottom() doesn't change. 

scale() Returns the current scale {scaleX, scaleY}. 
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scale(scaleX, scaleY) Scales object. If scaleY is left out then scaleY equals 

scaleX. 

• scaleX, scaleY: Scale value along x, y axis. 

scaleBy(multiplierX, 

multiplierY) 

Scales object by multiple values. If multiplierY is left 

out, then multiplierY equals multiplierX. E.g., if 

current scale is 2, scaleBy(3) means that scale is 2 x 

3 = 6. 

transform() Returns the current transform {translateX, 

translateY, scaleX, scaleY, rotate}. 

transform(translateX, 

translateY, rotate, 

scaleX, scaleY) 

Transforms object by matrix values. 

• translateX, translate are numbers in 

pixels. Note that object position return by left(), 
top(), right(), bottom() doesn't change. 

• degree: Number in degree. 

• scaleX, scaleY: Scale value along x, y axis. 

disabled() Returns true if the object is disabled, false otherwise. 

disable(disabled) Disables or enables object. Disabled object can't receive 
events. Disabled buttons, radio buttons, and check 
boxes show disabled state. 

• disabled: If true, disables object. Otherwise, 

enables object. 

submit() Submits the interaction object. 

clear() Clears the user input. 

score() Returns the object score. 

attempts() Returns the current attempts. 

maxAttempts() Returns the maximum allowed attempts. 

 

The Player object (AtomiAP) has the following methods: 

Method Description 

open(prezUrl, 

containerId, options) 

Returns the new presentation object or null if browser 

isn't supported. 

• prezUrl: The URL of the presentation. 

• containerId: The ID of the presentation’s 

container. 
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• options: Can be omitted. Available options are 

playMode: 'Demo', 'Tutorial', 'Practice', or 'Test' , 
etc. 

close(prez) Closes the presentation object. 

• prez : The presentation to close. 

find(containerId) Finds the presentation object from container id. 

• containerId : The ID of the presentation’s 
container. 

 
Example:  
If you want to set text for an object which has name “object1”, you can add an “Execute 
JavaScript” action and write below code: 
var obj = prez.object("object1"); 

if (obj) { 

obj.text(“the text you want to set”); 

} 

Converting between version 6 and version 7 APIs: 

Object Version 6 Version 7 

Prez Prez: presentation object. prez: presentation object. 

ShowSlide(index) showSlideAt(index) 

ShowNextSlide() nextSlide() 

ShowPreviousSlide() previousSlide() 

ShowPreviousVisitedSlide() historyBack() 

ShowNextVisitedSlide() historyForward() 

GetSlide() currentSlide() 

GetObject(objectName) object(objectName) 

Slide GetObject(objectName) Access from prez object instead 

Object SetText(htmlText) html(htmlText) 

GetText(plaintext) • plaintext equal true: 
text() 

• plaintext equal false: 
html() 

Show(show) • show equal true:  
show() 

• show equal false:  
hide() 

 

IsShown() visible() 
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GetPosition() Using two functions to replace:  
• top() 

• left() 

SetPosition(x, y) Using two functions to replace:  
• top(x) 

• left(y) 
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Advanced Project Editing 

Editing Project Properties 

Properties of a project fall in three categories: 

• Properties that you cannot edit from this Project Properties window: Slide size, total 
number of slides, total run time for the presentation, project file size, and the date on 
which the project was created and last modified.  

• Properties that you can edit from this Project Properties window: Author's name and 
any remarks that you want to attach to the project's file (such as client name, 
conference detail, the type of outputs for this project, etc.).  

• The JavaScript code: It is executed when loading the project. You can use this property 
in the case that you want to extend the capability of HTML5 output. 

To view the project properties, click the ActivePresenter button > Projects > Properties. 

The Project Properties window will pop up as below:  
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General Tab 

This tab gives you generic information and settings of the currently editing project. They are 
global settings that affect all slides in the project. However, if a slide already has a background 
image, it won't be affected. 

• Project Name: Change the name for the project. 

• Description: Give a description for the project. 

• Project Language: Specify the language of editing project. ActivePresenter will use 
the corresponding translation of selected language to display in the output (name of 
elements of toolbar and messages in HTML5) if the language is supported in 
ActivePresenter. For other languages, you can still modify the text in output by using 
Output Language Editor. 

• Project Size: The size of the project slides.    

• Number of Slides: The total number of slides in the project.  

• Total Duration: The total duration of all the slides in the project.  

Author Tab 

This tab allows you to enter all details including the author’s information and security.  

You can enter a password for opening the project file in the Security section. Once you set 
the password, you can only open the file if you enter the password. This is useful if you have 
to leave the project file on a public computer. 

Event Tab 

On the Event tab of this window, you can enter the JavaScript code which is executed when 
loading the project 

Making Project Accessible 

ActivePresenter allows you to make your projects accessible to people with disabilities. This 
means you can edit your projects so that viewers with disabilities can perceive, understand, 
navigate, and interact with the project outputs. The project outputs can be viewed in various 
ways that do not depend on a single sense or ability. For example, viewers can navigate with 
a keyboard, not with a mouse only. Also, audio content should be accompanied with closed 
captions for hearing impaired viewers, text description should be provided for visual contents 
so that screen readers can read out loud for visually impaired viewers. 

In this version, HTML5 is the only output format that supports accessibility.  

Tips for Creating Accessible Projects 

To create accessible projects, you should always use more than one mean (e.g. text, visuals, 
and sounds) to convey information. 

• For viewers with visual impairment, add text descriptions or audio equivalents for visual 
objects. For example, provide accessibility text description for Video so that you can 
send the information to viewers through the screen reader. For objects that contain 
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text such as shape, text caption, you should enable the Auto Label property, the 
screen reader will read the text when this object is displayed. If you choose to attach 
audio to the object, don't forget to remove all accessibility text, otherwise voice from 
the screen reader will interfere with the attached sound. 

• For users with hearing impairment, add text equivalents for audio objects. For example, 
when delivering a narrative audio, it is important to provide captions at the same time. 
You can use closed caption objects or any other type of objects that can display text, 
and remember to synchronize the text with the audio by using the Timeline. 

• For viewers with either visual or hearing impairment, ensure that viewers can interact 
with the output using keyboard. For example, enable Focusable property for mouse 
click objects so that viewers can use the TAB key to navigate between objects, and 
the ENTER or SPACE BAR key to activate it. You can also provide a key stroke object 
that acts as a hotkey for each mouse click object.  

• Enable Accessibility features when exporting to output formats that support 
accessibility. 

Customizing Accessibility Text for Slides 

In ActivePresenter, you can add accessibility text describing each slide for screen readers to 
read aloud when the slide is displayed. Screen readers and accessibility text are useful for 
people with visual impairment. 

 

By default, ActivePresenter uses slide name and description as slide accessibility text. To 
provide different text for screen readers, do as follows:  

1. Select the slide that you want to change accessibility text. 

2. In the Properties pane, expand Accessibility drop-down list. 

3. Deselect the Auto Label check box, the Accessibility Text box are now enabled. 
Type text that describes the slide. 

4. When the slide appears, screen readers will read aloud the accessibility description in 
the box. If you don't want screen readers to read anything, leave this box blank. 



ActivePresenter User Manual  Version 7 

Advanced Project Editing > Making Project Accessible 221 
 

Customizing Accessibility Text for Objects 

ActivePresenter supports accessibility text for each object in a slide. By default, accessibility 
text is generated automatically from the text that the object displays, or the object name if it 
doesn't contain any text. Therefore, the default accessibility text is usually useless for objects 
that don't contain text, such as video and image.  

In that case, you should customize the accessibility text to provide sufficient information about 
the object by following steps below:  

1. Select the object that you want to change accessibility text. 

2. Open the Properties pane > Size & Properties tab  > Accessibility. 

3. Deselect the Auto Label check box, the Accessibility Text box are now enabled. 
Type the description of the object in the box. 

4. When the object appears, screen readers will read aloud this accessibility description. 
If you don't want screen readers to read anything, leave this box blank. 
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Localizing Projects 

Localization is the process of adapting a project for use in a specific country, region with a 
particular language, culture, and desired local look and feel. If you are creating a 
demonstration or simulation of a certain application that supports multiple languages, you may 
need to localize your project for each language. With ActivePresenter, you can do it easily 
thanks to the slide background replacement and the text translation features. 

Localizing Process 

Before doing localization, make sure that you have finished editing the original project (usually 
in English). 

To localize your project, do the following steps: 

1. Export text in your project to XLIFF format. 

2. Translate text in the exported XLIFF file using any tool that supports XLIFF 1.2 (e.g. 
Swordfish Translation Editor). 

3. Replace the original slide backgrounds with the new ones that are captured in the new 
language. 

4. Import the translated XLIFF file into the project of which slide backgrounds have been 
replaced in step 3. 

5. Test the localized version of your project, make sure that all screenshot images are 
replaced, and all text are properly translated and displayed. 

The next sections will describe each step in details. 

Exporting to XLIFF 

XLIFF (XML Localization Interchange File Format) is an XML-based format created to 
standardize the way localizable data are passed between tools during a localization process. 

To export text in your project to XLIFF format, do the following steps: 

1. Click the ActivePresenter button > Projects > Localize > Export To XLIFF. 

2. In the Export To XLIFF dialog, select types of text which you want to export for the 
translation.  
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3. Check the Use TMX 1.4b standard compatible tags (<bpt>, <ept>, <ph>) check box 
if your translation tool doesn't support <g> and <x/> tag. 

4. Enter the output location and file name in the Output File box. 

5. Click OK to start exporting to XLIFF. 

Replacing Slide Backgrounds 

You should not localize directly in your original project, but in a copied version of the project. 
This section will describe the steps of copying projects and replacing slides.  

Step 1. Create a copy of the original project for the new language. 

1. Copy the project file in File Explorer, or use ActivePresenter button > Save As… 

If you copy it in File Explorer, make sure it is not opening in ActivePresenter. The 
project copied from an opening project may be corrupted. 

2. Give the copied project a meaningful name. It is recommended that the project name 
has language code suffice, for example, Skype_es.approj. You can also create a folder 
for the new language and place the copied project there. 

Step 2. Capture a new project for the new language. 

1. Change language preferences and settings for the captured application to display the 
new language, if needed. 

2. Use the same project size (width x height) as the size of the original project. 

3. Name the new captured project a meaningful name. For example, you can name it 
Skype_es_captured.approj. 

Step 3. Open the Slide Background Replacer window to replace slide backgrounds in the 
project copied in step 1 by new ones captured in step 2, or by slides of the new captured 
project. 

1. Open the project copied in step 1 (Skype_es.approj). 
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2. Click the ActivePresenter button > Project > Localize, and do one of the following:  

o Select Replace Backgrounds of All Slides From Project and browse the new 
project captured in step 2 (Skype_es_captured.approj) to replace all slide 
backgrounds of the current project. 

o Select Replace Backgrounds of Selected Slides From Project and browse the 
new project captured in step 2 (Skype_es_captured.approj) to replace some 
selected slide backgrounds of the current project. 

o Select Replace Backgrounds of All Slides to replace all slides backgrounds with 
slides of the new captured project. Selecting this option will launch the blue 
rectangle and the Replace Slide Backgrounds dialog so that you can capture the 
new project. 

o Select Replace Backgrounds of Selected Slides to replace some selected slide 
backgrounds with slides of the new captured project. Selecting this option will 
launch the blue rectangle and the Replace Slide Backgrounds dialog so that you 
can capture the new project. 

Step 4. In the Slide Background Replacer window, arrange new slides on the right in the 
same order as current slides on the left. 
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• To move a slide, drag and drop it to the new position. You can only drag slides in the 
same side (left or right) to change their position.  

• To copy/cut/paste/delete a slide, select it and press the DELETE key. You can also 
right-click it and select Delete from the context menu.  

• If you are not sure that a new slide of the new project (on the right) is redundant or not, 
move it to the bottom instead of deleting it. To do that, select the slide and click the 

down arrow button . 

• If a certain slide is required in the new language but not available in the original 

language, select it and click the Copy To Left button . This moves the selected slide 
from the right to the left. 

• If you do not want to change a certain slide in the left (e.g. the introduction slide), select 

it and click the New PlaceHolder button . This insert a placeholder slide into the 
right.  

Step 5. Click the OK button in the Slide Background Replacer window to replace slide 
backgrounds. 
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Importing from XLIFF 

After translating text and replacing slide backgrounds, you need to import the XLIFF file back 
to the project of which slide backgrounds are replaced. ActivePresenter will replace the current 
text in your project with the corresponding text in the translated XLIFF file. 

• Open the project that has been replaced slide backgrounds. 

• Click the ActivePresenter button > Projects > Localize > Import From XLIFF > 
browse the translated XLIFF file. 

• Verify imported text on each slide, adjust the object position and size if necessary. 

Active Window 

When creating a video demo or simulation to demonstrate how to work with an application or 
software (e.g. Microsoft), you will want to capture only a specified window sometimes (e.g. a 
confirmation dialog). ActivePresenter can automatically detect the area that you want to 
capture and save the information to captured slides through the Active Window feature. 

To view the Active Window, do one of the following:  

• Open the Slide tab > View Active Window . 

• Right-click the slide on the Canvas > View Active Window.  

The following screenshot shows an Active Window area (in the red dashed border) in a 
captured slide: 
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In some certain circumstances, the Active Window area detected while capturing doesn’t fit 
the dialog/window. You can modify this area by opening the Slide tab > Edit Active Window  

, or right-clicking the slide on the Canvas and select Edit Active Window. 

This enables the Edit Active Window Area tool. Then, you can resize the Active Window by 
dragging the red dashed border.  
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Exporting Projects 

Overview of Exporting Options 

ActivePresenter allows you to export the presentation in many different forms which are listed 
in the table below:  

Format Description 

Images Export all slides as images that can be used for purposes related to the 
presentation/training course. Each slide will be exported to an image. 

Video  Export the presentation to a video. Use the video exporting format type 
when the interaction with audience is not required. 

HTML 
SlideShow 

Slides in the presentation are exported to images, and embedded in HTML 
pages to be viewable in a browser. 

PDF 
Document 

Slides in the presentation are exported to images, and embedded in the 
PDF format. 

Microsoft 
Word 
Document 

Slides in the presentation are exported to shapes, text and images, and 
inserted in a doc/docx file. After that, this file can be edited further in 
Microsoft Word (or LibreOffice Writer). 

Microsoft 
Excel 

Slides in the presentation are exported to shapes, text and images, and 
inserted in an xls/xlsx file. After that, this file can be edited further in 
Microsoft PowerPoint (or LibreOffice Calc). 

Microsoft 
PowerPoint 

Slides in the presentation are converted into PowerPoint slides. After that, 
this exported file can be edited further in Microsoft PowerPoint (or 
LibreOffice Impress). 

HTML5  Presentation is exported to a set of files (HTML, CSS, JavaScript, etc.) using 
the HTML5 standard so it can run on most modern browsers (Internet 
Explorer 9 or later, Google Chrome, Mozilla Firefox, Safari), and on various 
devices and platforms (Windows, macOS, Linux, iOS, Android).  

Exporting to Images 

When you choose to export a project to images, each slide of the project will be exported to 
an image, which is great for creating brochures, handouts, and posters for the training. 

To export the project to images, open the Export tab > Images . 

After that, ActivePresenter will pop up a dialog as shown in the screenshot below:  
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The dialog has three main sections which are Rendering Options, Image, and Output 
section.  

General Options  

• Include Closed Caption: Export images along with closed captions (if any). Deselect 
this check box to exclude closed captions in the exported images.  

• Include Cursor Path: Export images along with cursor path (if any). Deselect this 
check box to exclude the cursor path in the exported images.  

• Include Objects Started by Event: Export images along with objects that are 
triggered by events. 

• Only Export Active Window Area: The exported images only include the Active 
Window area and slide objects that are selected to export.  

Image  

Parameter Option Description 

Size Range: 10% 
to 150%  
(in steps of 
10%) 

The size is relative to the slide size.   

You can view the slide size of the project by clicking the 
ActivePresenter button > Project > Project Properties > 
Project Size.  

Note that ActivePresenter only works with logical size (e.g. 
pixels). However, when displayed/printed, the physical size 
depends on pixels and the dpi (dots-per-inch) setting of the 
displaying printing device. 



ActivePresenter User Manual  Version 7 

Exporting Projects > Exporting to Images  230 
 

Format  JPEG 

PNG 

Due to their specs and compression algorithms, JPEG is 
best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).  

JPEG compression is lossy while PNG is lossless.  

PNG retains crystal clear quality, but it does not compress 
well with pictures (very big file size) and its decoding (when 
viewing) is slower than JPEG’s.  

PNG is suitable for screenshot compression because the file 
has a small size and there is no quality loss.    

Optimization 
Level  

None 

Low 

Normal 

High 

Ultra 

These are relative compression levels. Note that the higher 
the compression level, the longer it takes to export.  

• Select None when testing the output. 
• Select Ultra or High when exporting the final result. 

This option is only available if the PNG image format is 
selected. 

Quality Range: 1% to 
100% 

The higher the quality, the larger the output file size. This 
option is only available if the JPEG image format is selected. 

Output  

This section defines the location where the exported images will be saved. 
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Exporting to Videos 

The video format is suitable when audience don’t have to interact with the presentation in a 
self-paced manner. 

Exported videos can contain all animations, closed captions, and audio files, etc., that you 
have inserted in.   

To export the project to a video, open the Export tab > Video .  

The Export To Video dialog having two tabs will pop up as described in the following parts.  

General Tab 

 

Rendering Options  
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Option Description 

Zoom-n-Pan  The exported video will include the zoom-n-pan effect that 
you have inserted in the project. 

Include Cursor Path  The exported video will include the cursor path that you have 
inserted in the project.  

Export Audio This option is selected by default. Deselect this check box if 
you want to remove audio from the output.  

Since the audio data is not written to the output file so the file 
size of the video having audio will be smaller than that of the 
video without audio.  

Exported Closed Captions as 
Soft Subtitles (.srt) 

If you select this option, closed captions will be exported as 
a separate subtitle file (with .srt extension).  

This allows you to change the font, size and color of the 
subtitles at the play time. 

You can also change the .srt file to display the subtitles in a 
different language. 

Export Closed Caption as 
Hard Subtitles 

If you select this option, closed captions will be hard-coded 
inside the video. Any video player which can play the video 
can also display subtitles. However, the attributes of the 
subtitles cannot be changed at the play time. 

Embedded in HTML The project will be exported and embedded in HTML.  

Video  

Option Description 

Video Size 
(%) 

Select in the range [50, 150] (in steps of 10%). 

The video’s size reference is the slide size. You can view the slide size of 
the current project by clicking the ActivePresenter button > Project > 
Properties > Project Size.  

The video will be rescaled using bicubic interpolation. 

Note that the aspect ratio is fixed when you created the project. It cannot be 
changed at the render time. 

When you specify the width or height, the Video Size will be automatically 
calculated based on the original size of project. 

Width The width of exported video. When you specify the Video Size or height, the 
width will be automatically calculated based on the original size of project. 
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Height The height of exported video. When you specify the Video Size or width, the 
height will be automatically calculated based on the original size of project. 

Frame Rate Set between 1 and 30 fps (frames per second). 

Key Frame  Specify the number of frames between which we must have a key frame 
(default: 3* Frame Rate). 

Quality Select in the range [1,100]. The higher number, the better quality and the 
larger file size. 

Audio  

Option Description 

Channels Select from mono/stereo. 

Bit Rate Select from 64, 96, 128, 192, 256, 320 kbps. This option is only available for 
the AVI, MP4, FLV, and WMV format. 

Sample Rate Select from 11025, 22050, 44100, and 48000 Hz. The 48000 Hz option is 
not available for the FLV format. 

Quality Select in the range [1,100]. The higher number, the better quality and the 
larger file size. This option is only available for the WebM format. 

Output  

Option Description 

Format Select from AVI, MP4, WMV, WebM, MKV, and FLV. 

The following video and audio codecs are used for each container format: 

• AVI: MS MPEG4 v2, WMA v2. 

• MP4: H264 High Profile, ACC. 

• WMV: WMV v2, WMA v2. 

• WebM: VP8, Vorbis. 

• MKV: Flash Screen Video, PCM 16-bit (this format using lossless 
audio and video codecs so it can be used for further editing in other 
programs without quality loss). 

Output File Specify the file path and name for exported video. 
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Advanced Tab 

This tab allows you to set the thumbnail for the exported video when you choose to embed it 
in HTML. 

Option Description 

None The exported video does not have any thumbnail.  

Select a slide image from 
project 

Select one slide from the project to set as a thumbnail for 
the exported video.  

Select an image from file Select one image from your computer to set as a thumbnail 
for the exported video.  
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Exporting to HTML SlideShows 

To export the project to HTML SlideShow, in the Export tab, click HTML SlideShow  . 

The Export to HTML SlideShow dialog will pop up as shown in the screenshot below: 

 

Rendering Options  

Option Description 

Include Closed Caption If this option is selected, the images will have the closed 
caption that you have inserted in. 

Generate Navigation Guide 
Page 

Create a first page which contains the guideline of using 
hotkey to navigate through the slides. 

Include Cursor Path If this option is selected, the slideshow will include the cursor 
path that you have inserted.  

Generate in Compact Mode Create only one slide per slide group. 

Include Objects Started by 
Event 

Include the objects that are started by events.  

Only Export Active Window 
Area 

The exported area only includes the Active Window area 
and slide objects which are selected to export.  
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Image  

Parameter Option Description 

Size Range: 10% 
to 150%  

(in steps of 
10%) 

The size is relative to slide size of the project. You can view 
the slide size of the current project by clicking the 
ActivePresenter button > Project > Project Properties > 
Project Size. 

Note that ActivePresenter only works with logical size (e.g. 
pixels). However, when displayed/printed, the physical size 
depends on pixels and the dpi (dots-per-inch) setting of the 
displaying printing device. 

Format  JPEG 

PNG 

Due to their specs and compression algorithms, JPEG is 
best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).  

JPEG compression is lossy and PNG is lossless. So, PNG 
retains crystal clear quality, but it does not compress well 
with pictures (very big file size) and its decoding (when 
viewing) is slower than JPEG. However, screenshots are 
compressed better with PNG, the file has a small size and 
there is no loss of quality. 

Optimization 
Level  

None 

Low 

Normal 

High 

Ultra 

These are relative compression levels. Note that the higher 
the compression level, the longer it takes to export.  

• Select None when testing the output. 

• Select Ultra or High when exporting the final result. 

This option is only available if the PNG image format is 
selected. 

Quality Range: 1% to 
100% 

The higher the quality, the larger the output file size. This 
option is only available if the JPEG image format is selected. 

Output  

This section defines the location where the exported images will be saved.

Exporting to PDF Documents 

To export the project to Adobe PDF Document, in the Export tab > PDF Document . 

The Export To Adobe PDF dialog will pop up. It has three tabs which are described in 
details in the next parts. 
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General Tab 

 

Rendering Options 

Option 
Description 

Include Objects Started by 
Event  

The exported file will include objects which are started by 
events. 

Create Bookmarks Bookmarks are created from slide names and each 
bookmark is linked to a corresponding slide image. In other 
words, ActivePresenter creates bookmark links to each slide. 

However, there is a little difference in Compact mode, the 
first bookmark level is the slide group title, the second one is 
the slide name. 

Only Export Active Window 
Area 

The exported area only includes the Active Window area 
and slide objects which are selected to export. 

Layout 

Option 
Description 

Slides Per Page One: Single slide per page. 
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Two: Two slides per page (top, bottom). 

Contiguous: The slides are written contiguously in a page 
until there is not enough space, then it will be moved to the 
next page. 

Compact: Only the screen of the first slide in each group is 
exported. For the following slides, ActivePresenter exports 
only the slide name and slide description. 

Description Export slide description and specify which side of the slide to 
place it (Top, Left, Right, or Bottom).  

None: No description exported. 

Page Orientation Choose from landscape and portrait. 

The page size is fixed (A4). 

ActivePresenter uses fixed margins of 1” (2.54 cm) on all 
sides. 

Description Width The width of the slide description in each exported slide (in 
percentages). 

This option is only activated when you choose to place the 
description on the left or right side of the slide.  

Image 

Parameter Option 
Description 

Format  JPEG 

PNG 

Due to their specs and compression algorithms, JPEG is 
best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).  

Note that JPEG compression is lossy while PNG is lossless, 
so PNG retains crystal clear quality, but the downside of 
PNG is that it does not compress well with pictures (very big 
file size) and the decoding (when viewing) is slower than 
JPEG. However, screenshots are compressed better with 
PNG, the file has a small size and there is no quality loss. 

Optimization 
Level  

None 

Low 

Normal 

High 

Ultra 

These are relative compression levels. Note that the higher 
the compression level, the longer it takes to export.  

• Select None when testing the output. 

• Select Ultra or High when exporting the final result. 

This option is only activated if the PNG image format is 
selected. 

Quality Range: 1% to 
100% 

The higher the quality, the larger the output file size. 



ActivePresenter User Manual  Version 7 

Exporting Projects > Exporting to PDF Documents 239 
 

This option is only activated if the JPEG image format is 
selected. 

Output 

Specify the file path and name for the exported PDF document. 

Advanced Tab 

This tab contains two sections:  

• Description: PDF document-related options. 

• Protection: Security password for opening the PDF document. 

Description 

Option 
Description 

Title Title of the PDF document.  

When you open the PDF in a viewer, this name appears in the Windows Bar 
(or in the tab in the case of a tabbed PDF reader). 

Subject Subject of the document.  

This is one of PDF document properties which can be seen in Document 
Properties in any PDF viewer. 

Keywords Keywords defined in the PDF document. 

Protection

Opening Password  You can set a password for opening this PDF document. 

Confirm Password Enter the password again manually (no copy-paste from the 
previous field). 

Text Style Tab 

This tab controls the text in the generated PDF file. 

You can change the font size, line spacing, and text color for three different parts of the slide: 

• Group Title: The group title is only exported in the Compact mode. It’s placed before 
any slide group.  

• Slide Name: The name of the slide which is entered in Slide Title box in the Slide 
Description section.  

• Slide Description: The description of the slide which is entered in the Slide 
Descriptions section.  
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Exporting to Microsoft Word Documents 

General Options 

To export the project to Microsoft Word Document, in the Export tab > Microsoft Word 

Document . 

 

Rendering Options 

Option 
Description 

Include Objects Started by 
Event  

Include objects which are started by events.  

Create Table of Contents Add a Table Of Contents to the document with hyperlinks to 
slides. 

Only Export Active Window 
Area 

The exported area only includes the Active Window area 
and slide objects which are selected to export.  
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Layout 

Option Description 

Slides Per 
Page 

One: Single slide per page. 

Two: Two slides per page (top, bottom). 

Contiguous: The slides are written contiguously in a page until there is not 
enough space, then it will be moved to the next page. 

Compact: Only the screen of the first slide in each group is exported. For the 
following slides, ActivePresenter exports only the slide name and slide 
description. 

Description Export slide description and specify which side of the slide to place it (Top, 
Left, Right, or Bottom). 

None: No description exported. 

Description 
Width 

The width of the slide description in each exported slide (in percentages). 

This option is only activated when you choose to place the description on 
the left or right side of the slide. 

Page 
Orientation 

Choose from landscape and portrait. 

The page size is fixed (A4). 

ActivePresenter uses fixed margins of 1” (2.54 cm) in all sides. 

Use 
Template 
Layout 

Use the layout specified in the template. Refer to Creating Custom Word 
Template to learn more about how to create a custom layout.  

Image 

Parameter Option 
Description 

Format JPEG 

PNG 

Due to their specs and compression algorithms, JPEG is 
best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).  

Note that JPEG compression is lossy while PNG is lossless, 
so PNG retains crystal clear quality, but the downside of 
PNG is that it does not compress well with pictures (very big 
file size) and the decoding (when viewing) is slower than 
JPEG. However, screenshots are compressed better with 
PNG, the file has a small size and there is no quality loss. 
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Optimization 
Level  

None 

Low 

Normal 

High 

Ultra 

These are relative compression levels. Note that the higher 
the compression level, the longer it takes to export.  

• Select None when testing the output. 

• Select Ultra or High when exporting the final result. 

• This option is only available if the PNG image format 
is selected. 

Quality Range: 1% to 
100% 

The higher the quality, the larger the output file size. 

This option is only available if the JPEG image format is 
selected. 

Output 

Template Location of the template file. 

Output File Specify the file path and name of the exported document. 

Creating Custom Word Template 

When exporting to MS Word Document, you can create your own Word template and let 
ActivePresenter use it to create the output document. 

To create a custom layout template, you must have Word 2002 (Word XP) or a higher version 
installed on your computer. 

The steps are as the following: 

Step 1. Placing contents  

The following tags will be used to specify the location to place exported contents: 

• $SlideName1 

• $SlideDescription1 

• $SlideImage1 

For example, if you want to place slide name somewhere in the template, you type 
$SlideName1 in that location. 

Only the usage of $SlideImage1 is different. This is used to specify the location of the slide 

content (slide background, shapes, captions, text, etc.). You need to insert a Word drawing 

canvas and set its Alternative Text to $SlideImage1. 

Step 2. Styling contents 

To set styles (font name, font size, color, etc.) for Slide Name, Slide Description, you cannot 
set text properties directly to the tags. You need to open the Styles pane and add new styles 
and name to them as: SlideName and SlideDescription. ActivePresenter will automatically use 
these styles when writing Slide Name and Slide Description text. 

After exporting, you can also change these styles easily by opening exported document and 
changing appropriate styles. 
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Exporting to Microsoft Excel Worksheets 

To export the project to Microsoft Excel Worksheet, in the Export tab > Microsoft Excel .

 

Rendering Options 

Option 
Description 

Include Objects Started by 
Event  

Include objects which are started by events. 

Only Export Active Window 
Area 

The exported area only includes the Active Window area 
and slide objects which are selected to export. 

 

Layout 

Option 
Description 

Slides Per 
Page 

One: Single slide per page. 

Two: Two slides per page (top, bottom). 

Contiguous: The slides are written contiguously in a page until there is not 
enough space, then it will move to the next page. 
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Compact: Only the screen of the first slide in each group is exported. For the 
following slides, ActivePresenter exports only the slide name and slide 
description. 

Description Export slide description and specify which side of the slide to place it (Top, 
Left, Right, or Bottom).  

None: No description exported. 

Description 
Width 

The width of the slide description in each exported slide (in percentages). 

This option is only activated when you choose to place the description on 
the left or right side of the slide. 

Page 
Orientation 

Choose from Landscape and Portrait. The page size is fixed (A4). 

ActivePresenter uses fixed margins of 1” (2.54 cm) in all sides. 

Image 

Parameter Option 
Description 

Format  JPEG 

PNG 

Due to their specs and compression algorithms, JPEG is 
best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).  

Note that JPEG compression is lossy while PNG is lossless, 
so PNG retains crystal clear quality, but the downside of 
PNG is that it does not compress well with pictures (very big 
file size) and the decoding (when viewing) is slower than 
JPEG. However, screenshots are compressed better with 
PNG, the file has a small size and there is no quality loss. 

Optimization 
Level  

None 

Low 

Normal 

High 

Ultra 

These are relative compression levels. Note that the higher 
the compression level, the longer it takes to export.  

• Select None when testing the output. 

• Select Ultra or High when exporting the final result. 

This option is only available if the PNG image format is 
selected. 

Quality Range: 1% to 
100% 

The higher the quality, the larger the output file size. 

This option is only available if the JPEG image format is 
selected. 

Output 

Template Location of the template file. 

Output File Specify the file path and name of the exported worksheet. 
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Exporting to Microsoft PowerPoint Presentations 

To export the project to Microsoft PowerPoint Presentation, in the Export tab > Microsoft 

PowerPoint . 

 

Rendering Options 

Option 
Description 

Include Objects Started by 
Event  

Include objects which are started by events.  

Only Export Active Window 
Area 

The exported area only includes the Active Window area 
and slide objects which are selected to export.  

Layout 

Option 
Description 

Show Slide Name Display the slide name. 

Full Screen Open the presentation in full screen initially. 

Show Slide Description Render the slide description. 
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Advance Slides Select between Automatic and Manual. 

Image 

Parameter Option 
Description 

Format  JPEG 

PNG 

Due to their specs and compression algorithms, JPEG is 
best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).  

Note that JPEG compression is lossy while PNG is lossless, 
so PNG retains crystal clear quality, but the downside of 
PNG is that it does not compress well with pictures (very big 
file size) and the decoding (when viewing) is slower than 
JPEG. However, screenshots are compressed better with 
PNG, the file has a small size and there is no quality loss. 

Optimization 
Level  

None 

Low 

Normal 

High 

Ultra 

These are relative compression levels. Note that the higher 
the compression level, the longer it takes to export.  

• Select None when testing the output. 

• Select Ultra or High when exporting the final result. 

This option is only available if the PNG image format is 
selected. 

Quality Range: 1% 
to 100% 

The higher the quality, the larger the output file size. 

This option is only available if the JPEG image format is 
selected. 

Output 

Template Location of the template file.  

Output File Specify the file path and name of exported presentation. 
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Exporting to HTML5  

General Tab 

 

Operation Modes 

Parameter 
Description 

Modes There are four modes: Demonstration, Tutorial, Practice, and Test. 

You can select which modes to be exported and available to users. 

Besides, you can let each object show in each mode individually during the 
object editing phrase through the Show in Mode section in the Properties 
pane.   

The difference between four modes is explained in details in the table right 
below this table. 
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Total Max 
Time  

(in minutes)  

This is the total number of time which is taken by all objects to complete their 
lifecycles plus the time for students to answer. It also includes the pausing 
time of the presentation to wait for user answers.   

Set the value to 0 to disable this feature.  

Generate 
Index Page 

Select this check box to generate the HTML index page which contains the 
entry to open all selected modes. 

Total Max 
Time  

(minutes)  

This is the total number of time which is taken by all objects to complete their 
lifecycles plus the time for students to answer. It also includes the pausing 
time of the presentation to wait for user answers.   

Set the value to 0 to disable this feature.  

Pass 
Condition 

This condition is used to determine the overall pass/fail result of students 
when they take a test. 

Choose between the following options:  

• Percent of correct answers. 

• Points gained. 

• Number of correct answers. 

• Number of slides viewed. 

Due to SCORM specifications, take the following notes when the SCORM 
option is selected: 

• In SCORM 1.2, the raw score submitted to LMS is a normalized 
value in range 0-100. 

• In SCORM 2004, the raw score submitted to LMS is a normalized 
value in range 0-100 if the first condition (percent of correct answers) 
is chosen. Otherwise, it is an absolute value. 

Not less than: Enter a numerical value (cannot exceed 100) in this box. 

This is the minimum score that users have to gain to pass the test. 

The difference between four operation modes: 

Function Demonstration 
Mode 

Tutorial 
Mode 

Practice 
Mode 

Test 
Mode 

The simulation automatically runs 
based on the time you have set for 
objects and slides. 

Yes Yes Yes Yes 

The presentation jumps to the next 
slide when the current slide comes 
to the end. 

Yes Yes Yes Yes 

If the toolbar is available, users 
can control the presentation such 
as navigate to a certain slide, 
pause/resume the simulation. 

Yes Yes Yes Yes 
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The simulation supports interactive 
capability through mouse and 
keyboard. 

No Yes Yes Yes 

ActivePresenter assesses user 
response and executes associated 
actions which you have defined 
before. 

No Yes Yes Yes 

It has options to create the report 
of user result and send it to a 
specified HTTP address. 

No No Yes Yes 

The simulation displays interactive 
hidden objects when users fail to 
execute associated actions in 
predefined time. 

Not Applicable Yes Yes No 

Authors can limit the maximum 
time which users are allowed to 
complete the test. 

No No No Yes 

Content 

These options are applied to background images of slides. 

Parameter Option 
Description 

Include 
WebM & Ogg 

 

Select this check box to allow viewing HTML5 content on 
browsers which don’t support MP4 and MP3 but support 
WebM and Ogg.   

Enable 
Visual Focus 
Indicator 

 
If this check box is selected, an outline is displayed for the 
object having focus. 

Embed Fonts 
 

Embed fonts which are used in content into output using 
CSS3 Web font specification, so the content will look 
consistently between platforms and devices. 

JPEC Quality 
(%) 

Range: 1% to 
100% 

The higher the quality, the larger the output file size. 

This option only affects to images which are exported in 
JPEG format. 

PNG 
Compression 
Level 

None 

Low 

Normal 

High 

These are relative compression levels. Note that the higher 
the compression level, the longer it takes to export.  

• Select None when testing the output. 

• Select Ultra or High when exporting the final result. 
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Ultra This option only affects to images which are exported in 
PNG format. 

Audio Bit 
Rate 

64 Kbps 

96 Kbps 

128 Kbps 

192 Kbps 

256 Kbps 

320 Kbps 

Specify the audio bit rate in the output if any. The higher 
value, the higher audio quality and larger output file size. 

Video Quality 
(%) 

 

Specify quality for videos in the output if any. The higher 
value, the higher video quality and larger output file size. 

Output 

You can specify output location and file name from this section.  

When you click the Settings button, the following dialog will pop up allowing you to have 
further settings for the output:  

 

Player: the location for storing HTML5 player script and CSS files. 

Project Resources: the location for storing project images, audio, and video. 

Index Resources: the location for storing index page images. 

File Name Prefix: the file names of project related files such as resources and project CSS 

and JavaScript files will begin with this prefix. This option may be used in the scenario that 

the system needs putting files of multiple projects into one folder. 
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Reporting Tab 

 

eLearning Options 

This section allows you to package the content to one of the following standards for uploading 
to LMS: SCORM 1.2, SCORM 2004, and Experience API (xAPI). 

Option Description 

SCORM 1.2 and SCORM 2004 

Identifier Specify a name used by the LMS to identify different manifests (this 
value is generated automatically by ActivePresenter but you can 
change it if needed). 

Version  Specify a version that can be used to differentiate manifests with the 
same identifier.  
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Organization Title Specify a title for the organization which this item belongs to. 
Although ActivePresenter automatically generates this value from 
project name, you can change it if needed. 

Item Title The title of your project that is displayed to users viewing the project 
using an LMS.  

Although ActivePresenter automatically generates this value from 
project name, you can still change it if needed.  

Report the score in 
percentage 

Normalize the score in the range 1-100 instead of an absolute value. 
This option is only available in SCORM 2004. Score in SCORM 1.2 is 
always normalized. 

Export each 
operation mode to a 
separated package. 

Export each operation mode to a separated package instead of 
exporting all operation modes to one package with multiple 
organizations. 

Experience API 

Identifier Specify a name used by the LMS to identify different manifests.  

This value is generated automatically by ActivePresenter but you can 
change it if needed. 

Title The title of your project that is displayed to users viewing the project 
using an LMS. ActivePresenter automatically generates this value 
from project name but you can change it if needed.   

Description The description of your project that is displayed to users viewing the 
project using an LMS. ActivePresenter automatically generates this 
value from project description but you can change it if needed.  

Export each 
operation mode to a 
separated package. 

This option is always selected by default when exporting to 
Experience API. 

Additional Report 

This section lets you decide how to report the test results taken by students. They are useful 
when you don’t have an LMS or you want to handle the report by yourself. 

Option Description 

Method Choose between the following options:  

• No Report: Do not send the report. 

• HTTP: Send report through the HTTP request. 

Format Choose between the following reporting formats:  

• XML Document. 
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• JSON (JavaScript Object Notation). 

HTTP 
Address  

This is the HTTP address of a server side script that will process the report 
data (the data is either in XML or JSON format). 

Non LMS Reporting 

Content of Report 

The report can be formatted in various ways but the content generally consists of the following: 

Property Description 

Name Presentation name (also the project name). 

Description Presentation description (also the project description). 

Date The local time (based on the user computer date and time setting) when 
the report is created. 

UserID Identity of the user who takes the practice or test. When the user logs in 
to take the test, the server side script should store a cookie which its 
name is "userid".  

If no "userid" cookie found, the user will be prompt to input his/her identity 
before sending the report. 

TotalTime Duration in seconds in which users take the practice or test. 

SlideCount Number of slides in the presentation. 

TakenSlide Number of slides which the user has taken. 

TotalInteraction Number of interactions in the presentation. 

TakenInteraction Number of interactions which the user has taken. 

Correct Number of interactions which users perform correctly without any help. 

Score Score (marks) users gain through the practice or test, only correct action 
gains points. 

MaxScore Maximum score which users can gain in the practice or test (by taking 
correctly all slides). 

Percent Score over MaxScore in percentages (Score/MaxScore*100). 
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Result The practice or test assessment based on the pass condition. 

• For human readable: Passed or failed 

• For computer: True or false 

Users pass the practice or test if their results are greater than or equal 
the minimum required result. The result can be points which users gain, 
points gained over maximum points in percentages, or number of correct 
answers.  

Details Detail result for each slide and interaction which is called the interaction 
data record. 

The Details section of the report data contains an array of the interaction data record. Each 
interaction data record contains the following information: 

Property Description 

SlideIndex The index of the slide which contains the interaction (start from 1). 

ReportID The ReportID of the interaction. 

Attempts The number of actions that viewers have tried. 

Score Score gained when viewers interact with interactions. 

MaxScore The maximum score that viewers can get when interacting with interactions. 

Result A string represented in the output language of the presentation. It can be one 
of the following values: 

• Correct 

• Incorrect 

• Incomplete 

• (Empty) 

Type Type of the interaction represented in the output language of the 
presentation. There are the following interaction types: 

• Mouse Click 

• Key Stroke 

• Text Box 

• Drop Area 

• True/False 

• Multiple Choice 

• Multiple Response 

• Essay 
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• Fill in Blank 

• Fill in Multiple Blanks 

• Sequence 

• Drag-n-Drop 

• Rating Scale (Likert) 

LearnerRes
ponse 

Viewers’ responses.  

Some examples for each interaction type: 

• Mouse Click:  

• Left click 

• Click outside 

• Right click 

• Left double-click 

• Key Stroke:  

• A 

• Ctrl+A 

• Ctrl+Shift+Alt+A 

• Text Box:  

• This is a sample text 

• Drop Area:  

• Drop_area_report_id[.]Draggable_report_id 

• True – False: 

• Answer1_report_id 

• Multiple Choice: 

• Answer1_report_id 

• Multiple Response: 

• Answer1_report_id[,]Answer2_report_id 

• Essay:  

• This is a sample text 

• Fill in Blank: 

• This is a sample text 

• Fill in Multiple Blanks: 

• Answer1_report_id[.]text_value1[,]Answer2_report_id[.]text_val
ue2[,]Answer3_report_id[.]text_value3 

• Sequence: 

• Answer1_report_id[,]Answer2_report_id[,]Answer3_report_id[,]
Answer4_report_id 

• Drag-n-Drop: 
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• Droppable1_report_id[.]Draggable1_report_id[,]Droppable2_re
port_id[.]Draggable2_report_id[,] 

• Rating Scale (Likert): 

• Answer1_report_id[.]0[,]Answer2_report_id[.]5 

CorrectRes
ponses 

An array of correct responses. The format of a correct response is similar to 
the format of a learner response. 

Report in XML Format 

The report is formatted in XML (Extensible Markup Language) format. 

Here is an example: 

<?xml version="1.0" encoding="UTF-8"?> 

<Content> 

 <Report> 

  <Name>Quiz Sample</Name> 

  <Description></Description> 

  <Date>Tue, 10 May 2016 04:15:58 GMT</Date> 

  <UserID>apteam</UserID> 

  <TotalTime>96</TotalTime> 

  <SlideCount>2</SlideCount> 

  <TakenSlide>2</TakenSlide> 

  <TotalInteraction>2</TotalInteraction> 

  <TakenInteraction>2</TakenInteraction> 

  <Correct>2</Correct> 

  <Score>2</Score> 

  <MaxScore>2</MaxScore> 

  <Percent>100</Percent> 

  <Result>Passed</Result> 

  <Details> 

   <Interaction> 

    <SlideIndex>1</SlideIndex> 

    <ReportID>MouseClick1</ReportID> 

    <Attempts>2</Attempts> 

    <Score>1</Score> 

    <MaxScore>1</MaxScore> 

    <Result>Correct</Result> 

    <Type>Mouse Click</Type> 

    <Answers>Left click</Answers> 

    <LearnerResponse>Left click</LearnerResponse> 
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    <CorrectResponses> 

     <CorrectResponse>Left click</CorrectResponse> 

    </CorrectResponses> 

   </Interaction> 

   <Interaction> 

    <SlideIndex>2</SlideIndex> 

    <ReportID>KeyStroke1</ReportID> 

    <Attempts>1</Attempts> 

    <Points>1</Points> 

    <MaxPoints>1</MaxPoints> 

    <Result>Correct</Result> 

    <Type>Key Stroke</Type> 

    <Answers>Space</Answers> 

    <LearnerResponse>Space</LearnerResponse> 

    <CorrectResponses> 

     <CorrectResponse>Space</CorrectResponse> 

    </CorrectResponses> 

   </Interaction> 

  </Details> 

 </Report> 

</Content> 

Report in JSON Format 

The report is formatted in JSON (JavaScript Object Notation) format. 

Here is an example: 

{ 

 "Name": "Quiz Sample", 

 "Description": "", 

 "Date": "Tue, 10 May 2016 04:32:36 GMT", 

 "UserID": "apteam", 

 "TotalTime": 79, 

 "SlideCount": 2, 

 "TakenSlide": 2, 

 "TotalInteraction": 2, 

 "TakenInteraction": 2, 

 "Correct": 2, 

 "Score": 2, 

 "MaxScore": 2, 

 "Percent": 100, 
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 "Result": true, 

 "Details": [ 

  { 

   "SlideIndex": 1, 

   "ReportID": "Question_5", 

   "Attempts": 1, 

   "Score": 1, 

   "MaxScore": 1, 

   "Result": "Correct", 

   "Type": "Fill Multiple Blank", 

   "Answers": "1.quick, 2.jumps, 3.dog", 

   "LearnerResponse": "1[.]quick[,]2[.]jumps[,]3[.]dog", 

   "CorrectResponses": [ 

    "1[.]quick[,]2[.]jumps[,]3[.]dog" 

   ] 

  }, 

  { 

   "SlideIndex": 2, 

   "ReportID": "Question_6", 

   "Attempts": 1, 

   "Points": 1, 

   "MaxPoints": 1, 

   "Result": "Correct", 

   "Type": "Sequence", 

   "Answers": "1, 2, 3, 4, 5, 6, 7", 

   "LearnerResponse": "1[,]2[,]3[,]4[,]5[,]6[,]7", 

   "CorrectResponses": [ 

    "1[,]2[,]3[,]4[,]5[,]6[,]7" 

   ] 

  } 

 ] 

} 

Transmission of Report 

When the report is sent via HTTP protocol, the POST method will be used. The key is "report" 
and the value is the report content with the format specified when exporting to HTML5 
presentation.  

The server-side script at the HTTP address must handle and process the report.  

For example, suppose that the HTTP address is 

"http://atomisystems.com/reportreceiver.php". 
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The following is a trivial sample code in reportreceiver.php file to receive and process report: 

In case that you want to send the report data to a Google Sheets document or an email, you 
can see this tutorial to know how to do it: 

https://atomisystems.com/elearning/send-quiz-report-google-sheets-email/ 

Player Settings 

HTML5 is an interactive presentation, which is delivered through a browser. A Playback 
Control Toolbar is provided at the bottom of the screen, which allows users to play/pause/stop 
the presentation, show/hide closed captions, change volume, or jump to a particular slide. 
ActivePresenter allows you to customize that Toolbar through the Player Settings window. 

Besides, the Player Settings window also lets you create and customize the look and feel of 
the Table of Contents, and edit the Output Language.  

General Settings 

To open the Playback Controls window, open the Export tab > Player Settings  > 

Playback Controls . 

<?php 
if (isset($_POST["report"])) 
{ 

//read report data 
$report = $_POST["report"]; 
//process report, e.g. append to a text file here 
$report_file = fopen("report.txt", "a"); 
if($report_file) 
{ 

fwrite($report_file, $report); 
//separate this report from others 
fwrite($report_file,"\n\n---------\n\n"); 
fclose($report_file); 

} 
} 
?> 

https://atomisystems.com/elearning/send-quiz-report-google-sheets-email/
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1. Skin 

Access the Skin drop-down list and select the template for the Playback Control Toolbar. 

Click the Save button  next to the Preset drop-down list to name and save the template that 
you’ve customized as a new one. This new saved parameter preset will be available to use 

later on. Click the Remove button  to delete a preset. You cannot delete the Custom preset.  

2. Operation Mode 

ActivePresenter allows you to customize the Player for each operation mode separately or all 
of them together. Click the Operation Mode drop-down list and select the mode that you want 
to customize the Player for.  

Click Apply to All to apply the settings for all of the mode. 

Click the Restore Defaults button  to disable all changes and bring back the default 
settings. 

3. Parameters 

This section has three main parts containing parameters for Table of Contents, Toolbar, and 
Color settings.  

To customize any parameter, select it and adjust the value.  

4. Preview  

The Preview window displays all the adjustments you’ve made, which makes them more 
visual and intuitive. 

Table of Contents 

An informative table of contents (TOC) is essential for your project as it can give your audience 
a visual overview of the whole project and help them find what they are looking for at a single 
glance.  
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You can click a TOC entry to jump to the corresponding slide. The TOC entry associated with 
a side is also highlighted in the TOC pane when the slide is activated. A check mark next to a 
slide in the TOC pane indicates that the slide has been viewed completely.  

By default, ActivePresenter generates the TOC and shows it in the output. If you want to hide 
the TOC, go to Player Settings > General Settings > Table of Contents. Then, set the Initial 
State to Hidden. That way, you hide the TOC from view.  

Remember that you can always toggle the visibility of the TOC by click the TOC button at the 
bottom-right corner of the player toolbar. 

You can change the hierarchy of entries in the TOC regardless of the hierarchy of slides in the 
project. That is, the reorganization in the TOC doesn’t affect the order of the slides. Do one or 
more of the following to reorganize the TOC: 

 

• Uncheck the status check box if you want to hide certain slides in the TOC. Click the 

Visibility button  to show or hide all slides. Note that hiding a TOC entry doesn’t 
remove the slide from the project. 

• Click an entry, select Add New Topic  to add new entry right above it.  

• Click Move Entry Right  to make an entry one sublevel down. Click Move Entry 

Left   to make an entry one sublevel up. 

• Click Move Entry Up  to move an entry before previous. Click Move Entry Down 

 to move an entry after the next entry. You can also move a TOC entry by dragging 
it to a new location. 

• Click Reset Table Of Contents  to discard your changes. 

• Click Delete Entry  to delete an entry you create.  

• Click Settings  to adjust the TOC heading style. 

In case you reorganize slides after creating the TOC, your changes will not be automatically 
updated. Click Reset Table Of Contents to reflect any changes. New slides added to the 
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project after creating the TOC will be automatically listed according to their hierarchy in the 
project. 

Edit Output Language 

ActivePresenter provides the ready translated text for the output (name of elements in the 
toolbar and messages) for all supported languages through the Output Language editor. If you 
want to modify the translation or add the support for your language, do one of the following:  

• Open the Export tab > HTML5 > Edit Output Language.  

• Open the Export tab > Player Settings > Edit Output Language . 

The editor provides the following properties: 

• Project Language: Display the language of the opening project. You can change the 
Project Language in the Project Properties dialog (1). 

• Name: Display the text in the current user interface language of ActivePresenter so 
you can know their original meanings (2). 

• Value: Display the text in the language which is set in the Project Language section 
(if it is supported).  

You can modify the text in this column by double-clicking each row and type in it (3). 

• Reset: Restore the original translation of the text (4).

HTML5 Preview  

To preview the HTML5 output before actually exporting, click the HTML5 Preview button  

in the Home and Export tab. 

Click the drop-down arrow on the button to select one from four operation modes 

(Demonstration, Tutorial, Practice, Test).  

  



ActivePresenter User Manual  Version 7 

ActivePresenter Windows > Canvas  263 
 

ActivePresenter Windows 

Canvas  

The Canvas which is placed at the center of the User Interface displays all the slide contents. 
It can also be called the Working Window.  

When your project has many slides, the Canvas shows contents of the selected slide. All the 
project creating and editing are visually done here. This means that you can view all the 
changes of objects you’ve made from other panes (Properties pane, Timeline pane, etc.). 

• With a blank project, the Canvas displays the blank slide. 

• With a recorded project, the Canvas displays the recorded videos/slides along with all 
the annotations added. 

• With a created project, the Canvas shows the slide with all of its contents (quizzes, 
shapes, images, videos, etc.). 

Changing Canvas Color 

By default, the Canvas has a light gray color. You can change its color by clicking the 
ActivePresenter button > Preferences > Canvas Background Color, click the Color box 
and select one color from the Color Picker box that appears.  

When you change the Canvas color, the slide’s color is not affected. If you want to change the 

color for slides, open the Design tab > Background Styles .  

Refer to Slides to know more in details about slide’s properties.  

Zooming Canvas  

When working in ActivePresenter, you may want to zoom in or out the Canvas to work with 
objects or slides more clearly and easily sometimes.   

To zoom in/out the Canvas, do one of the following: 

• Drag the Zoom slider at the bottom-right corner of the application window. 

Drag it to the right or left to zoom in or zoom out the Canvas respectively. 

• Open the View tab > Zoom  > select a preset zoom scale percentage from the 
Zoom dialog that appears, or enter a value in the Percent spin box. 

• Place the mouse inside the Canvas area > hold CTRL while scrolling the mouse wheel 
up or down to zoom in or zoom out the Canvas respectively.  

To automatically fit the Canvas zoom level, do one of the following: 

• Click the Zoom Fit button  next to the Zoom slider. 

• Open the View tab > Zoom Fit . 

This automatically adjusts the zoom level to fit the space of the Canvas.  
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Canvas Snapping  

Canvas Snapping lets you align different objects and elements more easily and precisely. 

To turn the Snap mode on, open the View tab and click Canvas Snapping .  

When the Snap mode is on, as soon as a moving “snappable” element comes in the vicinity 
of another “snappable” element, it will make a tiny jump to match the edge of each other. 
Vertical or horizontal orange lines or both will appear to visualize the alignment.
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Timeline Pane  

Timeline Overview 

A Timeline defines how multiple objects in slide show or hide against time. By default, each 

slide has a Main Timeline which is run automatically when entering slide. You can add more 

Timelines into a slide. These added Timelines called interactive Timelines since they can only 

be run by an action. If you are working with a video project, you just need to work with Main 

Timeline while working with interactive presentation, you may need to use interactive 

Timelines. 

The Timeline pane is used to manage Timelines and edit each Timeline. You can do the 
following tasks in the Timeline pane:  

• Edit audio/video objects (e.g. split, join, change volume/speed, insert time, etc.). 

• Edit the object timing and animations. 

• Play slides and record your commentary in real time.  

• Preview slides. 

• Add, remove, or rename Timelines. 

 

Managing Timelines 

In ActivePresenter 7, you can create and manage multiple timelines simultaneously with the 
Multiple Timelines feature. You can add more or remove timelines when needed.  

• Select a Timeline: Click the Timeline list box and select one of the existing Timelines 
from the drop-down list.  

• Add a Timeline: Click the Timeline list box and select Add Timeline. The new 
Timeline will be created with an auto generated name (Timeline N). The newly created 
Timeline will be automatically chosen for editing.  You can add more than one Timeline.  

• Remove a Timeline: Click the Timeline list box, and select the Timeline that you want 
to remove, and then click Remove Timeline. You cannot remove the Main Timeline.  

• Rename a Timeline: Click the Timeline list box, and select the Timeline that you want 
to rename, and then click Rename Timeline. Enter a new name in the pop-up dialog 
and click OK.  You cannot rename the Main Timeline.  

Using Multiple Timelines 

To use Multiple Timelines, do the following steps:  
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1. Add Timelines.  

2. Rename added Timelines to a more meaningful name.  

3. Add animations to objects.  

To add animations to objects in add Timelines, select the object from the Canvas or Selection 
pane. Then, open the Animations tab and select entrance and exit effect from the effect 
gallery. 

4. Use events – actions to start/pause/continue the added Timelines.  

The Toolbar in the Timeline pane 

The Toolbar provides most of the functions in the Timeline pane.  

Button Name Hotkey Function 

 Add Timeline 
 

Add a Timeline. 

 Remove 
Timeline 

 
Remove a Timeline.  

 Rename 
Timeline 

 
Rename a Timeline.  

 Single 
Slide/All 
Slides 

 

Toggle between Current Slide and All Slides 
view. 

The All Slides display mode shows all slides 
in the Timeline. This mode is useful to see 
the objects that span across multiple slides. 

 Snapping 
 

If this is selected, the dragged object snaps 
to the features of other objects and to certain 
parts of the Timeline pane. See Timeline 
Snapping for more details.  

 Preview  

SPACE BAR 

Click to play the slide once, starting from the 
current position of the Playhead. You can 
also right-click the slide on the Canvas and 
select Play Preview. At the end of the 
preview, the Playhead returns to the start 
marker of the range. 

While the selection is being played, the 

button turns to Pause . When you click 
this button, the preview pauses, and the 

button turns to Resume . The Playhead 
stays at its current position. 

Click the Resume button to start playing 
from the Playhead current position, and click 

this button again to Pause . 

After that, successively click the button to 

toggle between Pause  and Resume . 

Tips: Instead of clicking these buttons, it is 
far easier to simply press the SPACE BAR 
to play/pause/resume. 
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If you click the drop-down arrow of this tool, 
a submenu will show up with two options: 

• Preview all: Select this option to 
preview from the first slide to the last 
slide in the project, which is similar to 
viewing the video output. 

• Preview from current slide: This 
option is similar to Preview all, 
however, the preview will start from 
the current slide. 

 Stop 
 

If you click this button while the Timeline is 
playing, ActivePresenter will stop playing, 
and the Playhead will stay at its current 
position. 

If you click this button when the Timeline is 
not playing, then ActivePresenter will remove 
the selection markers of the Playhead. In 
other words, use this button to clear the 
selected range. 
Double-click this button to temporarily hide 
the Playhead. Then, if you click the Preview 

button , the slide will be previewed from 
the very beginning.   

 Record 
Narration 

 

Record your voice even when you play the 
slide simultaneously. 

This allows you to watch the slide playback, 
and time your voice perfectly with the action 
on the screen. 

This also allows you to dub your slide in 
another language. 

To stop recording, press the Stop button . 

 Zoom out 
Timeline 

 

Click this button to reduce the time scale of 
the Timeline. 

Hold CTRL while scrolling down the mouse 
wheel to get the same result.  

 Zoom in 
Timeline 

 

Click this button to expand the time scale 
and see more details. 

Hold CTRL while scrolling up the mouse 
wheel to get the same result.  

 Zoom fit 
Timeline 

 

Click this button to automatically adjust the 
zoom factor to fit the entire slide's duration in 
the available pane width. 

 Cut Range CTRL+SHIFT+X 
Cut the selected range, and place it in the 
clipboard. 
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• The slide duration is shrunk by the 
duration of the range. 

• If the Time Bar of any object extends 
on both sides of the range, the 
remaining parts on both sides of the 
range are joined together. 

This command is activated only when a 
range is defined. The Cut Range command 
is explained in more details here. 

 Copy Range CTRL+SHIFT+C 
Copy the selected range into the clipboard.  
The original contents of the slide are not 
affected. 

This command is activated only when a 
range is defined. The Copy Range command 
is explained in more details here.   

 Delete Range CTRL+DELETE 
Delete the selected range.  
Nothing is placed in the clipboard (compare 
with the Cut Range command). 

This command is activated only when a 
range is defined. The Delete Range 
command is explained in more details here. 

 Crop to 
Range 

SHIFT+DELETE 
Everything in the slide is deleted except the 
content that falls within the range. 

After this command is executed, the duration 
of the slide is reduced to the cropped range. 

This command is activated only when a 
range is defined. The Crop to Range 
command is explained in more details here.  

 Insert Time 
 

This command is primarily used for inserting 
a Freeze-Frame control in the selected 
audio/video track at the position of the 
Playhead. 

To keep annotations in sync with the 
audio/video, you should make sure that they 
are all selected when using this command.  

If you want to expand the whole slide at the 
Playhead position, select nothing in the 
Timeline and click this button.  

The Insert Time command is explained in 
more details here.  

Note: In the older versions of 
ActivePresenter, you can insert Freeze-
Frames into an audio/video by using the 
Insert Silence/Freeze-Frame tool in Timeline. 
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From version 5.5, this tool is superseded by 
the Insert Time tool. 

 Split 
Audio/Video 
Objects 

 

Split the selected audio/video object at the 
Playhead position. 

• The Timeline shows the latter part as 
a new object.  

• The split parts are treated as new 
project-level resources (which 
appear in the Resources pane), and 
can be further used in other slides 
within the project. 

In case of audio objects, each split part is 

shown with a separate Audio icon  on the 
Canvas. However, all these icons are 
stacked together, so you cannot tell them 
apart. Only when you drag them apart can 
you see them individually. 

The Split Audio/Video Objects command is 
explained in more details here. 

 Join 
Audio/Video 
Objects 

 

Join the selected audio/video objects.  

This command is explained in details here. 

 Change 
Playback 
Speed 

 

Speed up or slow down the selected range of 
the selected audio/video track, as explained 
here. 

 Insert Blur 
Area 

 

This command is used for inserting a blur 
area into the selected video. The detail is 
described in the Blur Effect section. 

 Adjust 
Volume 

 

Adjust the relative volume of the selected 
range of the selected audio/video track, as 
explained here. 

 Audio Fade In 
 

This command is used for audio editing.  

 Audio Fade 
Out 

 

This command is used for audio editing. 

 Audio Noise 
Reduction 

 

This command is used for audio editing.  

 Insert Caption 
 

Insert a Closed Caption (CC) object into a 
video. 

 Split Slide 
 

Split the slide at the Playhead position.  

The slide is sliced vertically at the Playhead 
position, and a new slide is created from the 
second part. This newly created slide is 
inserted immediately after the current slide. 

https://docs.google.com/document/d/1XD46LItmclTg0jzRdXoTiAWp8MYuOeYoWacP728DxJs/edit#heading=h.3znysh7
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• Any content in the slide that is in the 
right side of the Playhead is 
transferred to the second (new) slide.  

• If the Playhead lies at the middle of 
the Time Bar of an object, that Time 
Bar is split at the Playhead position, 
and the latter part is transferred to the 
second (new) slide. 

 Go to 
Previous 
Keyframe 

 

This command is used for editing Blur 
Effect. 

 Add/Remove 
Keyframe 

 

This command is used for editing Blur 
Effect. 

 Go to Next 
Keyframe 

 

This command is used for editing Blur 
Effect. 

Object Time Bars 

The Time Bar of an object represents its existence along the time axis.  

 

As you can see from the Time Bar of Shape 10 in the screenshot above, Shape 10 will appear 
on the Canvas at the 5th second after the slide starts to play. The shape will disappear at the 
15th second, which means its duration is 10 seconds. The length of the object Time Bar 
represents its duration.  

The shape has animation effects which can be realized by the green and red bar placed inside 
the object Time Bar. The green-bar’s length indicates the duration of the entrance effect while 
the red-bar’s length indicates the duration of the exit effect.  

Though there are many kinds of objects in ActivePresenter, not all of them have Time Bar: 

• Sub-objects of composite objects don't have Time Bars. They use the timing values 
from top level parent.  

• Background images don't have Time Bars because they remain unchanged. You 
cannot vary their properties over time. 

• The object time bar is only available in Main Timeline since it takes a role for 
audio/video editing functions. The  

Initially Hidden Objects 

We can set the initial state of an object as hidden, so it can only be shown by an action or an 

interactive Timeline. The initially hidden object is represented in the Timeline pane as below: 
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You cannot change the time bar of initially hidden object. 

To change the initially hidden state, just right-click object and select Initially Hidden. You 

can also change this option in the Properties pane > Timing section. 

By default, some types of messages such as Correct Message, Incorrect Message are 

initially hidden objects. 

Changing Object Timing & Duration 

The timing and duration of an object is easy to adjust by using its Time Bar. The left-side edge 
of the Time Bar is the start point, and the right-side edge of the Time Bar is the end point of 
the object.  

• Changing the start time of objects: Hover the mouse over the start point of the object 
Time Bar until the mouse turns to a double-headed arrow, drag it horizontally to change 
its start time.  

 

• Changing the end time of objects: Hover the mouse over the end point of the object 
Time Bar until the mouse turns to a double-headed arrow, drag it horizontally to change 
its end time.  

 

• Moving objects in the Timeline: Hover the mouse over the object Time Bar until the 
mouse turns into a four-way arrow, drag the bar horizontally, and drop it wherever you 
want.  

 

You can move multiple objects as well as change their start/end points simultaneously 
by selecting multiple of them, and then moving them together. To select multiple 
objects, hold CTRL or SHIFT while clicking object Time Bars or clicking object names 
in the Timeline.  

To select contiguous objects, click the first object, and then hold CTRL while clicking 
the last object, all of the objects between these two objects will be selected. 

Putting Multiple Objects in a Line  

Each line in the Timeline can contain multiple objects which are displayed sequentially. Thanks 
to that, you can easily organize and track their timing and duration.  
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Objects in a line have the successive z-order. This means the object on the left has a smaller 
z-order in comparison with the one on the right. You cannot swap the z-order between two 
objects in a line without changing their start time.  

 

To move an object along its current line, select the object, then drag it sideways and drop it to 
the desired position.  

If the object is between two other objects, you can only move it within the available space 
between them.  

If the object is at the end of the line, the slide duration will be extended when you drag the 
object to the right and reach the end point of the slide duration.  

To move an object to a new line, do one of the following: 

• Select the object and drag it upward or downward to the new line. You can only drop 
the object in the line which has enough available space between two objects for it.  

If the object is placed at the end of the line, and the duration of the object is greater 
than the available duration, the Slide duration will be automatically extended to contain 
it.  

You can move multiple objects together sideways, but you cannot move them up/down 
simultaneously to the new line.  

• When there are at least two objects in a line: Right-click the object, then select Move 
Up into a New Line or Move Down into a New Line from the context menu. In this 
case, ActivePresenter will create a new line containing the object.  

Inserting Objects Using Playhead 

Note that the following description doesn’t apply for cursor path, closed caption, and zoom-n-
pan.  

When you insert an object with the present of the Playhead in the Timeline, the object will be 
placed at the Playhead position. The start time of the object is the current time of the Playhead.  

If there are any existing objects in a line and the duration of the newly inserted object is smaller 
than the line duration, the new object will be placed before them in the same line.  

If there are any existing objects, and the duration of the newly inserted object is larger than 
the line duration, the new object will be placed in the other line and above them in the Timeline, 
as long as the new line doesn’t contain any object that is overlapped in time with it.  

When you insert an object without the Playhead presented in the Timeline, the start time of 
the object is set to 0, and its duration is stretched to the end point of the slide. The new object 
will also be placed above existing objects in the slide.  
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Timeline Snapping 

With the Snap mode in ActivePresenter, you can align different objects more easily and 
precisely in the Timeline. When the Snap mode is on, as soon as a moving “snappable” 
element comes in the vicinity of another “snappable” element, it will make a tiny jump to match 
the timestamp of the other element.  

The Snap mode applies to the following elements: 

• In Ruler area: Playhead, start marker and end marker of the range. 

• In the Time Bars of objects: Starting and ending edge, all markers inside the object 
Time Bar. 

• Others: Start and end point of the slide.  

To turn the Snap mode on, open the View tab > Timeline Sapping . 

Below are some notes when using the Snap mode: 

• The “other element” may be anywhere in the Timeline: Right from the Ruler to the 
lowest object's Time Bar. The vertical separation between the elements does not 
matter at all. 

• You may not be dragging the “snappable” element itself. For example, when we drag 
a Time Bar of an object, all the “snappable” elements in the bar are moving 
simultaneously. Any of these elements can snap to another snappable element. 

• You can temporarily disable the Snap mode by pressing CTRL when dragging the 
element. 

When a snapping takes place, ActivePresenter shows an orange vertical line at that point of 
time in order to draw your attention. This helps you to synchronize the dragged elements 
precisely with other elements in the Timeline. Now it is up to you whether to drop the dragged 
element there or keep dragging. 

Productivity Tips for Using Timeline 

Most of the editing work is accomplished on the Canvas and Timeline. Hence, knowing some 
productivity tips for using them will make you work more effectively.  

Here is a summary of hotkeys on the keyboard that you can use when working with the 
Timeline:  

Hotkey Function 

HOME Move the Playhead to the beginning of slide. 

END Move the Playhead to the end of slide. 

LEFT ARROW • When no objects are selected: Move the Playhead to the 
left.  

• When objects are selected: Move the selected objects to 
the left. 

CTRL+LEFT ARROW Same as above, but 10 times faster (the CTRL key is x10 
accelerator). 
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RIGHT ARROW • When no objects are selected: Move the Playhead to the 
right. 

• When objects are selected: Move the selected objects to 
the right. 

CTRL+RIGHT ARROW Same as above, but 10 times faster (the CTRL key is x10 
accelerator). 

[ Move the Playhead to the start marker of the selected range. 

] Move the Playhead to the end marker of the selected range. 

SHIFT+[ Set the start marker of the selected range at the Playhead 
position.  

SHIFT+] Set the end marker of the selected range at the Playhead position. 

SHIFT+LEFT ARROW • When no objects are selected: Move the start point of the 
range to the left. 

• When objects are selected: Reduce the selected objects' 
duration. 

CTRL+SHIFT+LEFT 
ARROW 

Same as above, but 10 times faster (the CTRL key is x10 
accelerator). 

SHIFT+RIGHT 
ARROW 

• When no objects are selected: Move the end point of the 
range to the right. 

• When objects are selected: Increase the selected objects' 
duration. 

CTRL+SHIFT+RIGHT 
ARROW 

Same as above, but 10 times faster (the CTRL key is x10 
accelerator). 

SHIFT+Mousewheel 
scrolling 

Scroll horizontally the Timeline. 

Added to that, below are some customizable hotkeys which you can change their settings by 
clicking the ActivePresenter button > Preferences > Hotkeys. 

Hotkey Function 

CTRL+SHIFT+X Cut the selected range. 

CTRL+SHIFT+C Copy the selected range to the clipboard. 

CTRL+DELETE Delete the selected range. 

SHIFT+DELETE Crop to range. 

CTRL+SHIFT+R Record narration. 
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Properties Pane 

The Properties pane is where you can view and change all common properties of selected 
objects or slides. 

 

There are many tabs in the Properties pane: Style & Effects, Size & Properties, 
Interactivity, Audio, Media, and Slide Properties tab.  

There are many sections in each tab. Each section displays several properties which are 
related to each other. You can freely expand or collapse any section by clicking the section 
title. You can select multiple objects or slides to change their properties simultaneously. 

Style & Effects Tab 

The Style & Effects tab contains object’s properties in terms of fill, line, and shadow so that 
you can customize them. Not all of object types have this tab. For example, an audio object 
doesn’t have this tab.  

Fill Section 

In this section, you can customize the background of the object and create your own object 
style.  

 

a) No Fill: The object's background becomes transparent (no solid color or gradient of colors). 
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b) Solid Fill: Fill the shape with a single color. 

To fill a shape with a single color, click the drop-down button of the Color Picker box > select 
a color > change the color Opacity by dragging the slider along the ruler or entering a number 
in the Opacity spin box.  

c) Gradient Fill: Fill the shape with a gradient of colors. 

 

The Gradient Strip (3) is at the heart of the controls. It shows a live sample of the gradient, 
and lets you make changes to it in a visual manner. 

Choose between Linear and Radial gradients using the Gradient Type drop-down list (1). 

• Linear: Shades vary in a straight direction. 

• Radial: Shades are in concentric circles. 

Define the Transform (2) of the gradient using the spin boxes or dragging the sliders, as 
shown below:  

• Angle: Gradient Rotation. This option is available only if you select Linear gradient 
type. 

• Offset X (%): X-offset from the top-left corner (range from -100 to 100, default value is 
0). 
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When you drag the bar of the Offset X slider to the right or increase the value in the 
spin box, the gradient stops will move to the right of the gradient correspondingly, and 
vice versa. 

The closer a gradient stop offset value is to -100, the closer the color is to the start of 
the gradient. On the other hand, the closer a gradient stop offset value is to 100, the 
closer color is to the end of the gradient. 

• Offset Y (%): Y-offset from the top-left corner (range from -100 to 100, default value is 
0). 

Note that this slider is only activated when you select the Radial Gradient type. 

When you drag the bar of the Offset Y slider to the right or increase the value in the 
spin box, the color gradient stops of the radial gradient will move downward, and vice 
versa. 

The closer a gradient stop offset value is to -100, the closer the color is to the start of 
the gradient. On the other hand, the closer a gradient stop offset value is to 100, the 
closer color is to the end of the gradient. 

• Scale X (%): Gradient horizontal scale (range from 10 to 250, default value is 100). 

When you drag the bar of the Scale X slider to the right or increase the value in the 
spin box, the horizontal radius of the radial gradient (Radial Gradient type), or the width 
of the linear gradient colors (Linear Gradient type) will be increased correspondingly, 
and vice versa. 

• Scale Y (%): Gradient vertical scale (range from 10 to 250, default value is 100). 

Note that this slider is only activated when you select the Radial Gradient type. 

When you drag the bar of the Scale Y slider to the right or increase the value in the 
spin box, the vertical radius of the radial gradient will be increased correspondingly, 
and vice versa.  

The triangular “stops” at the bottom of the Strip show how many colors are used to compose 
the gradient.  

You can click any stop to make it active and drag it along the Strip. An active stop has a red 
border. Then, use control boxes (5), (6), (7) to edit the properties of the active stop.  

To add more stops, click anywhere in the Strip (3), the new stop will be added at the point that 

you click. Alternatively, click the Add button  (4) to get the same result. After that, go to 
select a new color for the stop by clicking the Color Picker box (6), then change its opacity if 
needed (7).  

To delete any stop, select it and click the Remove button  (4). 

d) Image Fill: This option allows you to fill the shape with an image. 
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The controls are as follows: 

First, select how the shape is to be filled (1). 

• Tile: The image will be replicated in x- and y-axis to fill up the space. If the image is 
larger than the shape, it will be clipped. 

• Stretch: The image will be stretched in height and/or width to fill up the available 
space. If the image is larger than the shape, it will be rescaled to fit the available space. 

Next, select an image either from project or your file system (2). 

Line Section 

In this section, you can customize the look and feel of a line by changing its width, line style, 
cap type, and join type.  

• No Line: There is no outline for objects at all.  

• Solid Line: This part allows you to customize the line border of the object.  
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You can set the following properties for a solid line: 

• Line Width: Change the width of the line (in pixels) by entering a value in the Width 
box or clicking the up/down arrow of the spin box.  

• Cap Type: This property matters only in an open curve, where you can see the end of 
a line. You can let the end of an open shape have either a round or square cap type.  

o Round: The end of the line is capped with a round shape. 

o Square: The end of the line is capped with a square shape.  

• Join Type: You can change the type of the join where two lines intersect with each 
other.  

o Round: The corners where two lines connect are rounded.  

o Bevel: The corners where two lines connect are cut off at a 45-degree angle.  

o Miter: The corners where two lines connect are squared off.  

• Dash Pattern: Solid/dot/dash/dot-dash. 

• Arrow Type and Size: These properties are only available for Line and Arrow shape. 

• Color: Change the color of the line. 

• Opacity: Adjust the opacity of the line by moving the slider or entering a number in the 
Opacity box (255 = fully opaque). 

Shadow Section 

This section lets you customize the shadow of the object.  
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• No Shadow: The shape has no shadow. 

• Custom Shadow: Customize the shadow of the object.  

o Presets: Choose one of the presets.  

o Blur Radius: Set the blur radius for the shadow. The larger the radius, the more 
diffused the shadow.  

o Angle: Angle is measured clockwise, with x-axis as reference. 

o Distance: Set the shadow length distance from the shape. 

o Color: Select a color for the shadow. 

o Opacity: Adjust the opacity of the shadow by moving the slider or entering a value 
in the spin box (255 = fully opaque). 

Size & Properties Tab 

Timing Section 

This section defines when and how the object start/stop displaying in the presentation.  

• Start Time: The start time of the object (vis-a-vis start time of the slide). 

• Duration: The duration in which the object will be displayed in the presentation.  

• Initially Hidden: Hide the selected objects until they are called by an event.  

See Initially Hidden Objects for more information.  

• Show to the End of Slide: The object will be shown until the end of the slide. If you 
select this check box, and then change the object duration either by entering a value 
in the Duration box or dragging the object Time Bar, the check box will be 
automatically unchecked.  

Transform Section 

This section defines the size and position of the frame that is used to define the shape. 

• Left: Left edge of the frame. 

• Top: Top edge of the frame. 
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• Width: Width of the frame. 

• Height: Height of the frame. 

• Rotation: Rotate the object by specified degree in slide coordinates. The rotation 
center is the center point of the frame that is used to define the shape. 

• Lock Aspect Ratio: Keep the ratio between the width and the height of frame 
unchanged when resizing the frame. 

Text Margin Section 

This section defines the minimum margin between the frame and the text inside it. 

• Left: Minimum margin on the left side. 

• Right: Minimum margin on the right side. 

• Top: Minimum margin on the top side. 

• Bottom: Minimum margin on the bottom side. 

• AutoFit Text: When this option is selected, the frame automatically changes its size 
to fit the text. 

Group Layout Section 

Group Layout allows you to define the layout of the object group.  

The Group Layout section displays when you work with the answers of the question or a 
group of objects. In case of the question, the answer part is considered as a group of text box 
objects.  

Note: You cannot change the layout for an Essay or a Fill in Blank question. 

• Mode: Select between None and Grid layout.  

o None: Allow you to freely change the size and position of any object of a group by 
dragging it. 

o Grid: The object position is fixed and you cannot change the position/size for each 
object separately.  

You can only change the position/size for the whole group of objects together. 

• Click Start Capture to start a capture session: Number of answer column in a 
question. 

• Horizontal Spacing: The horizontal space between object columns. 

• Vertical Spacing: The vertical space between object rows. 

• Advanced Settings: Click to open the Group Layout Advanced Settings dialog, 
which lets you adjust proportion and alignment of object columns and rows. 

Show in Mode Section 

This section allows you to select the modes in which the object will be visible by clicking the 
check boxes (Demonstration, Tutorial, Practice, and Test).  

Accessibility Section 

This section defines properties that make the object accessible to viewers with disabilities 
when viewing the project output. 
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• Focusable: Define whether the object can receive focus when viewers navigate using 
the mouse or the TAB key. This property is available only for mouse click object (text 
box is always focusable). If this property is enabled, in the HTML5 output: 

o The object will gain focus automatically when it is displayed if no object in the 
content has focus at that time. 

o When the object has focus, pressing the ENTER or SPACE BAR on the keyboard 
is the same as clicking the object itself.  

o When the object has focus, the object outline (yellow, dotted by default) will be 
displayed if the Enable visual focus indicator option is selected when exporting 
to HTML5. And viewers can navigate between focusable objects by pressing the 
TAB key.  

• Auto Label: If you check this check box, accessibility text will be generated 
automatically from the text that the object displays, or the object name if it doesn't 
contain any text. 

• Name: This box shows the accessibility name of the object. Screen reader will read 
this text aloud when the object appears. 

• Description: This box provides more information about the object. Screen reader will 
read this text aloud when the object appears after reading the accessibility name. 

Cursor Section 

This section only appears if your project has a cursor path (e.g. in Software Simulations).   

Properties Function 

Cursor Image Change the cursor shape. 

Position Change the position for each dot in the dotted line of the cursor path. 

Timing Change the timing of the cursor movement.  

Start Duration The duration which is counted from the beginning point of the cursor 
segment (the time when the cursor appears) to the point when the 
cursor starts moving.  

During this time, the cursor has no movement. Refer to Changing 
Path’s Timing for more details. 

Stop Duration The duration which is counted from the point when the cursor stops 
moving to the end point of the cursor segment. 

During this time, the cursor has no movement. Refer to Changing 
Path’s Timing for more details.  

Moving 
Duration 

The duration in which the cursor has movement. Refer to Changing 
Path’s Timing for more details.  

Speed The speed of the cursor movement.  

Fixed Speed The movement speed is fixed.  
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Select this check box will disable the option to set the moving duration. 

Click Point Change the click point’s sound, effect, and timing.   

Type Select the click type to add and customize it (Left click, Middle click, 
Right-click, and Left double-click). 

Click Sound  The sound which is played when a mouse button is pressed. 

Click Time The duration from the time that the cursor appears to the time it starts 
moving. 

If that cursor is the last one, it is the cursor’s showing time. 

Click Effect The animation effect which is rendered when a mouse button is 
pressed. You can select from: None, Circle, Concentric Circles, and 
Square. 

Size Size of click effect. 

Color The color which is used to draw the click effect. 

Opacity The opacity which is used to draw the click effect. 

Apply To All 
Left Clicks 

Apply the click sound and effect to all left clicks in the simulation.  

Cursor Path Section 

This section only appears if your project has a cursor path (e.g. Software Simulations).  

Properties Function 

Highlight Type of the highlight effect.  

You can select from: None, Circle, and Square. 

Size Size of the highlight effect.  

It is the radius of the circle in the Circle Highlight or half of the square 
width in the Square Highlight. 

Color The color which is used to draw the highlight. 

Opacity The opacity which is used to draw the highlight. 

Show to end Show the last Cursor to the end of the slide.  
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Interactivity Tab  

General Section 

• Name: Show the name of the currently selected object. You can type text here to 
change its name.  

• Cursor: Change the cursor shape.  

You can let the cursor display in default shape or change it to other shape. Select none 
if you don’t want your project to show the cursor.  

• Tab Order: Allow specifying the tab order for objects. It is the order in which users 
move from one object to another by using the TAB key.  

o Focusable Only: Objects are able to receive focus. However, it will not gain the 

tab focus. 

o Auto: Objects will be automatically ordered. When the TAB key is pressed, objects 
will be selected randomly. 

o Specific Value: Define a specific order for an object. When the TAB key is 
pressed, objects will be selected in the order you’ve set. 

o None: Select this if you don’t want to give objects any tab order. 

• List of Correct Values: Allow setting the correct answer list for a question. It only 
displays for two question types: Essay and Fill in Blank.  

Click Add Value and type text in the box to set the correct answer for a question. When 
you are done with typing, click Add Value again to save the correct answer, and a new 
blank box will instantly appear, in which you can type text to set one other correct 
answer. Keep doing that until you have a desired list of correct answers for the 
question.  

When you want to delete any answer in the answer list, click the Remove button  
next to that answer.  

Score & Reporting Section 

This section allows you to select the mode of the question and interactive object between 
Graded and Survey mode and have further settings for each of them. 

When you select the Graded mode, the Score & Reporting section will show properties as 
explained below:  

• Mode: Select between Graded and Survey mode. 

• Shuffle Answer: Allow shuffling answer choices of a question.  

This property only appears when you are working with some certain types of question: 
True/False, Multiple Choice, and Multiple Response.  

• Points: Allow learners to get a specified point that you set in the Points spin box.  

Partial: Allow learners to get the points assigned to the particular correct answer that 
they choose. This option is used when you want to give some answers more or less 
points than some others. When users choose more correct answers, these partial 
scores are added up.  

• Attempts: Set the maximum number of attempts that users could make. If exceeding 
the predefined number, users could not interact with objects anymore. 
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Infinite: There is no limit for the number of attempts that users could make. 

• Timeout (ms): Enable you to specify the time limit. When this check box is selected, 
if users don’t respond within the defined time limit, objects will be disabled.  

• Max Attempts: Set the maximum number of attempts that users could make. If 
exceeding the predefined number, users could not interact with objects anymore.  

• Pause presentation to wait for user input: If this check box is selected, all objects 
stop playing as seen in the Timeline pane (users can still interact with them), and the 
presentation resumes when one of the defined actions is executed (Continue 
Presentation, End Presentation, Go to Slide, Go to Slide at Index, etc.). 

If you select this check box, you have to define actions for the question in the Events 
- Actions section.  

• Report Answers: Select this check box to enable the reporting of interactive objects. 

• Report ID: This unique reference number is used for reporting the test result. Only text 
that contains alphanumeric characters (A-Z, a-z, 0-9) and underscore (_) is allowed 
(maximum length=250 characters). 

• Password Field: Entered characters will be displayed as asterisks as if user entering 
password if this option is selected. This option is only available for text box. 

• Case Sensitive: Uppercase and lowercase letters are treated equally if this option is 
selected. This option is only available for text box. 

• Submit: Select the method to submit entered text. This option is only available for text 
box. 

• Variable: Select the variable which is associated with the text box. The value of 
variable will be updated following the content in the text box. 

When you select the Survey mode, the Score & Reporting section will only show the Report 
ID, Validate User Input, and Password Field property. 

Drag-n-Drop Section 

This section contains the drag-n-drop properties. See the Creating Drag and Drop 
Interactions section for more details. 

Events - Actions Section 

Events - Actions allows you to define actions for a given event of the question, interactive 
object, or slide of the project. 

To open this section, select the question/interactive object/slide > Interactions tab > Event 

. 

Alternatively, you can select the slide containing the question or interactive object > 

Properties pane > Interactivity tab  > Events - Actions.  

The image below shows the sample of the question’s Events - Actions.  
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There are many types of events in ActivePresenter (On Correct, On Incorrect, On Accept, On 
Rollover, etc.). They may vary from question to question and object to object. On the other 
hand, there are up to 21 types of actions that an event can have. To know more in details 
about what those events and actions are, and what they are used for, click here. 

The next parts will explain how to add and remove them in details.  

a) Adding Events 

Each question, object, or slide can have more than one event. 

To add an event to a question/object/slide, select it > hover the mouse over the 

question/object/slide title in the Properties pane > Add Event  > choose an event from the 
pop-up list. 

For example, to add an event for a Sequence Drag-n-Drop Question, hover the mouse over 

the question title and click the Add Event button , and then select an event from the pop-
up list.  

 

b) Removing Events 

To remove an event, click the event that you want to remove > Delete Event .  

For example, if you want to remove the On Correct event for a question, hover the mouse over 

this event and click the Delete Event icon .  
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c) Adding & Removing Actions for Events 

Note: Since the structure of a given event does not change from object to object, the next 
parts will describe how to add and remove actions for the On Correct event as a sample. You 
can do similarly for other types of events. 

Each event can have more than one action. In that case, actions will be played in the order 
that you insert. To change the order of an action, select it and click the Move Action Up button 

 or Move Action Down button  to bring an action up or down one level respectively.  

To add actions to an event, select the event > Add Action . Repeat these steps to add 
more actions if needed.  

For example, if you want to add actions to a correct event, select the On Correct event and 

click the Add Action button .  

 

ActivePresenter will pop up an action list, shown in the screenshot below:  
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To change the action, click the Action name (e.g. Go to Slide) and select one action from the 
pop-up action list.   

To delete an action, click/hover the mouse over the action entry, and then click the Delete 

Action button .  

 

Each action can have specified conditions. This means the action can only be played if some 

certain contexts are met. You can assign those conditions by clicking Add Condition .  

The following sections will describe how to add and remove each action for an event in details.  

1. Continue Presentation 
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To add the Continue Presentation action to an event, click the Add Action button (1) on that 
event, and select Continue Presentation from the pop-up list.  

If you want to change it into other types of action, click that action (2) and select another one 
from the pop-up list. The new action will replace the old one. This action list is exactly the 
same as the list that appears when you click the Add Action button (1).  

To remove this action, hover the mouse over it and click the Delete Action button (3). 

To add conditions for the action, click Add Condition  (4). 

2. Pause Presentation  

 

To add the Pause Presentation action to an event, click the Add Action button (1) on that 
event, and select Pause Presentation from the pop-up list.  

To change it into other types of action, click that action (2) and select another action from the 
pop-up list. The new action will replace the old one.  

To remove this action, hover the mouse over it and click the Delete Action button (3). 

To add conditions to the action, click Add Condition  (4). 

3. End Presentation 

 

To add the End Presentation action to an event, click the Add Action button (1), and select 
End Presentation from the pop-up list.  

To change it into other types of action, click that action (2) and select another action from the 
action list that pops up. This action list is exactly the same as the list that appears when you 
click the Add Action button (1). After that, the new action will replace the old one. 

To delete this action, hover the mouse over it and click the Delete Action button (3). 

To add conditions to the action, click Add Condition  (4). 
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4. Go to Slide 

 

To add the Go to Slide action to an event, click the Add Action button (1), and select Go to 
Slide from the pop-up list.  

If you want to change it into other types of action, click Go to Slide (2) and select another 
action from the pop-up list. This action list is exactly the same as the list that appears when 
you click the Add Action button (1).  

After that, you can define a particular slide that the presentation will go to. Click the slide 
number section (3) (e.g. Slide 1) and select a slide from the slide list that appears.  

For example, if you set Go to Slide: Slide 4 for a correct event, the presentation will jump to 
Slide 4 when the user takes a correct action.  

To delete this action, hover the mouse over it and click the Delete Action button (4). 

To add conditions to the action, click Add Condition  (5). 

5. Go to Slide at Index 

 

To add the Go to Slide at Index action to an event, click the Add Action button (1), and select 
Go to Slide at Index from the pop-up list.  

To change it into other types of action, click that action (2) and select another action from the 
pop-up list. This action list is exactly the same to the list that appears when you click the Add 
Action button (1).  

After that, you can define a particular slide index that the presentation will go to. Just click the 
slide index section (3) (e.g. 1) and enter a value in the Slide Index spin box. You can also 
click the up/down arrow button to increase/decrease the slide index respectively. 

To delete this action, hover the mouse over it and click the Delete Action button (4). 

To add conditions to the action, click Add Condition  (5). 

6. Go Forward 
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To add the Go Forward action to an event, click the Add Action button (1), and select Go 
Forward from the pop-up list.  

To change it into other types of action, click that action (2) and select another action from the 
pop-up list.  

After that, you can define a number of slides that the presentation will move forward by clicking 
the number of slide section (3) (e.g. 1 Slide), and entering a value in the Number of Slide 
spin box, or clicking the up/down arrow button to increase/decrease the number of slide 
respectively. 

For example, when you set Go Forward: 2 Slides for a correct event, the presentation will 
move forward 2 slides when the user takes a correct action.  

For example, when you set Go Forward: 2 Slides for a correct event, the presentation will 
move forward 2 slides when the user takes a correct action.  

To delete this action, hover the mouse over the action section, and then click the Delete 
Action button (4). 

To add conditions to the action, click Add Condition  (5). 

7. Go Backward 

This action works similarly with the Go Forward action, but the presentation moves backward 
n number of slide instead of moving forward.  

 

To add the Go Backward action to an event, click the Add Action button (1), and select Go 
Backward from the pop-up list.  

To change it into other types of action, click Go Backward (2) and select another action from 
the action list that pops up.  

Then, you can define a number of slides that the presentation will move backward. Clicking 
the number of slide section (3) (e.g. 1 Slide), and enter a value in the Number of Slide spin 
box, or simply click the up/down arrow button to increase/decrease the number of slide 
respectively. 

For example, when you set Go Backward: 2 Slides for a correct event, the presentation will 
move backward 2 slides when the user takes a correct action.  

To delete this action, hover the mouse over the action section, and then click the Delete 
Action button (4). 

To add conditions to this action, click Add Condition  (5). 
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8. Show Object 

 

To add the Show Object action to an event, click the Add Action button (1), and select Show 
Object from the pop-up list.  

To change it into other types of action, click that action (2) and select another action from the 
pop-up list.  

When you click Click to edit (3), ActivePresenter will pop up a dialog (4) in which you can 
select which object to show by accessing the Object list box, and set its animation effects 
through effect boxes below. To know in details about this, refer to Object’s animation effect. 

Click the Blocking check box to block subsequent actions until the object is hidden.  

For example, if you set Show Object: Correct Message_8 for a correct event, the presentation 
will show the correct message (with the animation effect you’ve set) when the user takes a 
correct action.  

To delete this action, hover the mouse over the action section, and then click the Delete 
Action button (5). 

To add conditions to the action, click Add Condition  (6). 

9. Hide Object 
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This action works similarly to the Show Object action. However, because it is used to hide an 
object, it contains exit effect only. 

To add the Hide Object action to an event, click the Add Action button (1), and select Hide 
Object from the pop-up list.  

To change it into other types of action, click Hide Object (2) and select another action from 
the action list that pops up. This action list is exactly the same as the list that appears when 
you click the Add Action button (1).  

Click Click to edit (3) to open a dialog (4) in which you can select which object to hide by 
accessing the Object list box, and set its animation effect through effect boxes below. To know 
in details about the object’s animation and effect, click here.  

For example, if you set Hide Object: Shape_1 for a correct event, the presentation will hide 
Shape_1 (with the animation effect you’ve set) when the user takes a correct action.  

To delete this action, hover the mouse over the action section, and then click the Delete 
Action button (5). 

To add conditions to the action, click Add Condition  (6). 

10. Highlight Object 
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To add the Highlight Object action to an event, click the Add Action button (1), and select 
Highlight Object from the pop-up list.  

To change it into other types of action, click Highlight Object (2) and select another action 
from the action list that pops up. This action list is exactly the same as the list that appears 
when you click the Add Action button (1).  

After that, select the object to highlight by clicking Click to edit (3). In the dialog (4) that pops 
up select an object from the object list. You can also define its animation effect through effect 
boxes here. Refer to object animations and effects for more details.  

For example, if you set Highlight Object: Shape_1 for a correct event, the presentation will 
highlight Shape_1 (with the animation effect you’ve set) when the user takes a correct action.  

To remove this action, hover the mouse over the action section, and then click the Delete 
Action button (5). 

To add conditions to the action, click Add Condition  (6). 

11. Change Object State 

 

To add the Change Object State action to an event, click the Add Action button (1), and select 
Change Object State from the pop-up list.  

To change it into other types of action, click Change Object State (2) and select another 
action from the action list that pops up. This action list is exactly the same as the list that 
appears when you click the Add Action button (1).  
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After that, click Click to edit (3) and select an object from the existing objects, select a state 
from the existing states from the pop-up dialog (4).  

For example, if you set Change Object State: Shape 7, hover for a correct event, the 
presentation will show the Hover state of the object named Shape 7 when users take a correct 
action.  

To remove this action, hover the mouse over the action section, and then click the Delete 
Action button (5). 

To add conditions to the action, click Add Condition  (6).   

12. Play Audio 

 

To add the Play Audio action to an event, click the Add Action button (1), and select Play 
Audio from the pop-up list.  

To change it into other types of action, click Play Audio (2) and select another action from the 
action list that pops up. This action list is exactly the same as the list that appears when you 
click the Add Action button (1).  

Then, select the audio file to play by clicking Click to edit (3) and do one of the following 
methods:  

Click  button to import an audio file from other projects (4).  

Click  button to import an audio file from your computer (5). 

After that, when the user takes a correct action, ActivePresenter will play the audio file that 
you’ve selected.  

If you want to delete this action, hover the mouse over the action section, and then click the 
Delete Action button (6). 

To add conditions to this action, click Add Condition  (7). 

13. Clear User Input 

 

To add the Clear User Input action to an event, click the Add Action button (1), and select 
Clear User Input from the pop-up list.  
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To change it into other types of action, click Clear User Input (2) and select another action 
from the action list that pops up. This action list is exactly the same as the list that appears 
when you click the Add Action button (1).  

After that, click All showing interactions (3) and select where to clear input of users from the 
pop-up list (4). For example, if you set Clear User Input: Multiple Choice Question 2 for a 
correct event, the presentation will clear all of the inputs that learners have made in this 
question.  

To remove this action, hover the mouse over the action section and click the Delete Action 
button (5). 

To add conditions to the action, click Add Condition  (6). 

14. Submit 

 

To add the Submit action to an event, click the Add Action button (1), and select Submit from 
the pop-up list.  

To change it into other types of action, click Submit (2) and select another action from the 
action list that pops up. This action list is exactly the same as the list that appears when you 
click the Add Action button (1).  

After that, click All showing interactions (3) and select the object to submit from the pop-up 
list (4). You can choose to submit all showing interactions or a specific interaction object. For 
example, if you set Submit: Multiple Choice Question 2 for a correct event, ActivePresenter 
will end the presentation and submit question 2. 

To remove this action, hover the mouse over the action section and click the Delete Action 
button (5). 

To add conditions to the action, click Add Condition  (6). 

15. Start Timeline 

 

To add the Start Timeline action to an event, click the Add Action button (1), and select Start 
Timeline from the pop-up list.  

To change it into other types of action, click Start Timeline (2) and select another action from 
the pop-up list. This action list is exactly the same as the list that appears when you click the 
Add Action button (1).  
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To select the Timeline to play, click Click to edit (3) and select a Timeline from the drop-down 
list (4).  

For example, if you set Start Timeline: Timeline 1 for the correct event, ActivePresenter will 
start to play the Timeline 1 when the user takes a correct action.  

If you want to delete this action, hover the mouse over the action section, and then click the 
Delete Action button (5). 

To add conditions to this action, click Add Condition  (6). 

16. Pause Timeline 

 

To add the Pause Timeline action to an event, click the Add Action button (1), and select 
Pause Timeline from the pop-up list.  

To select a Timeline to pause, click Click to edit (3) and select a Timeline from the drop-down 
list (4). Here has the list of Timeline that your project is having. If you don’t add any Timeline, 
it will show Main Timeline as the only option.  

For example, if you set Pause Timeline: Timeline 1 for the correct event, ActivePresenter will 
stop to play Timeline 1 to wait for the user’s next input when he or she takes a correct action.  

To change it into other types of action, click Pause Timeline (2) and select another action 
from the pop-up list. This action list is exactly the same as the list that appears when you click 
the Add Action button (1).  

To remove this action, hover the mouse over it and click the Delete Action button (5). 

To add conditions to this action, click Add Condition  (6). 

17. Continue Timeline 

 

To add the Continue Timeline action to an event, click the Add Action button (1), and select 
Continue Timeline from the pop-up list.  

To select a Timeline to pause, click Click to edit (3) and select a Timeline from the drop-down 
list (4). Here has the list of Timeline that your project is having. If you don’t add any Timeline, 
it will show Main Timeline as the only option.  

For example, if you set Continue Timeline: Timeline 1 for the correct event, ActivePresenter 
will stop playing the current Timeline and continue by playing Timeline 1 when users take a 
correct action.  
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To change it into other types of action, click Continue Timeline (2) and select another action 
from the pop-up list. This action list is exactly the same as the list that appears when you click 
the Add Action button (1).  

To remove this action, hover the mouse over it and click the Delete Action button (5). 

To add conditions to this action, click Add Condition  (6). 

18. Adjust Variable 

 

To add the Adjust Variable action to an event, click the Add Action button (1), and select 
Adjust Variable from the pop-up list.  

To edit the variable, click Click to edit (3) and change the value in the pop-up dialog (4). 

To change it into other types of action, click Adjust Variable (2) and select another action 
from the pop-up list. This action list is exactly the same as the list that appears when you click 
the Add Action button (1).  

To remove this action, hover the mouse over it and click the Delete Action button (5). 

To add conditions to this action, click Add Condition  (6). 

19. Send Email 

 

To add the Send Email action to an event, click the Add Action button (1), and select Send 
Email from the pop-up list.  

After that, click Click to edit (3) and type or paste the email address in the text box that pops 
up (4). 

To change it into other types of action, click Send Email (2) and select another action from 
the pop-up list. This action list is exactly the same as the list that appears when you click the 
Add Action button (1).  

To remove this action, hover the mouse over it and click the Delete Action button (5). 

To add conditions to this action, click Add Condition  (6). 
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20. Open Webpage 

 

To add the Open Webpage action to an event, click the Add Action button (1), and select 
Open Webpage from the pop-up list.  

After that, click Click to edit (3) to open the dialog (4) where you can enter or paste the web 
address in the URL box. The Window list box lets you decide how to open the page (in a New, 
Parent, Current, Topmost, or Named Window).  

To change it into other types of action, click Open Webpage (2) and select another action 
from the pop-up list. This action list is exactly the same as the list that appears when you click 
the Add Action button (1).  

To remove this action, hover the mouse over it and click the Delete Action button (5). 

To add conditions to this action, click Add Condition  (6). 

21. Execute JavaScript  

 

To add the Execute JavaScript action to an event, click the Add Action button (1), and select 
Execute JavaScript from the pop-up list.  

After that, click Click to edit (3) to open the Write JavaScript Code window.  

To change it into other types of action, click Execute JavaScript (2) and select another action 
from the pop-up list. This action list is exactly the same as the list that appears when you click 
the Add Action button (1).  

To remove this action, hover the mouse over it and click the Delete Action button (4). 

To add conditions to this action, click Add Condition  (5). 

d) Adding Conditions To Actions 

ActivePresenter allows you to set specified conditions for a given action so that the action can 
only be played if predefined conditions are met. Conditions can be based on variables or 
shapes in which the slide displays.  

To add conditions for an action, click or hover the mouse over the action entry and click Add 

Condition . This pops up the Add Condition dialog. 
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Note: The content of this dialog will vary differently. It depends on which type of objects you 
are working with.  

For example, if you want to add conditions to the Show Object action of the On Correct event, 

hover the mouse over the Show Object action, and click the Add Condition button  to open 
the Add Condition dialog as shown in the image below:   

 
 

Parameter Function 

And/Or Use this to combine multiple conditions in an action. 

And  Execute the action if all conditions are true. 

Or  Execute the action if there is at least one condition is true. 

List  The type of object to be compared in a condition. 

Variables Compare a variable with a value or other variable. 

Shapes Compare the current state of a shape to a specified state of the shape. 

Mouse Compare the value of a mouse click event to a value. This is only available in 

the On Click event. 

Key Compare the value of key stroke event to a value. This is only available in 

the On Key Press event. 

If Specify the variable, shape to be compared. 

Operator  The logical operator which is used to compare. 

State The state of the shape which the current state of the shape is compared with. 
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Type  Select to compare a variable with a variable or a value. 

Value Set the value to compare the variable with. 

After adjusting the Add Condition dialog, click Add button to complete the process. Then 
click Close to close the dialog.  

After that, a Condition entry will be added right below the Action entry.  

 

To delete a condition, hover the mouse over that condition section, and click the Delete 

Condition button . 

To edit the condition that you’ve added, click the Edit Condition button  . This opens the 
Edit Condition dialog which has the same structure and content to the Add Condition one 
shown above.  

Audio Tab  

The Audio tab is used to change and edit the sound associated with objects, such as shape, 
text caption, etc. in a project. The sound plays when the object starts showing. In general, this 
tab has the same structure and function as those of the Audio section in the Media tab, except 
the Playback Options section.  

To view this contextual tab, select the object > Properties pane > Audio tab  .  

General  

This part shows the name and source of the audio file and its duration. It also contains 
playback buttons to control the audio playing.  

• Click  button to select an audio from project or click  button to import an audio file 
from your computer. 

• Click the Remove button  to delete the audio.   

Recording 

This part allows you to record your own audio track. To record the sound, do as follows:  

1. Select a device from the Input Device drop-down list. 

2. Click the Record button  to start recording.  

3. Click the Volume control button  to adjust the recording volume.  

4. Click the Stop button  when finished.   
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Note: You can calibrate the sound level before starting the recording to make sure that the 
sound level is strong enough. To calibrate the sound level, click Calibrate Input… and scale 
the input volume in the pop-up dialog.  

Text To Speech  

This part provides you an alternative source of the sound, which is a text-to-speech sound of 
the text that is entered in the box. 

By default, ActivePresenter copies the text that is entered in the shape into this box. However, 
you can edit the text by directly entering here.  

To adjust the TTS settings, do as follows:  

1. Click the Settings button. The following dialog will pop up: 

 

2. Select a TTS voice from the Voice drop-down list. All the installed voices are displayed 
here. 

Adjust the speed and volume, and then check out the overall effect by clicking the 
Speak button. Repeat the cycle till you are satisfied, and then click OK to exit. 

3. Click the Generate button to generate the TTS audio.  

When you generate a TTS audio, the object duration can be shorter than the generated audio 
duration. In that case, ActivePresenter will open a dialog to ask whether you want to extend 
the object duration to match the duration of the generated audio.  

You can also take further adjustments in the Preference dialog to extend the object duration 
so that it can match the audio duration. Do the following to get it done: Click the 
ActivePresenter button > Preferences > select Yes in the Extend object duration to match 
the duration of generated audio section.  
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Media Tab 

The Media tab is only displayed if you select a media file (audio/video) in your project. If you 
select an audio file, the Media tab will show the Audio section. On the other hand, when you 
select a video file, the Video section will be shown.  

Audio Section 

 

a) General  

This part shows the name and source of the audio file and its duration. It also contains 
playback buttons to control the audio playing.  

• Click the  button to select an audio from project or click the  button to import an 
audio file from your computer. 

• Click the Remove button  to delete the audio.   

b) Recording 

This part allows you to record your own audio track. To record the sound, do as follows:  

1. Select a device from the Input Device drop-down list. 

2. Click the Record button  to start recording.  
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3. Click the Volume control button  to adjust the recording volume.  

4. Click the Stop button  when finished.   

Note: You can calibrate the sound level before starting the recording to make sure that the 
sound level is strong enough. To calibrate the sound level, click Calibrate Input… and scale 
the input volume in the pop-up dialog.  

c) Text To Speech  

This part provides you an alternative source of the sound, which is a text-to-speech sound of 
the text that is entered in the box. 

By default, ActivePresenter copies the text that is entered in the shape into this box. However, 
you can edit the text by directly entering here.  

To adjust the TTS settings, do as follows:  

• Click the Settings button. The following dialog will pop up: 

 

• Select a TTS voice from the Voice drop-down list. All the installed voices are 
displayed here. 

Adjust the speed and volume, and then check out the overall effect by clicking the 
Speak button. Repeat the cycle till you are satisfied, and then click OK to exit. 

• Click the Generate button to generate the TTS audio.  

When you generate a TTS audio, the object duration can be shorter than the generated 
audio duration. In that case, ActivePresenter will open a dialog to ask you whether to extend 
the object duration to match the new audio or not.  

d) Playback Options  

This section provides options to control how the audio is played. These options are available 
only for audio objects, not for the audio files which are attached to other types of objects. 
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• Loop: Make the video replay continuously. When the Playhead reaches the end of the 
range, it will return to the start point and continue playing. This feature is helpful 
especially for adding background music to a project.  

• Autoplay: Make the video play automatically when the slide loads and the Playhead 
reaches the start point of the video Time Bar.   

• Show Media Controls: Display a separate Play Bar for the video in HTML5 output, 
which allows users to control the playback. 

• Background Music: Make the audio file play as the Background Music for the 
presentation.  

Video Section 

a) Video 

• General: Show the name and source of the video file and its duration: 

o Click the  button to import a video from the project or click the  button to import 
a video from your computer. 

o Click the  button to delete a video.   

• Playback Options: Allow you to define the playing mode of the video: 

o Loop: Make the video replay continuously. When the Playhead reaches the end of 
the range, it will return to the start point and continue playing.  

o Autoplay: Make the video play automatically when the slide loads and the 
Playhead reaches the start point of the video Time Bar.   

o Show Media Controls: Display a separate Play Bar for the video in HTML5 output, 
which allows users to control the playback. 

b) Cursor Effects 

This part is used to change the Cursor effects for the recorded video. The following will 
describe in details how to work with it. 

• Select the Render Cursor check box to enable all the options below.  

• Change Cursor Highlight properties.  

o Click the Set the cursor path highlight button to change the cursor type. You can 
choose between None, Circle, and Square. 

o Enter a value in the Size spin box to change the highlight size of the cursor. You 
can also click the up/down arrow button to increase/decrease its size respectively.   

o Click the Color Picker split button to change the color for the highlight.  

o Drag the Opacity bar to adjust the highlight opacity. You can also enter a value in 
the Opacity spin box, or click the up/down arrow to increase/decrease its opacity.  

• Change Left-Click Effects, Right-Click Effects, and Left Double-Click Effects.  

Because the structure of these three parts doesn’t change from part to part, the following 
will explain how to change properties for Left-Click Effects. You can do similarly with the 
other two.  

o Click the Click Sound arrow button and select one sound track from the drop-down 
list. You can also import an audio file from your computer or from other projects. 

o Access the Click Effect arrow button and select one effect between Circle, 
Concentric Circle, and Square from the drop-down list.  
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o Enter a value in the Size spin box to change the click effect size. You can also click 
the up/down arrow button to increase/decrease its size respectively.  

o Click the Color Picker split button to change the color for the click effect.  

o Drag the Opacity bar to adjust the click effect opacity. You can also enter a value 
in the Opacity spin box, or click the up/down arrow to increase/decrease its 
opacity.  

c) Green Screen Effect 

This part allows you to apply the green screening technique for the video. It’s described in 
details in the Green Screen Effect for Videos section.  

d) Blur Effect 

This section is activated only if your video has a Blur effect, which is used to blur a selected 
area in a video.  

Slide Properties Tab 

This tab allows you to change properties of the slide. It has four sections which are General, 
Background Fill, Background Image, and Accessibility.   

General Section 

This section allows you to have and edit the general information of the slide. 

Property Default 
Value 

Function 

Name Blank Title of the slide.  

This property will be used as a table of content (TOC) entry 
in the HTML5 output or as a brief description of slides in 
document outputs. 

When planning navigational jumps among slides, Slide 
Name is very useful.   

Description Blank Your comments about the content. While exporting the 
project to document formats (PDF, MS Word, Excel, 
PowerPoint), you can choose whether to export slide 
description. For example, if you plan to present the slides 
personally, you can enter your speech associated with the 
slide in this field (equivalent to the “Notes” field in 
PowerPoint). 

Duration 3000 ms You can set the duration of each slide in milliseconds. This 
duration is represented by a slide Time Bar in the Timeline.  

This duration is the default value to start with. If any object in 
the slide ends beyond this time limit, ActivePresenter 
automatically extends that slide's duration to display all 
objects. 
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You can also change the duration of the slide by dragging 
the slide Time Bar along the Timeline.  

Background Fill Section 

This section allows you to set the background fill (color or image) of the slide. 

Property Function 

Solid Fill 

 

Fill the background of the slide with a single color. 

1. Click the Color Picker split button and select a color. 

2. Drag the slider along the Opacity bar to change the opacity 
value. You can enter a value in the Opacity spin box, or click the 
up/down arrow button to increase/decrease value respectively.  

Gradient Fill Fill the background of the slide with a gradient of colors.  

This part is explained in details here.  

Image Fill Fill the background of the slide with an image.  

This part is explained in details here.  

Hide background 
graphics 

Hide objects in the slide layout that is used by the slide.  

Apply to All Apply the changes you’ve made to all of slides in the project. 

Reset 
Background 

Restore the default value of the slide’s background.  

Background Image Section 

Background images can be used for many purposes, such as showing a corporate logo 
throughout the presentation, setting different backgrounds for different segments/subjects of 
the presentation, and showing a theme.  
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• To import an image to a project as the background image, you can click the  button 

to select a background image from an ActivePresenter project or click the  button to 
import a background image from your computer. The new inserted image will be 
automatically stretched to fit the slide size.  

When you choose to import an image from project, ActivePresenter will pop up the 
Select an image… dialog where you can choose which image to import.  

Click the Remove button  to delete the background image.  

• Change the background image position and size (in px or %) using spin boxes. 

o Left: X position of the background image from the top-left corner. 

o Top: Y position of the background image from the top-left corner.   

o Width: Change the width of the background image.  

o Height: Change the height of the background image. 

• Restore Original Size: Restore the original size of the inserted image.  

• Fit To Background: The inserted image will fit the background size. 

Accessibility Section 

Property Function 

Auto Label If this property is selected, accessibility text will be generated automatically 
from the slide name and slide description. 

Name Accessibility name of the slide. 
Screen reader will read this text aloud when the slide appears. 

Description This provides more information about the slide. 
Screen reader will read this text aloud when the slide appears after reading 
the accessibility name. 

Resources Pane 

The Resources pane provides you with the images and audio/video clips that are available in 
the current project. It has two tabs: 

• Images: Provide Images from the current project. 
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• Audio & Video: Provide audio and video clips from the current project. 

There are some different ways in which resources get into a project, being shown in the 
Resources pane: 

• Resources added by users: 

o Audio files by inserting, recording narration, or using Text To Speech. 

o Video files by inserting or recording. 

o Image files by inserting or capturing. 

• Logical resources created by certain operations: Audio/video splitting, audio/video 
range editing, slide splitting.

Images Tab 

As being shown in the screenshot below, the Images tab has the Toolbar and Preview 
section.  

The Toolbar section contains buttons for managing image resources.  

Button Function 

 Select to view resources either as thumbnails or items. 

 Add an image from the computer (or LAN, etc.).  

 Select the resources that are unused in the current project. 

 Remove the resource from the project storage area. 

 Export an image to a file. 

 Launch the Image editor and load the image in it. 

 This button triggers the Image Resource Properties dialog.  

You can also click the resource icon (image/video/audio) to view the resource 
information and show the dialog.  

 Toggle the Slide Background type of images.  

 Toggle the Object Background type of images. 

 Toggle the Cursor type of images. 

The Preview section shows the resources. The currently selected images have dark blue 
borders. You can drag any resource from here into the slide to use it.  

Audio & Video Tab 

The Audio & Video tab also has the Toolbar and Preview section.  
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The Toolbar section contains icons to manage the audio and video resources. The buttons 
work as follows: 

Button Function 

 

Select to view resources either as thumbnails or as items.  

 

Add an audio/video clip from the computer (or LAN, etc.)  

 

Select the resources that are unused in the current project. 

 

Remove the resource from the project storage area. 

 

Export (save) the media as a file. 

 

This button triggers the Audio/Video Resource Properties dialog. 

You can also click the resource icon (image/video/audio) to view the resource 
information and show the dialog.  

 

Toggle the Audio type of media. 

 

Toggle the Video type of media. 

The Preview section is placed at the center of the pane. This section shows the resources 
(audio files and video clips). The currently selected resource has a dark blue border. You can 
drag any resource from here into the slide to use it.  

Resource Properties Dialog  

Video Resource Properties Dialog  

The dialog has two tabs which are General and Details tab. 

The General tab contains generic information of the video such as video name, duration, 

format, and data size. You can rename the video if needed. You can use the Play button  

or Stop Playing button  to preview or stop previewing the video respectively. Click the 

Change Volume button  to change the video output volume.  

The Details tab displays more detailed information of the video, for example, audio sample 
rate, audio channels, and video frame rate.  

Audio Resource Properties Dialog  

This window also has two tabs which are General and Details tab.  

The General tab contains generic information of the audio. It also lets you preview the audio.  

Similar to the Details tab of the Video Resource Properties dialog, this tab of the Audio 
Resource Properties dialog also displays more detailed information of the audio (e.g. sample 
rate and channels). 
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Image Resource Properties Dialog  

This dialog of images has only one tab which is General tab.  

Name: Show the name of the resource, you can change it without affecting any functionality.  

Type: This is the type of the resource. You can tag the image as Slide background, Object 
background and/or Cursor.  

Cursor HotSpot: This section is for defining the cursor hotspot for the Cursor resource type. 
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Slide Pools Pane 

The Slide Pools pane is where you can manage all Slide Pools in a project. This pane is 

hidden by default. To show this pane, in the View tab, click the Slide Pools button  .  

Selection Pane 

The Selection pane shows all objects in a given slide by their stacking order (z-order). The 
Selection pane is hidden by default. To show the Selection pane, in the View tab, click the 

Selection button  .   

 

You can do the following tasks in the Selection pane: 

1. Select slide objects: If a slide has many overlapping objects, it can be tricky to select 
them using the Canvas. With the Selection pane, you can simply click a line in the 
pane to select the corresponding object on the slide.  

If you want to select multiple objects, hold CTRL while clicking them.  

If you want to select a range of objects, click the first object of the range, and then 
hold SHIFT while clicking the last object. All of the objects between the two objects 
will also be selected.  

You can also right-click selected objects and select one from the following operations: 
Cut, Copy, Delete, Bring Forward, Bring to Front, Send Backward, and Send to Back. 

2. Rename objects in the Selection pane: Double-click the name part of an object in the 
Selection pane and type a new name. Giving objects unique names can be helpful 
when you are adjusting their timing values in Timeline or writing custom script which 
refers to the object by name.  

3. Turn visibility state on or off: The Visibility button  controls whether to display the 
object on the Canvas. 

4. Click it to toggle its state (an eye-slash  means the object becomes invisible). 

The best use of this control is to turn an object off to edit the overlapped object easier. 
Note that this control is applicable only during editing; not during playback. 

It also does not affect the output when exporting. The objects which are hidden by this 
command still display normally in the exported materials. 

The Master Visibility button  in the first line toggles the visibility of all objects at 

once. 

5. Turn lock state on or off: The Lock button  controls whether you can edit the object. 
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Click this button to toggle its state.  

A closed lock  means that the object is “locked”: You cannot select its shape by 
using any pane and you cannot edit it. 

The Master Lock button  in the first line toggles the lock status of all objects at once. 

6. The Expand/Collapse button  is available for object which contains the sub-objects. 
It controls whether to display those sub-objects. You can use RIGHT ARROW or LEFT 
ARROW key on the keyboard to get the same result.  

7. You can use the UP ARROW or DOWN ARROW key on the keyboard to navigate 
between objects in the Selection pane. 

8. You can drag and drop objects to change their z-order in the Selection pane. 

Calibrate Audio Input Dialog  

The Calibrate Audio Input dialog allows you to select appropriate level of input volume for 
recording audio. 

You can calibrate audio in two different modes:  

Manual Calibration 

• Keep the microphone in its normal position, and speak in your normal volume. 

• Click the  button, and speak something into your microphone.  

• At the same time, move the slider to right and increase the gain till the LED bar on the 
right shows yellow bars intermittently. If the bar starts showing red LEDs, move the 
slider a bit to the left (otherwise the voice will be clipped).  

• When you are satisfied with the audio level, click the  button to stop the calibration. 

• Now click the  button to play your recorded voice. If the sound has any defects (e.g. 
breathing noise), take care of the problem and repeat steps 1-4. Or you can use the 
Audio Noise Reduction feature in ActivePresenter. 

Automatic Calibration 

• Click the Auto Calibrate button, and use the microphone normally. 

The Auto Calibrate button turns into Stop Calibration button which you can click 
when you want to stop the calibration.  

• Continue speaking so that ActivePresenter can automatically optimize the gain. 

After a few seconds, the button reverts to Auto Calibrate button. This indicates that the 
calibration is over. 

Regardless of the calibration method, the volume adjustment is accepted only when the OK 
button is clicked. If you click the Cancel button, the new value will be discarded and the old 
value still be applied. 
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Recording Settings Dialog 

When you record screen as video or software simulations, ActivePresenter provides the 
Recording Settings for Video and Recording Settings for Software Simulation dialog 
correspondingly so that you can have settings for the audio/video/webcam quality and storage 
size.  

In the previous versions of ActivePresenter, these settings are included in the Capture Profile 
Editor dialog.  

Both dialog have three same tabs: Audio & Video, Cursor, and Hotkeys tab. However, the 
Recording Settings for Software Simulation dialog has one more tab which is the 
Annotation tab.  

Audio & Video Tab 

This tab contains two main sections for audio, video, and webcam settings separately.  

 

Video Settings Section 

• Video Codec: ActivePresenter offers two choices which are Flash Screen Video 
(lossless) and H.264/MPEG-4 AVC (lossy). 
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When the flash codec is selected, ActivePresenter uses the lossless algorithm in 
encoding to preserve the quality. But when you select the H.264 codec, 
ActivePresenter down-samples the video data, resulting in the reduction of file size but 
at the cost of irreversible loss of video detail. 

• Frame Rate: A higher frame rate can increase the size of the recorded video. It may 
also overload simpler computers, because the computer not only has to run all the 
applications, but also captures those screens in real time. In the worst case, you will 
see dropped frames in the captured video. 

On the other hand, a lower frame record will appear jerky. This particularly happens 
with the rates which are lower than 15 frames/s. Besides, you may miss capturing 
some low-duration events (something that just flashes on the screen and vanishes). 

The most commonly used range is 20-30 frames/s. 

• Key Frame Every: This is the number of continuous non-key frames between key 
frames. When recording video, ActivePresenter will automatically place a key frame 
every n frames. 

When you change the frame rate, ActivePresenter automatically adjusts this setting so 
that the video will have exactly one key frame every four seconds. But you can 
manually change this rate. 

Key frames are full frames that video player can jump directly to, a higher value results 
in a (little bit) smaller video size, but will make seeking less accurate. Also, in case of 
corruption, lesser number of frames are lost because the key frames spaces are closer. 

As a compromise, the [4 - 400] range is used. 

• Quality: When you select one of the lossy codecs, ActivePresenter allows you to select 
a quality level between 1 (min) and 100 (max). The higher the number you select, the 
better the video quality and the larger the file size. 

Audio Settings Section 

• Audio Codec: ActivePresenter offers a choice of three audio codecs which are 16-bit 
PCM, (lossless), Vorbis (lossy), and MP3 (lossy). 

When the 16-bit PCM codec is selected, ActivePresenter uses the lossless algorithm 
in encoding to preserve the quality. But when you select the Vorbis or MP3 codec, 
ActivePresenter uses the lossy algorithm in encoding, resulting in the reduction of the 
file size and the irreversible loss of audio quality. 

• Sample Rate: The incoming analog sound is firstly converted to digital form and then 
stored in the disk. This digital sound is not the exact replica of the original, some fidelity 
is always lost. The fidelity of the digital sound depends on the Sample Rate and Bit 
Rate. This means the higher the sampling and bit rate, the better the fidelity. 

However, higher fidelity also increases the file size, which means more data needs to 
be stored. 

• Channels: Choose from Mono and Stereo channel. Unless you are opting for a studio-
recorded sound track, Mono channel is sufficient. (During playback, the sound card 
feeds the same sound in left and right channels). Stereo recording needs to double the 
storage size as compared to Mono. 

• Bit Rate: This is the amount of compressed data needed to store one second of sound. 
The higher the bit rate you set, the better the quality and the larger the size the audio 
file has. 
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This option is only available if the MP3 audio codec is selected because 
ActivePresenter encodes the MP3 audio in constant bit rate mode. 

• Quality: ActivePresenter allows you to select a quality level between 1 (min) and 100 
(max). The higher the number you select, the better the audio quality and the larger 
the file size. 

This option is only available if the Vorbis audio codec is selected because 
ActivePresenter encodes the Vorbis audio in constant quality mode. 

Webcam Settings Section 

Choose one from two video codecs: Flash Screen Video and H.264/MPEG-4 AVC codecs. 
They are similar to the video codecs mentioned in the Video Settings section above. Refer 
to Webcam Settings for more details. Note that this section is only activated in recording 
video demos.  

Cursor Tab 

The options in the Cursor tab apply for both the cursor in recorded videos and the cursor of 
the cursor path object.  

 

The Cursor tab contains the following sections: 
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Cursor Settings Section 

• Record Mouse Cursor: It is common that you want to record the cursors in a software 
demonstration video, so this option is selected by default. If you don’t want cursors to 
appear in recorded result, deselect this check box.  

• Make Cursor Editable for Full Motion Recording: ActivePresenter allows you to edit 
the cursor highlight, mouse click sounds and effects in recorded video if this option is 
selected before recording. Deselect this option if you want the cursors to be rendered 
directly into the recorded video. 

• Exclude Layered Windows While Recording to Reduce Cursor Flickering: When 
recording videos or creating software simulations, some layered windows may appear 
on the screen. In that case, ActivePresenter will exclude those windows that you don’t 
want to record. 

Cursor Path Section 

• Real Movement: The mouse movements on screen will be recorded truthfully.  

• Simplified: The mouse movements on screen will be recorded and saved as straight 

or curved lines.  

Note that this section is only available in recording software simulations.  

Automatic Panning Section 

• Make Capture Window Follow Mouse Cursor: When this option is selected, the blue 
rectangle follows the mouse pointer around the screen. 

As long as the pointer is within the blue rectangle, the frame does not move. But when 
the mouse pointer crosses any side of the frame, the frame starts following it. 

• Panning Speed: Set the speed (in pixels/s) at which the frame will start following the 
mouse pointer.  

Note that very high speeds are unsettling for viewers, because the small blue rectangle 
presents a blinkered view to begin with, and at high pan speeds, the user won't realize 
which area of the screen you are at. 

Annotation Tab 

This tab controls the annotations and interactions that are automatically added during the 
capturing. (These are distinct from the annotations and interactions added during the editing 
of the captured project.) 

Note that the Annotations tab is only activated when you record software simulations. When 
you record video, this tab is deactivated.  
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The Annotations tab has two main sections, one for the mouse and the other for the 
keyboard.  

Both have identical options, as follows: 

Annotation: Introduce an annotation (mouse/key) that is about to occur or to guide learners 
how to operate. Annotation is usually used for demonstrating and training. 

Correct Message/Incorrect Message/Hover Message: Correct, Incorrect, and Hover 
message are feedback objects. ActivePresenter presentations can provide a feedback to 
viewers’ actions when they interact with the HTML5 (in Tutorial, Practice or Test mode; but 
not in Demonstration mode).  

• The Correct message is displayed if the user action is correct.  

• The Incorrect message is displayed if the user action is incorrect. 

• The Hover message is displayed when the user hovers the mouse over the interactive 
object (e.g. mouse click, key stroke).  

Place Annotation inside Active Window Area: Let you place all the annotations that are 
automatically added during the capture inside the Active Window area. 

Hotkeys Tab 

The Hotkeys tab lets you set the keyboard hotkeys for various functions.  
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The image below shows the Hotkeys tab when you record Software Simulations. If you record 
Video, this tab doesn’t have four last options: Manual Capture, Capture For Next Slide, Start 
Full Motion Recording, and Stop Full Motion Recording.  

 

Select the Use Hotkeys check box to enable all the options below. Otherwise, deselect it if 
you want to disable all of them. 

To change any hotkey, just click inside the box corresponding to it, and press the new 
combination of keys on your keyboard. The new combination does not take effect till you click 
the Save button. 

The Capture For Next Slide function is similar to the Manual Capture function except the 
captured screenshot will be used as background for next steps. This function may be useful 
in some circumstances, for example when you want to capture a button in the normal state, 
not in the hover state. 

The Restore Defaults button at the bottom restores all the default values. This is useful if you 
have experimented with the controls far too much and want to start over. 

To know more in details about hotkeys and how to customize it, refer to Customizing 
Hotkeys. 
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Webcam Settings Dialog  

Webcam Properties 

Video Proc Amp 

 

Drag the slider to the right or left to increase or decrease the values in this dialog.  

• Brightness: Brightness level that adjusts the amount of lighting on the image. 

• Contrast: Contrast level that adjusts the difference between brightest and dimmest 
areas in the image. 

• Hue: Hue setting that adjusts the color tint of the image through the red-yellow-blue 
spectrums. 

• Saturation: Saturation level that adjusts the amount of color in the image. 

• Sharpness: Sharpness level that adjusts the clarity of the image. 

• Gamma: Gamma measurement. 

• White Balance: Color temperature in degrees Kelvin. 

• Backlight Comp: Configure backlight compensation modes to adjust the camera to 
capture images dependent on environmental conditions. 

• Gain: A multiplier for the RGB color values. 

• ColorEnable: Specify the color enable setting. 
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Camera Control 

 

Drag the slider to the right or left to increase or decrease the values in this dialog.  

• Zoom: Control zooming, measured in millimeters. 

• Focus: Set focus, as the distance to the optimally focused target, in millimeters. 

• Exposure: Specify exposure, in log base 2 seconds. 

• Aperture (Iris): Specify iris setting, in units of f-stop x 10. 

• Pan: Control panning, measured in degrees. 

• Tilt: Control tilting, measured in degrees. 

• Roll: Control rolling, measured in degrees. 

• Low Light Compensation: Configure light compensation modes to adjust the 
camera to capture images. 
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Format Settings  

 

You can change the following settings: 

• Frame Rate:  Change the recording frame rate for webcam. A higher value will make 
the motion in the video smoother but larger file size. 

• Color Space: You can use the default value for this option. 

• Output Size: The dimension of recorded video.   
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Menus, Toolbars & Hotkeys 

ActivePresenter Main Menu 

When clicking the ActivePresenter button at the top-left corner of the application window, you 
will see the ActivePresenter Main Menu. Basically, this button is a user interface feature 
change that replaces the traditional “File” menu, commonly seen at the top of Microsoft Office 
programs.  

As described earlier, the ActivePresenter Main Menu provides access to all common file 
operations, the configuration settings, and the list of recently opened files.

Icon  Command Hotkey  Function 

 

Blank Project  

 

Create a new project with an automatically inserted 
blank slide. 

 

Record Video 
 

Record screen as a video. 

 

Record Software 
Simulation 

 

Record a software simulation. 

 

Responsive 
Project  

 
Design a new responsive project which runs 
seamlessly both on desktop and mobile devices. 

 

Import 
PowerPoint 

 

Create a new project from a PowerPoint 
presentation in your file system. 

 

Open Project...  CTRL+O Open an existing project on your computer. 

 

Save  CTRL+S Save the current project. 

 
Save As... 

 

Save the current project under a new name and 
different types. 

 
Close 

 

Close the current project. 

 
Project 

 

Click to access options relating to projects: 

Properties : See and edit some information 
about the current project. 
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Convert to Responsive Project… : Convert the 
current project to a responsive project. 

Convert to Non-Responsive Project… . 

Convert the current project to a non-responsive 
project.  

Shrink…: Make the project compact. 

Localize: Localize projects for each language. 

Reset Default Objects : Reset objects to default.  

 
Recent Projects 

 

List of recently opened projects. 

 

Preferences 

 

View and edit the global settings. 

 

Start Page 

 

Click to open the Start Page. 

 
Exit  

 

Close the ActivePresenter application. 

Quick Access Toolbar 

The Quick Access Toolbar includes a set of commands which are independent of the 
Tabbed Toolbar. This toolbar gives you a quick access to commonly used features like saving 
and opening. Note that you can’t move and add commands to the Quick Access Toolbar. 

Icon Command Hotkey  Function 

 Create Blank 
Project  

 

Create a new blank project. 

 Open Existing 
Project  

CTRL+O Open an existing project. 

 Save Changes  CTRL+S Save the current project. 

 Undo Last Action CTRL+Z Reverse the last actions. 

Click the down arrow to choose the type of action 
you want to undo.  

 Redo Last Action  CTRL+Y Restore the last “undone” actions. 
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Click the down arrow next to this button to choose 
the type of action you want to redo.  

Home Tab 

The Home tab is the first tab on the Tabbed Toolbar and selected by default whenever you 
launch ActivePresenter. It contains all common tools which allow you to insert slides, add 
shapes, manage, and format objects on your slides. 

Icon Command Hotkey Function 

 

Cut CTRL+X Cut the selected items into the clipboard. 

 

Copy CTRL+C Copy the selected items to the clipboard. 

 

Paste  CTRL+V Paste contents from the clipboard. 

Click the down arrow next to this command 
to show two types of paste: 

Paste Destination Theme : Change the 
theme properties of pasted contents 
according to the new slide which will contain 
them.  

Keep Source Formatting : Keep the 
theme properties of pasted contents similar 
to those of copied ones. 

 

New Slide 

 

Insert a new slide into your project. 

Click the down arrow next to this button to 
select a slide from the slide gallery or from 
templates. 

 

Layout 

 

Change the layout of a slide. 

You can click this button to display the 
layout gallery, and then select a layout from 
it.  

 

Reset 

 

Reset the position, size, and formatting of 
the slide placeholders to their default 
settings. 
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Record Screen 

 

Record new slides. 

Click this button to select Record Video  

or Record Software Simulation . 

 

Import Slides 

 

Import slides from images, PowerPoint 
Presentation or other ActivePresenter 
projects. 

 
Font Name 

 

Change the font name for the selected text 
or objects. 

 
Font Size 

 

Change the font size for the selected text or 
objects. 

 

Increase Font 
Size  

CTRL+] Increase the font size for the selected text 
or objects. 

 

Decrease Font 
Size 

CTRL+[ Decrease the font size for the selected text 
or objects. 

 

Remove Format 

 

Remove inline text formatting for the 
selected objects. 

 

Bold CTRL+B Make the selected text, or the text in the 
selected objects bold. 

 

Italic CTRL+I Make the selected text, or the text in the 
selected objects italic. 

 

Underline CTRL+U Underline the selected text, or the text in the 
selected objects. 

 

Strikethrough CTRL+SHIFT+S Strikethrough the selected text, or the text in 
the selected objects. 
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Text Color 

 

Change the text color for the selected text 
or objects. 

Click the down arrow to open the Color 
Picker. Do the following: 

• Select a color from the Theme 
Colors (or Standard Colors) section. 

• Click More Colors…  to define a 
color. 

• Click Eyedropper…  to pick a 
color on the screen.  

 

Highlight Color 

 

Highlight the selected text, or the text in the 
selected object. 

Click the down arrow to open the Color 
Picker. Do the following: 

• Select a color from the Theme 
Colors (or Standard Colors) section. 

• Click More Colors…  to define a 
color. 

• Click Eyedropper…  to pick a 
color on the screen.  

 

Subscript CTRL++ Format the selected text as subscript. 

 

Superscript CTRL+SHIFT++ Format the selected text as superscript. 

 

Insert Symbol 

 

Insert symbol into the editing text. 

 

Insert Hyperlink 

 

Make the selected text link to a webpage. 

 

Remove 
Hyperlink 

 

Remove the link to a webpage from the 
selected text. 

 

Numbering 

 

Add numbering to the selected text. 

 

Bullets 

 

Add bullets to the selected text. 
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Decrease Indent 

 

Increase the indent of the selected text. 

 

Increase Indent 

 

Decrease the indent of the selected text. 

 Line Spacing  

 

Adjust the amount of space between each 
line in paragraph. You can reduce the line 
spacing to fit more lines on a slide, or 
increase it to improve readability.  

ActivePresenter offers you preset spacing 
options. However, you can also click Line 
Spacing Options… to adjust the line 
spacing with even more precision.  

 

Align Text Left CTRL+L Align the selected text, or the text in the 
selected objects left. 

 

Align Text 
Center 

CTRL+E Align the selected text, or the text in the 
selected object center. 

 

Align Text Right CTRL+R Align the selected text, or the text in the 
selected objects right. 

 

Justify CTRL+J Justify the selected text, or the text in the 
selected objects. 

 

Text Vertical 
Align 

 

Change the vertical alignment of the text in 
the selected objects. 

Click this button to select one from three 
options: 

 

• Align Text Top: Align text to the top 
of the text box.  

• Align Text Middle: Align text to the 
center of the text box.  

• Align Text Bottom: Align text to the 
bottom of the text box.  

 

Shapes 

 

Add a shape to slide. 
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Click the Shapes button to select a shape 
from the shape gallery.  

 

Interactions 

 

Add an interactive object to a slide. 

Click the Interactions button to select a 
type of interactivity from the drop-down list. 
You can choose a basic interaction or a 
question.  

 

Text Caption 

 

Add a Text Caption to a slide. 

 

Arrange 
 

Click the Arrange button to display the 
following command groups: 

• Order: Change the z-order of the 
selected objects. The options 
include Bring to Front, Bring 
Forward, Send to Back, and Send 
Backward.  

• Group: Group a set of certain 
objects on a slide. There are three 
options including Group, Ungroup, 
and Add to Group. 

• Align: Use alignment options to 
align the selected objects. 

 

Quick Style 
 

Quickly set the style (fill, line, shadow, and 
text) for the selected objects. Click this 
button to display the theme style gallery. 

 

Fill 
 

Change the fill style for the selected objects. 
You can also do that by going to the 
Properties pane. See Fill section or more 
details.  

 

Line 
 

Change the line for selected objects. 

Click the down arrow to adjust the line color 
and width. Also, you can change the type of 
dash and arrow for lines. 

For more details, refer to Line section. 

 

Shadow 
 

Change the shadow for selected objects. 
Click the Shadow button to select a type of 
shadow from the preset shadow list. 
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This facility is also built in the Shadow 
section of the Properties pane. 

 

Variables 
 

Insert and edit user-defined variables. Also, 
click the System tab to show system 
variables. For more details, see Variables.  

 

Reference 
 

Create a reference to a variable. 

 

Find 
CTRL+F 

Find the occurrence of text in objects in 
specified slides. 

 

Replace 
CTRL+H 

Replace the occurrence of text by specified 
text. 

 

HTML5 Preview 
 

Click to preview HTML5. You can preview 
your working project in 4 operation modes: 
Demonstration, Tutorial, Practice, and Test.  

Slide Tab 

The Slide tab contains all buttons which make it easier for you to work with slides. Along with 
inserting slides, changing layouts, and importing slides from other sources, you can also 
modify slide backgrounds, edit Active Window, and use Batch Operations from this tab.   

Icon Name Function  

 

New Slide Insert a new slide into your project. Click the down arrow to 
select a slide from the slide gallery or templates.  

 

Layout Change the layout of a slide. Click this button to show the 
layout gallery. 

 

Reset Reset the position, size, and formatting of the slide 
placeholders to their default settings. 

 
Record Video Insert a new slide by recording screen as a video. 

 
Software 
Simulation 

Insert new slides by recording screen as a software simulation. 
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Import Images Insert images as slides (create new slides and insert images 
from file system as their background). 

 

Import 
PowerPoint 

Insert PowerPoint slides as ActivePresenter slides. 

 

Import 
ActivePresenter  

Import slides in other ActivePresenter projects to the current 
project. 

 

Random Slide  Insert a random slide. 

 

Report Slide  Insert a report slide. 

 

Save Slide As 
Image  

Export the current slide as an image. 

 

Edit 
Background 
Image 

Edit slide background. 

 

View Active 
Window  

Show/hide the Active Window area. 

 

Edit Active 
Window 

Enable/disable editing the Active Window area. 

 

Batch 
Operations 

Provide options for changing multiple objects in multiple slides 
at once. 

• Insert Objects: Select an object of any type and insert 
it in multiple slides. 

• Delete Objects: Delete objects of the selected type 
from multiple slides. 

• Convert Closed Captions To Audio: Convert closed 
captions to speech for the current slide, selected slides 
or all slides. 

• Generate Slide Name From First Shape: Find the first 
shape in slide and use its text for slide name. 
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Annotations Tab 

The Annotations tab comprises all types of annotation objects such as shapes, images, 
videos, audio, and zoom-n-pan. You can work with them to visualize your contents and attract 
the audience’s attention. 

Icon Command Function 

 

Shapes Click the Shapes button to show the shape gallery. Then, 
select one to insert in a slide. 

 

Text Caption Insert a Text Caption. 

 

Highlight Insert a Highlight. 

 

Spotlight Insert a Spotlight. 

 

Gesture Effects Insert a Gesture effects: Single Tap, Double Tap, Hold, Two 
Fingers Single Tap, Two Fingers Double Tap, Swipe Up, Swipe 
Down, Swipe Left, Swipe Right, Rotate Left, Rotate Right, 
Pinch In, Pinch Out, Fingers. 

 

Footer Insert a Footer. 

 

Image 
Insert an Image. 

 

Screenshot 
Take a Screenshot: 

• Window : Capture a window. 

• Object : Capture an object. 

• Full Screen : Capture the full screen. 

• Application or Region : Capture an application or a 
rectangular area.  

• Capture Window Shadow: Select this screenshot option 
to capture the shadow of the target window (when not 
maximized). 

• Process Rounded Corners: Select this screenshot option 
to keep rounded corners of target window (instead of sharp 
corners). 
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• Use Opaque Background: Select this screenshot option 
to use opaque border of the target window instead of 
transparent border. 

• Shadow Usage Guide: Select this screenshot option to 
show tooltip. 

 

Audio Insert an Audio. You can select one of the following options: 

• From File...: Insert an audio from file system. 

• Create New: Insert an audio object for recording or text to 
speech. 

 

Video Insert a Video. You can select one of the following options: 

• From File...: Insert a video from file system. 

• Webcam Recording: Create a new video by recording 
webcam. 

 

YouTube Insert a YouTube video. 

 

Web Object Insert a Web Object. 

 

Cursor Path Insert a Cursor Path. 

 

Zoom-n-Pan Insert a Zoom-n-Pan. 

 

Closed Caption 
Insert a Closed Caption (CC).  

Interactions Tab 

Unlike the Annotations tab, the Interactions tab includes many types of interactive objects 
which are designed to respond to user input and create professional eLearning contents.

Icon Command Function 

 

Mouse Click Insert a Mouse Click. 
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Key Stroke Insert a Key Stroke. 

 

Text Box Insert a Text Box. 

 

Drop Area Insert a Drop Area. 

 

Button  Insert a Button. 

 

Check Box Insert a Check Box. 

 

Radio Button Insert a Radio Button. 

 

True/False Insert a True/False question. 

 

Multiple Choice Insert a Multiple Choice question. 

 

Multiple 
Response 

Insert a Multiple Response question. 

 

Essay Insert an Essay question. 

 

Fill in Blank Insert a Fill in Blank question. 

 

Fill in Multiple 
Blanks 

Insert a Fill in Multiple Blanks question. 

 

Sequence Insert a Sequence question. 

 

Drag-n-Drop Insert a Drag-n-Drop question. 
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Rating Scale 
(Likert) 

Insert a Rating Scale (Likert) question. 

 

Event Show the Events - Actions section in the Properties pane. 
From here, you can insert events and corresponding actions for 
each object.  

 

Message Insert types of feedback messages, including Correct, Incorrect, 
Timeout, and Hint for the focused interactive object. If the 
focused object is an element of a question object, the message 
is inserted for the question.   

Design Tab 

The Design tab contains tools relating to the appearance of slides like Themes, Theme 
Colors, Theme Fonts, and Background Styles. Besides, you can change the slide size from 
this tab.  

Icon Command Function 

 
Design Gallery Display a list of built-in and custom themes. For more details, 

see Applying & Managing Themes. 

 

Colors Pick a built-in theme color to apply to slides or create your own. 
For more details, see Applying & Customizing Theme 
Colors. 

 

Fonts  Select a built-in theme font to apply to slides or create your 
own. For more details, see Applying & Customizing Theme 
Fonts. 

 

Background 
Styles 

Choose a built-in background style to apply to slides. A list of 
available background styles varies depending on the currently 
applied theme in selected slides. Refer to Applying 
Background Styles for more information. 

 

Slide Size Change the size of slides in the current project. For more 
details, see Changing Slide Size.  

Transitions Tab 

The Transitions tab comprises a number of slide transition effects which you can apply to 
different slides in the current project. All buttons in this tab are described as below:
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Icon Name Function 

 

Transition 
Gallery 

Display a list of built-in slide transitions. 

 

Effect Options Select a type of effect for slide transitions (Push, Wipe, Zoom, 
Cover, Uncover, and Fly Through). Note that available effect 
options depend on type of effects.  

 

Effect Duration Change the duration when an effect appears. 

 
Slide Duration Change the duration of a slide. You can enter your value or click 

the up/down arrow. 

Animations Tab 

ActivePresenter supports several types of different animation effects for objects. Using them 
is a quick way to bring any object to life and draw audience’s attention to a piece of content 
you want.  

Icon Name Function 

 

Entrance 
Effects 

Select an entrance effect for selected objects. 

 
Entrance Effect 
Options 

Select a direction for the entrance effect. 

 

Entrance Effect 
Duration 

Set the duration of the entrance effect. 

 

Exit Effects Select an exit effect for selected objects. 

 
Exit Effect 
Options 

Select a direction for the exit effect. 

 

Exit Effect 
Duration 

Set the duration of the exit effect. 

 

Start Time Specify the time in seconds when the effect is set to start 
playing. 
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Duration Set the duration of the effect in seconds. 

 

Add Animation Select a type of animation (Motion Path or Emphasis). 

Export Tab 

Once completing a project you want, go to the Export tab to export it. ActivePresenter allows 
you to export your project to eight types of output formats.

Icon Command Function 

 

Images Export slides as individual images. 

 

Video Export as a video. You can export files to many types of output 
formats, including MP4, FLV, AVI, WMV, WebM, and MKV. 

 

HTML 
SlideShow 

Export the slides as HTML SlideShow. 

 

PDF Document Export as a PDF file. 

 

Microsoft Word Export as an MS Word file. 

 

Microsoft Excel Export as MS Excel file. 

 

Microsoft 
PowerPoint 

Export as Microsoft PowerPoint file. 

 

HTML5 Export as HTML5. 

 

Player Settings Customize the layout of HTML5 exported project. 

 

HTML5 Preview Click to preview HTML5. You can preview your working project 
in 4 operation modes: Demonstration, Tutorial, Practice, and 
Test. 
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View Tab 

The View tab is highly practical when you want to view or hide a pane such as Slide Master, 
Selection, and Properties for specific purposes. Especially, the ability to hide panes can 
prevent you from being distracted by unnecessary ones and increase the work space. 

Icon Command Function 

 

Slides in 
Column 

Show slides thumbnails in the Slides pane. The slide 
thumbnails are resized automatically to fit the available width. 

 

Slides in Grid Show slide thumbnails in the Slides pane. The slide thumbnails 
have a fixed size and are displayed in grid. 

 

Slides in Titles Show slide titles in the Slides pane. 

 

Slide Master Show/hide the Slide Master pane. 

 

Timeline Show/hide the Timeline pane. 

 

Resources Show/hide the Resources pane.  

 

Properties Show/hide the Properties pane. 

 

Slides Show/hide the Slides pane. 

 

Selection Show/hide the Selection pane. 

 

Slide Pools Show/hide the Slide Pools pane. 

 

Object States Show/hide the Object States pane. 

 

Object 
Templates 

Show/hide the Object Templates pane. 
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Drag-n-Drop Show/hide the highlight rectangles of drag source and drop 
target along with the connection between them. 

 
Tab Order Specify the tab order for objects on the Canvas.   

 

Canvas 
Snapping 

Enable/disable snapping on the Canvas. 

 

Timeline 
Snapping 

Enable/disable snapping in the Timeline pane. 

 

Cursor 
Snapping 

Enable it to make cursor path move continuously between 
slides. 

 

Zoom Set the zoom level for the Canvas. 

 

Zoom Fit Automatically adjust the zoom level to fit the space of the 
Canvas. 

 

Language Click this button to choose the GUI language. 

Help Tab 

The Help tab contains many useful buttons which allow you to access some kinds of 

information and activate or deactivate ActivePresenter. Remember that most of these buttons 

(except About) are also available on the Start Page. 

Icon Command Function 

 

User Manual Launch the Help file. 

 

Product 
Homepage 

Launch the default browser to access the ActivePresenter 
homepage. 

 

Support Center Launch the default browser to access the user forum/FAQ. 



ActivePresenter User Manual  Version 7 

Menus, Toolbars & Hotkeys > View Tab  340 
 

 

Activate Product Enter the license information to activate the product, for 
example, converting Free edition to Standard or Professional 
edition. This tool is only available if you are using the Free 
edition.  

 

Deactivate 
Product 

Remove the license information to convert Standard or 
Professional edition back to Free edition. This tool is only 
available if you have already activated ActivePresenter. 

 

Check Updates Check for update on the website. 

 

About Provide information about the current version. 

Format Tab 

The Format tab is a contextual tab automatically displayed only when an object is selected. 
This is where you can customize properties of objects such as shape type, style, fill, line, and 
shadow. You can also order, group, or align objects from here.  

Icon Command Function 

 
Change Shape Change the shape of selected objects, for example, from 

rectangle to oval. 

 
Style Gallery Contain a list of built-in object styles. 

 

Fill Change the fill for selected objects. See Fill section. 

 

Line Change the line for selected objects. See Line section. 

 

Shadow Change the shadow for selected objects. See Shadow section. 

 

Order Change the order of selected objects. See Ordering Objects. 

 

Group Group selected objects in a slide. See Grouping Objects. 
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Align Align selected objects in a slide. See Aligning Objects. 

Drawing Tab 

The Drawing tab will be displayed on the screen when you click the Edit Background or Edit 
Image button. This tab consists of all basic photo editing tools you can use to modify your 
images. 

Icon Command Function 

 

Paste Paste the copied contents. 

 Cut Cut the selected contents.  

 Copy Copy the selected contents. 

 

Select 
Rectangle 

Select a rectangle for moving, deleting or copying. 

 Crop Crop the selected area. 

 Scale Image Scale image. Click this button to show the Scale Image dialog: 

 

You can specify the target width and height. If the Width/Height 
ratio is not similar to original, the image will get stretched. 

Alternatively, select the Lock ratio check box, and then specify 
only one of the dimensions. ActivePresenter will maintain the 
original aspect ratio and rescale the image.  



ActivePresenter User Manual  Version 7 

Menus, Toolbars & Hotkeys > View Tab  342 
 

The Reset button restores the original size of the image. 

The quality of the rescaled image depends on the algorithm 
used. ActivePresenter offers a choice of algorithms, including 
Box, Bilinear, Bicubic, 4th order b-spline, Catmull-Rom spline, 
and Lanczos3. 

The Box algorithm is the simplest one and usually gives the 
lowest quality. Lanczos3 is an advanced algorithm and 
commonly used in popular image editor. This algorithm also 
gives the best quality. 

However, choosing the most suitable algorithm also depends 
on the image content, so you can use try-and-error tactic to 
choose the most suitable one.  

 Insert Image Insert an Image. 

 Auto Shape Select a Shape. 

 Rotate Right 90o Rotate right. 

 Rotate Left 90o Rotate left. 

 Flip Horizontal Flip horizontally. 

 Flip Vertical Flip vertically. 

 

Antialias Enable antialiasing to draw anti-aliased lines.  

 Line Draw a line. 

 Polygon Draw a polygon. When you click at various spots, those points 
are added to the current polygon. At the last point, double-click 
to finish the polygon-creation mode. 

 Spline Draw a spline. As you click at various spots, those points are 
added to the current spline. A double-click ends the spline-
creation mode. 

 Pencil Draw freehand with the pencil. 
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 Air Brush Create spray with a color. 

 Eraser Use this tool to turn an area on the image into a transparent 
one.  

 Flood Fill Click anywhere on the image to find a contiguous area with the 
same color, and then fills it with the current pen color. 

 Text Create rich text by using the text editor. 

 Blur Blur/obfuscate the selected area. 

 
Blur Radius Specify the blur radius. The larger the radius, the more 

obfuscated the image. 

 Pen Color Select a pen color for pending or drawing later. 

 Fill Color Set the color filled inside a shape. 

 
Pen Opacity Set the opacity level for pen (0 means fully transparent, 255 

means fully opaque.) 

 
Fill Opacity Set the opacity level for fil (0 means fully transparent, 255 

means fully opaque.) 

 Pick Pen Color After selecting this tool, click any area on the image and the 
pen tool will assume that color (hue and saturation) and 
opacity. 

 Pick Fill Color After selecting this tool, click any area on the image and the fill 
color tool will assume that color (hue and saturation) and 
opacity. 

 Line Width Set the line width for the outline of a shape or for the pencil 
tool. 

 Line Style Set the type of line for the outline of a shape or for the pencil 
tool. 

 Zoom Set the zoom level for the Canvas. 
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 Zoom Fit Adjust the zoom level automatically to fit the Canvas to the 
available space. 

Slide Master Tab  

ActivePresenter has a facility to create themes. You can access this capability by going to the 
View tab and clicking Slide Master. By using the Slide Master tab, you can design your own 
slide layouts and apply them to slides in the current project or preserve them and reuse later.  

Icon Command Function 

 

Insert Slide 
Master 

Add a new Slide Master. 

 

Insert Layout  Insert a layout into an existing Slide Master. 

 

Delete Delete a Slide Master or layout. 

 

Rename Rename a Slide Master or layout. 

 

Preserve Preserve a Slide Master. 

 

Master Layout Show the Master Layout check box list.   

 

Insert 
Placeholder 

Insert a placeholder into a layout. 

 
Title Select to show the Title placeholder on slide layouts. 

 
Footers Select to show the Footers placeholder on slide layouts. 

 

Themes Display the theme gallery. From here, you can apply Themes 

to Slide Masters.  

 

Colors Display the theme color gallery. From here, you can apply 
Theme Colors to Slide Masters. 



ActivePresenter User Manual  Version 7 

Menus, Toolbars & Hotkeys > Slide Master Tab  345 
 

 

Fonts Display the theme font gallery. From here, you apply Theme 
Fonts to Slide Masters. 

 

Background 
Styles 

Display the background style gallery. From here, you can apply 
Background Styles to Slide Masters. 

 

Slide Size Change the size of slides in the current project. 

 

Close Master 
View 

Exit the Master View. 
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ActivePresenter Customization 

Customizing Language 

By default, the display language in ActivePresenter is set to English (United States). If you 
want to choose another language, select Language from the View tab, and then select your 
desired language from the drop-down list. Your change will be applied the next time you open 
the application.  

 

Another way to customize the display language is to use the Preferences dialog. Do the 
following steps: 

1. Click ActivePresenter > Preferences. 

2. In the General tab, select the appropriate language in the Program section. 

3. Click Apply to submit changes. Your change will be applied the next time you open 
the application.  

Customizing User Interface 

Showing/Hiding Panes & Toolbar 

You can make the following changes: 

• View/hide various panes (Timeline, Slides, Properties, etc.) by using the View tab. 

• Collapse the Tabbed Toolbar by using the Hide/Show Toolbar button at the top-right 
corner of the application window. 

ActivePresenter saves the project settings when you close a project. The next time you open 
the application, the settings of the last saved project will be automatically applied to the new 
one. 

Changing Pane Location 

Drag a pane from its current location by dragging its title bar or clicking its Undock button. 
Note that for the Timeline pane, you can only undock it by clicking the Undock button. 
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Remember not to release the mouse button until you find the location you want to place the 
pane. As you move the pane, you have two available options: 

• Dock the pane in the highlighted drop zones that appear on screen. By docking a pane, 
it can stand alone or together with other panes on one edge of the Canvas.  

 

• Make the pane free-floating by dragging it to an area that is not a drop zone. The 
floating pane allows you to position it anywhere on the screen, even outside the 
application window. 
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Changing Pane Size 

You can change the size of the panes that appear in ActivePresenter. This is useful when you 
want to make your work area larger by reducing the pane size, or when you want to view more 
of the information that appears in a pane by increasing its size. 

• To resize a docked pane, move the pointer over the left or right edge of the pane (for 
vertical panes) or over the top edge of the pane (for horizontal panes). When the 

pointer turns into a horizontal resize pointer  or vertical resize pointer , drag the 
boundary to resize the pane to the dimensions you want. 

• To resize a floating pane, hover over any edge or corner of the pane until the pointer 
turns into a bidirectional resize pointer, and then drag the boundary until the pane is 
the width/height you want.  

Customizing Preferences 

Use the Preferences dialog to set how you want ActivePresenter to operate. To open the 
dialog, click ActivePresenter > Preferences. 

The dialog has six tabs, each serves a different area. Select the relevant tab to change the 
relevant settings.

Tab Category  

General  General options applicable to the entire application. 

Auto Annotation 
Text 

ActivePresenter has the capability to automatically generate 
appropriate annotations from interactions. This tab controls how those 
annotations are generated.  
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Hotkeys Hotkeys used for various operations. 

Tabbed Toolbar Tabs and tools in the Tabbed Toolbar. 

Script Editor Features and colors in the JavaScript Function form. 

Miscellaneous Options that don’t fit anywhere in the above tabs. 

General Tab 

  

The options work as follows: 

Control Function 

Program 
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Display 
Language 

The drop-down list provides the choice of available languages. 

Max Recently 
Used Projects 

The spin box defines how many recently opened projects would be 
listed. Set to 0 to disable this control. 

Note that a large number is not actually useful. Instead, cultivate the 
habit of storing the project files in a hierarchical folder system so that 
you can retrieve any project fast. 

Clear List ActivePresenter will forget the actual list of recently opened projects.  

Canvas 
Background 
Color 

Use this control to change the color of the Canvas background. Click 
the button to see a palette of colors. Select any desired color. Note that 
this control only affects the Canvas inside ActivePresenter editor, it 
does not affect your projects at all.  

Reset Window 
Layout 

Reset the layout of the application to default. You need to restart the 
application so this change can take effect. 

Project 

Backup Project 
Every n minutes 

Define how frequently to back up (save) the project. In rare cases when 
ActivePresenter crashes, it will allow you to recover your last opening 
projects from the latest back-ups. Set to 0 to disable this control. 

Note that these are not permanent back-ups: Back-ups will be 
automatically removed when you close your projects. 

Project 
Language 

Set the default project language. 

Project Location This is the default folder path where all new projects will be saved. You 
are allowed to change this folder when you save a new project. 

Template 
Location 

This is the default folder path where all custom templates will be saved. 
You can change this location if needed. 

Default Project 
Size 

Set the default project size. To change the size, enter a new value or 
choose from the Preset Size list. 

Restore Defaults Go back to the original settings. 

Auto Annotation Text Tab 

This tab defines auto annotation text that is automatically added when you record software 
simulations. 
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ActivePresenter can automatically generate the text for annotation based on what you are 
interacting with while capturing. For example, when you type your User Name into a log-in 
screen, ActivePresenter can create a callout which says “Type [XXX] into User Name text 
box”. 

You can easily customize how ActivePresenter generates the annotation text while capturing. 
There are three parameters available to specify dynamic contents. Each parameter has the 
form {$XXX}, in which XXX is the parameter name: 

{$name} This is the name of the item with which you are interacting while capturing. For 
example, when you enter your name in a log-in screen, the text box may have a 
name like “User Name”. 

{$type} This is the type of the item that you are interacting with. The item types are 
provided by the Operating System. For example, you are typing in a text box, 
then the item type is “text box”. If you are clicking a button, then the item type is 
“button”. 
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{$value} This is what you are entering while capturing. If you are pressing a key, the 
value is the key that you’ve pressed. If you are entering text into a text box, then 
the value is the text you’ve entered. 

Note that the Prefix Modifiers check box is selected by default to allow using modifier keys 
(SHIFT, CTRL, and ALT) in mouse clicks and key strokes. 

Hotkeys Tab 

The Hotkeys tab shows all the hotkeys in ActivePresenter. You can assign hotkeys to 
commands or remove any hotkeys you do not want.  

All major commands are grouped functionally in a hierarchical tree. The tree consists of nodes; 
each node contains a group of related commands. To expand any node to list the commands 
or other items that it contains, click the  button on the left of it. Any hotkeys that are currently 
assigned to a command or item will be shown in the Current hotkey box on the right side of 
the dialog. 

 

To assign hotkeys: 

1. Select a command or item that you want to assign a hotkey. 

2. Click inside the New hotkey box, and then press the combination of keys that you 
want to assign. 

3. Look at the Currently assigned to box to see if the combination of keys is already 
assigned to a command or item. If the combination is already used, press a different 
combination. 
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4. Click the Add button to assign the new hotkey. 

5. Click Apply to submit changes. 

To remove hotkeys: 

1. Select a command or item that you want to remove a hotkey. 

2. Click the Remove button. 

3. Click Apply to submit changes. 

When you assign hotkeys, you can reassign a combination of keys if you want; however, in 
that case you can no longer use the combination for its original purpose. 

Example: Select the Save command in the tree view, and then press CTRL+A in the New 
hotkey box. The combination of CTRL and A is automatically captured and displayed. In fact, 
ActivePresenter detects that this hotkey is currently used by the Select All command. 

Now you have two options: Either try another hotkey (and repeat the cycle), or press the Add 
button to reassign the CTRL+A hotkey to the Save command. If you choose the second option, 
this hotkey will no longer be assigned to the Select All command. You can restore the default 
settings by clicking the Restore Defaults button. 

Tabbed Toolbar Tab 

In this tab, you can customize the Tabbed Toolbar for your interest and improve the 
performance in editing.  

The box to the left of this tab contains all commands which are organized in groups. The box 
to the right is the structure of the current toolbar of ActivePresenter. 

 

Note: You cannot reorder the default commands, hide their names, or rename them. 
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Reordering Tabs/Groups/Commands 

You can change the order of all tabs/groups/commands but not the default commands. To do 
that, in the right box, select the tab/group/command that you want to move. Then, click the 

Move Up  or Move Down  until you get the order you want. Don’t forget to click OK to 
save and see your changes. 

Removing Tabs/Groups/Commands 

In the right box, select the group (both default and custom) or tab/command (custom only) that 
you want to remove. Then, click the Remove button to exclude them from view. 

To remove the default tabs or groups/commands like the Home or Slide tab, uncheck the 
relevant check box in the right box. Note that you cannot hide contextual tabs such as Format 
and Drawing. 

Adding Tabs/Groups Back to the Toolbar 

After removing a tab/group from view, you can still add it back to the Tabbed Toolbar by: 

1. In the left box, select the tab that you want to bring back. In case you want to recover 
group, you must select a tab in the right box to place it. 

2. Click the Add button to retrieve the selected tab/group. After that, change the tab/group 
order if needed. 

3. Click OK to save and see your changes. 

Creating Custom Tabs/Groups 

ActivePresenter lets you add new tabs to the Tabbed Toolbar. Add new groups to both default 
and custom tabs. Regarding commands, it only allows you to add commands to custom 
groups. 

The custom tabs and group have the word (Custom) after their names, but this word doesn’t 
appear in the Tabbed Toolbar. 

To create custom tabs/groups, perform the following (ignore any unnecessary steps if any): 

1. In the right box, select the tab to which you want to add a new group. In case you want 
to create a tab, the new tab with be inserted below all other tabs or the selected one. 

2. Click New Tab… or New Group… to create a new tab or group, respectively. 

3. In the dialog, enter a name for the new tab/group and click OK. 

4. For custom groups, select Hide Command Labels to hide the labels while showing 
the icons in smaller size. 

5. In the main dialog, click OK to save and see your changes. 

After creating a custom group, you need to add commands to them. Use the Add button to 
add commands from the left box. 

Renaming Tabs/Groups/Commands 

You can rename both default and custom tabs and groups, but for commands, you can only 
rename the ones added to custom groups. For those included in default groups, you cannot 
rename them. 
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If your experiments go haywire, you can always restore to the defaults by pressing the Restore 
Defaults button. All your customization will be removed. 

Script Editor Tab 

In this tab, you can customize coding preferences such as code formatting and coloring. 

The tab has three parts. The Color box to the left shows the color of the editor components. 
The View box in the center lists some code view options. The Preview box to the right allows 
you to preview the coding contents. 

  

To change the color of the editor components, click the color rectangle next to the component 
in the component list, and then select a color in the Color Picker. All changes you make are 
immediately reflected in the preview editor on the right side. 

To change the code view options: 

• Line Number: Select to display line numbers along the side of the code. 

• View White Space: Select to display dots in place of white space. 

• Auto Insert (), {}, []: Selected by default. This option automatically inserts matching 
closing brackets to the code. 

If your experiments go haywire, you can always restore to the defaults by pressing the Restore 
Defaults button. All your customization will be removed. 
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Miscellaneous Tab 

This tab is a “catch-all” tab: It contains application options that could not be placed in other 
tabs. 

 

Control Function 

Automatic Updates 

Automatically Check 
for Updates 

Selected by default. ActivePresenter will periodically check for 
updates when started. 

Connection Settings To connect to the Internet, ActivePresenter needs the 
connection settings. 
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When you click this button, a dialog appears and offers the 
following options: 

• No proxy 

• Use system settings (default) 

• Manual configuration 

Check with your admin and set the values. 

Log Settings 

Enable Logging Selected by default. If you disable this option, no logs will be 
kept. 

Log UI Level Select the log level that will be displayed. Only log messages 
which have severity level that is higher or equal to the selected 
level will be displayed. The other logs will be written to the log 
file silently. 

Verbose Mode In verbose mode, more details are captured. This is better for 
troubleshooting. 

Log Level There are five levels: 

1. Fatal Error (most severe level) 

2. Error 

3. Warning 

4. Message 

5. Status 

6. Information 

If you select any level, the log will be kept of that level and 
higher levels (if any). 

For example, selecting Warning will keep a log of the top three 
types of problems, but selecting Fatal Error will keep a log of 
fatal errors only. 

View Log Click this button to show the log file. The log file is automatically 
cleared and started over when its size reaches 2 MB. 

Confirmation Settings 

Warning none-ANSI 
path when export  

Selected by default. When you export your project, there are 
some outputs that cannot be opened or run properly if the file 
name contains non-ANSI characters. This option specifies 
whether ActivePresenter should ask you in such case or not. 
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Show language 
confirmation when 
importing XLIFF 

Selected by default. When you import from XLIFF, chances are 
the target language is unspecified or invalid. ActivePresenter will 
show a language confirmation to let you select a target language 
to continue. 

Extend object duration 
to match the duration 
of generated audio 

Select any of the choices to determine how ActivePresenter 
performs when converting text to speech: Should 
ActivePresenter display the dialog so you can make further 
changes to the TTS settings before converting? 

Save external resource  

Link resources with file 
size greater than n MB 

When a resource is added to a project, ActivePresenter creates 
a copy of the resource file and stores it in that project (to ensure 
that even if you rename, move, or delete the original file, the 
inserted item will not be affected). 

But if the original file is large, storing it directly in the project will 
consume more disk space than necessary, which severely 
reduces the performance and prones to errors that might corrupt 
the project. 

In that case, ActivePresenter doesn’t store the original file 
directly in the project. Instead, ActivePresenter maintains its own 
copy of the original file and creates a link in the project which 
points to its own copy. 

This parameter defines the threshold above which 
ActivePresenter will create a link to the resource instead of 
storing the original file directly in the project. 

Use software rendering 
instead of GPU 
rendering 

This option may improve performance for some computers 
which have a strong CPU but a weak GPU. 

Use Direct3D for 
recording screen 

Uncheck this option if you cannot capture the screen due to 
graphics driver-related issues. 

Use JPEG color range 
(full range) when 
exporting video 

Check to fix the “white color turns to grey” issue when viewing 
output videos on some systems. 

 

 

Last updated: 2018/02/13 
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